aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTatsuki Makino <tatsuki_makino@hotmail.com>2021-10-24 20:16:58 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2021-10-24 20:17:04 +0000
commit74451a1660699281ac43c0673e8c7560dee653b8 (patch)
treeb1777a0b979493b19496aa213f8297375460d0ea
parent34197c5c60d360ad5af37c3e8aaf4d18176d4f3b (diff)
downloadports-74451a1660699281ac43c0673e8c7560dee653b8.tar.gz
ports-74451a1660699281ac43c0673e8c7560dee653b8.zip
audio/libamrnb: Makefile adjustment
Adjust Makefile to follow Porter's Handbook and framework more closely, also pet portclippy while at it. PR: 259202 Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D32621
-rw-r--r--audio/libamrnb/Makefile14
-rw-r--r--audio/libamrnb/distinfo1
-rw-r--r--audio/libamrnb/pkg-descr2
3 files changed, 9 insertions, 8 deletions
diff --git a/audio/libamrnb/Makefile b/audio/libamrnb/Makefile
index 05929e6430ad..9250f5e91d15 100644
--- a/audio/libamrnb/Makefile
+++ b/audio/libamrnb/Makefile
@@ -1,13 +1,13 @@
# Created by: Tatsuki Makino <tatsuki_makino@hotmail.com>
PORTNAME= libamrnb
-PORTVERSION= 11.0.0.0
-PORTREVISION= 1
+DISTVERSION= 11.0.0.0
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= audio
MASTER_SITES= http://www.penguin.cz/~utx/ftp/amr/ \
- http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/:SRC26104
-DISTNAME= amrnb-${DISTVERSION}
+ https://www.3gpp.org/ftp/Specs/archive/26_series/26.104/:SRC26104
+DISTNAME= amrnb-${DISTVERSIONFULL}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SRC26104}:SRC26104
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -20,15 +20,15 @@ LICENSE_COMB= multi
LICENSE_NAME_3GPP= 3GPP
LICENSE_TEXT_3GPP= unclear legal status, probably need licenses from 3GPP and more
LICENSE_PERMS_3GPP= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
-LICENSE_DISTFILES_BSD3CLAUSE= ${DISTNAME}${EXTRACT_SUFX}
LICENSE_DISTFILES_3GPP= ${SRC26104}
+LICENSE_DISTFILES_BSD3CLAUSE= ${DISTNAME}${EXTRACT_SUFX}
-USES= gmake tar:bzip2 libtool
+USES= autoreconf gmake tar:bzip2 libtool
+USE_LDCONFIG= yes
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
-USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
diff --git a/audio/libamrnb/distinfo b/audio/libamrnb/distinfo
index bd01c083ebe5..6f277661b42f 100644
--- a/audio/libamrnb/distinfo
+++ b/audio/libamrnb/distinfo
@@ -1,3 +1,4 @@
+TIMESTAMP = 1632279600
SHA256 (libamrnb/amrnb-11.0.0.0.tar.bz2) = 3890004b665278b963ecaae2dc1321dcee29c53ea9d91aaf18d9286105e0f1e1
SIZE (libamrnb/amrnb-11.0.0.0.tar.bz2) = 244917
SHA256 (libamrnb/26104-b00.zip) = 23df8b24b0f009783027b8eef5fa8225ec71f859f2704bdb06829f09018cc8f1
diff --git a/audio/libamrnb/pkg-descr b/audio/libamrnb/pkg-descr
index c5499a57b792..bf57a496e2bc 100644
--- a/audio/libamrnb/pkg-descr
+++ b/audio/libamrnb/pkg-descr
@@ -3,7 +3,7 @@
3GPP released reference implementation of 3GPP Adaptive Multi-Rate
Floating-point (AMR) Speech Codec (3GPP TS 26.104).
-http://www.3gpp.org/ftp/Specs/html-info/26104.htm
+https://www.3gpp.org/ftp/Specs/html-info/26104.htm
This package converts 3GPP TS 26.104 reference implementation of AMR-NB to a
shared library.