aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-07 10:05:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-07 10:06:16 +0000
commit75a27d29f88d0e8fe22c538748cf6f500d0c1c1b (patch)
treeb7b26fd1ee97f819fa7c42e4a931225dab9746e8
parenta135085d0ab085b1c221cfb6343e845264e5dd4c (diff)
downloadports-75a27d29f88d0e8fe22c538748cf6f500d0c1c1b.tar.gz
ports-75a27d29f88d0e8fe22c538748cf6f500d0c1c1b.zip
misc/py-histoprint: New port: Pretty printing of histograms to the console
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-histoprint/Makefile26
-rw-r--r--misc/py-histoprint/distinfo3
-rw-r--r--misc/py-histoprint/pkg-descr10
4 files changed, 40 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 95c2ec66f9ae..1dbe785ac433 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -387,6 +387,7 @@
SUBDIR += py-gluoncv
SUBDIR += py-gluonnlp
SUBDIR += py-halo
+ SUBDIR += py-histoprint
SUBDIR += py-huepy
SUBDIR += py-kartograph
SUBDIR += py-log_symbols
diff --git a/misc/py-histoprint/Makefile b/misc/py-histoprint/Makefile
new file mode 100644
index 000000000000..fbb40bde00bf
--- /dev/null
+++ b/misc/py-histoprint/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= histoprint
+DISTVERSION= 2.4.0
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pretty printing of histograms to the console
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=7.0.0:devel/py-click@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uhi>=0.2.1:misc/py-uhi@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/py-histoprint/distinfo b/misc/py-histoprint/distinfo
new file mode 100644
index 000000000000..cdc3ab414335
--- /dev/null
+++ b/misc/py-histoprint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659855148
+SHA256 (histoprint-2.4.0.tar.gz) = 328f789d186e3bd76882d57b5aad3fa08c7870a856cc83bcdbad9f4aefbda94d
+SIZE (histoprint-2.4.0.tar.gz) = 359154
diff --git a/misc/py-histoprint/pkg-descr b/misc/py-histoprint/pkg-descr
new file mode 100644
index 000000000000..676047f7795f
--- /dev/null
+++ b/misc/py-histoprint/pkg-descr
@@ -0,0 +1,10 @@
+histoprint is a package for pretty print of NumPy (and other) histograms to the
+console.
+
+Histoprint uses a mix of terminal color codes and Unicode trickery (i.e.
+combining characters) to plot overlaying histograms. Some terminals are not able
+to display Unicode combining characters correctly. Histoprint can still be used
+in those terminals, but the character set needs to be constrained to the
+non-combining ones.
+
+WWW: https://github.com/scikit-hep/histoprint