aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-04 11:49:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-04 11:50:54 +0000
commit76810a270cfe9319a06506159d1ccb37802f1cd3 (patch)
tree7b7a299f30eaed13a8a410b0509e802c60faaa80
parenta41f63c03eae513377384519d8d75eaf0b95e226 (diff)
downloadports-76810a270cfe9319a06506159d1ccb37802f1cd3.tar.gz
ports-76810a270cfe9319a06506159d1ccb37802f1cd3.zip
lang/solidity: Disable CVC4 option because the project doesn't yet support CVC5
-rw-r--r--lang/solidity/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/solidity/Makefile b/lang/solidity/Makefile
index e9b571eba936..c2ff2ade047d 100644
--- a/lang/solidity/Makefile
+++ b/lang/solidity/Makefile
@@ -1,5 +1,6 @@
PORTNAME= solidity
PORTVERSION= 0.8.17
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -22,14 +23,15 @@ USES= cmake compiler:c++14-lang cpe
CPE_VENDOR= ${PORTNAME}lang
OPTIONS_DEFINE= Z3 CVC4
-OPTIONS_DEFAULT=Z3 CVC4
+OPTIONS_DEFAULT=Z3 #CVC4
OPTIONS_EXCLUDE_i386= Z3
Z3_DESC= SMT Checker via Z3
CVC4_DESC= SMT Checker via CVC4
Z3_LIB_DEPENDS= libz3.so:math/z3
-CVC4_LIB_DEPENDS= libcvc4.so:math/cvc4 libgmp.so:math/gmp
+CVC4_LIB_DEPENDS= libcvc5.so:math/cvc5 libgmp.so:math/gmp
Z3_CMAKE_OFF= USE_Z3
CVC4_CMAKE_OFF= USE_CVC4
+CVC4_BROKEN= solidity uses cvc4 which has been succeeded by cvc5
CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
-DRANGE_V3_INCLUDE_DIR="${LOCALBASE}/include" \