aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-26 17:05:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-26 17:44:06 +0000
commit768d017078a6a3e1ccadbd3f67e429ab8628b305 (patch)
treece0f48d47160ddd3f23752ddd2fd4e5086d95b4d
parent6283f5a043f5175099e10b96d35b34268a9eb458 (diff)
downloadports-768d017078a6a3e1ccadbd3f67e429ab8628b305.tar.gz
ports-768d017078a6a3e1ccadbd3f67e429ab8628b305.zip
devel/flatbuffers: Update 2.0.0 -> 2.0.5
-rw-r--r--devel/flatbuffers/Makefile11
-rw-r--r--devel/flatbuffers/distinfo6
-rw-r--r--devel/flatbuffers/pkg-plist16
3 files changed, 22 insertions, 11 deletions
diff --git a/devel/flatbuffers/Makefile b/devel/flatbuffers/Makefile
index 38a88d5e373d..1a5e1eb0a166 100644
--- a/devel/flatbuffers/Makefile
+++ b/devel/flatbuffers/Makefile
@@ -2,7 +2,7 @@
PORTNAME= flatbuffers
DISTVERSIONPREFIX= v
-DISTVERSION= 2.0.0
+DISTVERSION= 2.0.5
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= Memory efficient serialization library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake compiler:c++11-lib cpe
+USES= cmake:testing compiler:c++11-lib cpe python:build
CPE_VENDOR= google
USE_LDCONFIG= yes
@@ -20,11 +20,8 @@ GH_ACCOUNT= google
CMAKE_ON= FLATBUFFERS_BUILD_SHAREDLIB
CMAKE_OFF= FLATBUFFERS_BUILD_FLATLIB FLATBUFFERS_BUILD_TESTS
+CMAKE_TESTING_ON= FLATBUFFERS_BUILD_TESTS # one test fails, see https://github.com/google/flatbuffers/issues/7009
-do-test:
- @cd ${BUILD_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DFLATBUFFERS_BUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${TEST_TARGET}
+BINARY_ALIAS= git=false python3=${PYTHON_CMD}
.include <bsd.port.mk>
diff --git a/devel/flatbuffers/distinfo b/devel/flatbuffers/distinfo
index ce9e50e2b40b..6dc071823e33 100644
--- a/devel/flatbuffers/distinfo
+++ b/devel/flatbuffers/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620746822
-SHA256 (google-flatbuffers-v2.0.0_GH0.tar.gz) = 9ddb9031798f4f8754d00fca2f1a68ecf9d0f83dfac7239af1311e4fd9a565c4
-SIZE (google-flatbuffers-v2.0.0_GH0.tar.gz) = 1538022
+TIMESTAMP = 1643215699
+SHA256 (google-flatbuffers-v2.0.5_GH0.tar.gz) = b01e97c988c429e164c5c7df9e87c80007ca87f593c0d73733ba536ddcbc8f98
+SIZE (google-flatbuffers-v2.0.5_GH0.tar.gz) = 1671969
diff --git a/devel/flatbuffers/pkg-plist b/devel/flatbuffers/pkg-plist
index fb71915c5830..82c5f777939d 100644
--- a/devel/flatbuffers/pkg-plist
+++ b/devel/flatbuffers/pkg-plist
@@ -1,6 +1,14 @@
bin/flatc
+include/flatbuffers/allocator.h
+include/flatbuffers/array.h
include/flatbuffers/base.h
+include/flatbuffers/bfbs_generator.h
+include/flatbuffers/buffer.h
+include/flatbuffers/buffer_ref.h
include/flatbuffers/code_generators.h
+include/flatbuffers/default_allocator.h
+include/flatbuffers/detached_buffer.h
+include/flatbuffers/flatbuffer_builder.h
include/flatbuffers/flatbuffers.h
include/flatbuffers/flatc.h
include/flatbuffers/flexbuffers.h
@@ -14,7 +22,13 @@ include/flatbuffers/reflection.h
include/flatbuffers/reflection_generated.h
include/flatbuffers/registry.h
include/flatbuffers/stl_emulation.h
+include/flatbuffers/string.h
+include/flatbuffers/struct.h
+include/flatbuffers/table.h
include/flatbuffers/util.h
+include/flatbuffers/vector.h
+include/flatbuffers/vector_downward.h
+include/flatbuffers/verifier.h
lib/cmake/flatbuffers/FlatbuffersConfig.cmake
lib/cmake/flatbuffers/FlatbuffersConfigVersion.cmake
lib/cmake/flatbuffers/FlatbuffersSharedTargets-%%CMAKE_BUILD_TYPE%%.cmake
@@ -23,5 +37,5 @@ lib/cmake/flatbuffers/FlatcTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/flatbuffers/FlatcTargets.cmake
lib/libflatbuffers.so
lib/libflatbuffers.so.2
-lib/libflatbuffers.so.2.0.0
+lib/libflatbuffers.so.2.0.5
libdata/pkgconfig/flatbuffers.pc