aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:13:45 +0000
commit78d77a7c97a7f41485b3225a923b16cdd6205169 (patch)
tree309a4df7481c59dc2010487251175d68b48195a7
parent7f9480c704826bce8020a898e57695f78e0bd811 (diff)
downloadports-78d77a7c97a7f41485b3225a923b16cdd6205169.tar.gz
ports-78d77a7c97a7f41485b3225a923b16cdd6205169.zip
sysutils/socket: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--sysutils/socket/Makefile2
-rw-r--r--sysutils/socket/files/patch-globals.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/socket/Makefile b/sysutils/socket/Makefile
index 7d275dfd2e24..b464edd10a0c 100644
--- a/sysutils/socket/Makefile
+++ b/sysutils/socket/Makefile
@@ -1,6 +1,6 @@
PORTNAME= socket
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils net
MASTER_SITES= https://wolfram.schneider.org/src/ LOCAL/wosch
diff --git a/sysutils/socket/files/patch-globals.h b/sysutils/socket/files/patch-globals.h
new file mode 100644
index 000000000000..0ad1ee77f125
--- /dev/null
+++ b/sysutils/socket/files/patch-globals.h
@@ -0,0 +1,11 @@
+--- globals.h.orig
++++ globals.h
+@@ -48,7 +48,7 @@
+ void strip_crs A((char *from, char *to, int *sizep)) ;
+ void background A((void)) ;
+
+-extern int errno ;
++#include <errno.h>
+
+ /* global variables */
+ extern int serverflag ;