aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-05-24 11:55:14 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-05-29 11:16:33 +0000
commit78e416d826472fd8eca9f3cf702e171914443273 (patch)
tree793c689f5941bfd3cd0d5cd485400048269b9a7c
parenta2238beaf0ba23b62277efb17f74fb8ee7b7b9ef (diff)
downloadports-78e416d826472fd8eca9f3cf702e171914443273.tar.gz
ports-78e416d826472fd8eca9f3cf702e171914443273.zip
devel/py-qt5-pyqt: add DBus dependency
This makes DBus explicitly available when installing py-qt5-pyqt, which is good for desktop use. Previously, building this with DBus installed **and** pkgconfig and the Python DBus bindings would trip up in `check-plist`. PR: 261717 Reported by: John Hein
-rw-r--r--devel/py-qt5-pyqt/Makefile7
-rw-r--r--devel/py-qt5-pyqt/pkg-plist1
2 files changed, 6 insertions, 2 deletions
diff --git a/devel/py-qt5-pyqt/Makefile b/devel/py-qt5-pyqt/Makefile
index db2e44c94202..7c14685624a4 100644
--- a/devel/py-qt5-pyqt/Makefile
+++ b/devel/py-qt5-pyqt/Makefile
@@ -11,9 +11,12 @@ COMMENT= Python bindings for the Qt5 toolkit, QtCore module
PYQT_DIST= yes
-LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
+LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5 \
+ libdbus-1.so:devel/dbus
+BUILD_DEPENDS+= py${PYTHON_SUFFIX}-dbus>1:devel/py-dbus
+RUN_DEPENDS+= py${PYTHON_SUFFIX}-dbus>1:devel/py-dbus
-USES= python:3.8+ pyqt:5 qt:5
+USES= pkgconfig python:3.8+ pyqt:5 qt:5
USE_PYTHON= concurrent flavors py3kplist
USE_PYQT= qtbuilder sip pysip
USE_QT= connectivity core dbus declarative designer gui help imageformats location \
diff --git a/devel/py-qt5-pyqt/pkg-plist b/devel/py-qt5-pyqt/pkg-plist
index c33979fc53d7..077accfe8021 100644
--- a/devel/py-qt5-pyqt/pkg-plist
+++ b/devel/py-qt5-pyqt/pkg-plist
@@ -4,6 +4,7 @@ bin/pyuic5
%%PYQT_APIDIR%%/PyQt5.api
%%PYQT_DESIGNERDIR%%/libpyqt5.so
%%PYQT_QMLDIR%%/libpyqt5qmlplugin.so
+%%PYTHON_SITELIBDIR%%/dbus/mainloop/pyqt5.abi%%PYTHON_MAJOR_VER%%.so
%%PYTHON_SITELIBDIR%%/PyQt5-%%PYQT_PYQTVERSION%%.dist-info/INSTALLER
%%PYTHON_SITELIBDIR%%/PyQt5-%%PYQT_PYQTVERSION%%.dist-info/METADATA
%%PYTHON_SITELIBDIR%%/PyQt5-%%PYQT_PYQTVERSION%%.dist-info/RECORD