aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-01 18:50:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-01 18:50:08 +0000
commit790a53bad21ef482acc13a36265785a548c2baaa (patch)
tree894b7a161c5490658ce01d89765f7036d9ca4d12
parentb731af4a0d2f41d3b52a1a04a1821862b6cff626 (diff)
downloadports-790a53bad21ef482acc13a36265785a548c2baaa.tar.gz
ports-790a53bad21ef482acc13a36265785a548c2baaa.zip
graphics/fotoxx: update the port to version 23.1
When disabling needless CXXFLAGS pollution, simply guard the Makefile part with an unset variable instead of removing all the code, this simplifies the patch and (hopefully) makes it more robust against future changes. Reported by: portscout
-rw-r--r--graphics/fotoxx/Makefile2
-rw-r--r--graphics/fotoxx/distinfo6
-rw-r--r--graphics/fotoxx/files/patch-Makefile44
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.cc6
-rw-r--r--graphics/fotoxx/pkg-plist1
5 files changed, 20 insertions, 39 deletions
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
index 306197694bce..0211030edb33 100644
--- a/graphics/fotoxx/Makefile
+++ b/graphics/fotoxx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fotoxx
-PORTVERSION= 23.0
+PORTVERSION= 23.1
CATEGORIES= graphics
MASTER_SITES= https://kornelix.net/downloads/downloads/
diff --git a/graphics/fotoxx/distinfo b/graphics/fotoxx/distinfo
index 52982493ab33..37042b8b235a 100644
--- a/graphics/fotoxx/distinfo
+++ b/graphics/fotoxx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1672669839
-SHA256 (fotoxx-23.0.tar.gz) = 7629edde4053ea6ebb815e84f5717e32982ad2c2ef0d00412c9719294f5122d7
-SIZE (fotoxx-23.0.tar.gz) = 9258345
+TIMESTAMP = 1675202410
+SHA256 (fotoxx-23.1.tar.gz) = 2043daedac89d5826699ff2833e6e697caad707ae174bebb9470e21b692312c1
+SIZE (fotoxx-23.1.tar.gz) = 9198469
diff --git a/graphics/fotoxx/files/patch-Makefile b/graphics/fotoxx/files/patch-Makefile
index 9e8d9f64bc29..893519013c6e 100644
--- a/graphics/fotoxx/files/patch-Makefile
+++ b/graphics/fotoxx/files/patch-Makefile
@@ -1,39 +1,21 @@
---- Makefile.orig 2022-08-01 12:52:28 UTC
+--- Makefile.orig 2023-01-31 21:43:57 UTC
+++ Makefile
-@@ -1,40 +1,12 @@
+@@ -1,5 +1,6 @@
# fotoxx Makefile
--#
--# export CXX=g++ gnu compiler
--# export CXX=clang++ clang compiler
--# export DEBUG=x debug build with address checking
+ #
++ifdef WANT_EXTRA_CXXFLAGS
+ # export CXX=g++ gnu compiler
+ # export CXX=clang++ clang compiler
+ # export DEBUG=x debug build with address checking
+@@ -28,6 +29,7 @@ else # GCC
+ CXXFLAGS += -Wall -g2 -rdynamic -O2 -Wno-format-truncation -Wno-stringop-truncation
+ endif
+ endif
++endif
--
--# Try to fix warning from champlain-tile.h but none of this works
--# CXXFLAGS += -D GTimeVal=GDateTime
--# MAKEDIR:=$(shell dirname $(realpath $(firstword $(MAKEFILE_LIST))))
--# CXXFLAGS += -I $(MAKEDIR)
--
--
--ifeq ($(CXX), clang++) # CLANG
-- ifdef DEBUG
-- CXXFLAGS += -Wall -g -O0 -fsanitize=address -Wno-stringop-truncation
-- LDFLAGS += -fsanitize=address
-- else
-- CXXFLAGS += -Wall -g -O2
-- endif
--else # GCC
-- ifdef DEBUG
-- CXXFLAGS += -Wall -g2 -rdynamic -O0 -fsanitize=address \
-- -Wno-format-truncation -Wno-stringop-truncation
-- LDFLAGS += -fsanitize=address
-- else
-- CXXFLAGS += -Wall -g2 -rdynamic -O2 -Wno-format-truncation -Wno-stringop-truncation
-- endif
--endif
--
PKG_CONFIG ?= pkg-config
- CFLAGS = $(CXXFLAGS) $(CPPFLAGS) -c \
+@@ -35,7 +37,7 @@ CFLAGS = $(CXXFLAGS) $(CPPFLAGS) -c
`$(PKG_CONFIG) --cflags gtk+-3.0 --libs champlain-gtk-0.12`
LIBS = `$(PKG_CONFIG) --libs gtk+-3.0` \
diff --git a/graphics/fotoxx/files/patch-zfuncs.cc b/graphics/fotoxx/files/patch-zfuncs.cc
index ccd16436e512..116014da25a0 100644
--- a/graphics/fotoxx/files/patch-zfuncs.cc
+++ b/graphics/fotoxx/files/patch-zfuncs.cc
@@ -141,9 +141,9 @@
*********************************************************************************/
- int zfind(cchar *pattern, char **&flist, int &NF)
+ int zfind(ch *pattern, ch **&flist, int &NF)
{
- char **zfind_filelist = 0; // list of filespecs returned
+ ch **zfind_filelist = 0; // list of filespecs returned
+#ifdef GLOB_PERIOD
int globflags = GLOB_PERIOD; // include dotfiles
+#else
@@ -151,7 +151,7 @@
+#endif
int ii, jj, err, cc;
glob_t globdata;
- char *pp;
+ ch *pp;
@@ -5805,9 +5850,16 @@ int zinitapp(cchar *appvers, int argc, char *argv[])
if (argc > 1 && strmatchV(argv[1],"-ver","-v",0)) exit(0); // exit if nothing else wanted
diff --git a/graphics/fotoxx/pkg-plist b/graphics/fotoxx/pkg-plist
index 0dc28fa3e115..498e96fc3cfc 100644
--- a/graphics/fotoxx/pkg-plist
+++ b/graphics/fotoxx/pkg-plist
@@ -295,7 +295,6 @@ share/applications/fotoxx.desktop
%%DATADIR%%/images/rotate.jpg
%%DATADIR%%/images/saturation.jpg
%%DATADIR%%/images/save.png
-%%DATADIR%%/images/search-images-metadata.jpg
%%DATADIR%%/images/search-images.jpg
%%DATADIR%%/images/select-area-finish.jpg
%%DATADIR%%/images/select-area.jpg