aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-25 19:06:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-25 20:40:25 +0000
commit799d6652eda8f2843adf1383bb4969dd86d6bf9d (patch)
treeb38a0ac6cc79436b3a8b87c0d51826f399d50c81
parent1e5aaab3fc82a054d429caefe5374607f6db12e1 (diff)
deve/py-pytest-parallel: New port: Pytest plugin for parallel and concurrent testing
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-parallel/Makefile24
-rw-r--r--devel/py-pytest-parallel/distinfo3
-rw-r--r--devel/py-pytest-parallel/pkg-descr2
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a167e923b47a..dc445d542f75 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5135,6 +5135,7 @@
SUBDIR += py-pytest-mutagen
SUBDIR += py-pytest-mypy
SUBDIR += py-pytest-nunit
+ SUBDIR += py-pytest-parallel
SUBDIR += py-pytest-pep8
SUBDIR += py-pytest-plus
SUBDIR += py-pytest-profiling
diff --git a/devel/py-pytest-parallel/Makefile b/devel/py-pytest-parallel/Makefile
new file mode 100644
index 000000000000..9fdac0a4633a
--- /dev/null
+++ b/devel/py-pytest-parallel/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= pytest-parallel
+DISTVERSION= 0.1.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pytest plugin for parallel and concurrent testing
+WWW= https://github.com/browsertron/pytest-parallel
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tblib>0:devel/py-tblib@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils pytest # many tests fail, see https://github.com/browsertron/pytest-parallel/issues/115
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-parallel/distinfo b/devel/py-pytest-parallel/distinfo
new file mode 100644
index 000000000000..378a75957149
--- /dev/null
+++ b/devel/py-pytest-parallel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664131953
+SHA256 (pytest-parallel-0.1.1.tar.gz) = 9aac3fc199a168c0a8559b60249d9eb254de7af58c12cee0310b54d4affdbfab
+SIZE (pytest-parallel-0.1.1.tar.gz) = 9547
diff --git a/devel/py-pytest-parallel/pkg-descr b/devel/py-pytest-parallel/pkg-descr
new file mode 100644
index 000000000000..de5ea671ce5a
--- /dev/null
+++ b/devel/py-pytest-parallel/pkg-descr
@@ -0,0 +1,2 @@
+The pytest-parallel plugin makes it possible to run tests quickly using
+multiprocessing (parallelism) and multithreading (concurrency).