aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDerek Schrock <dereks@lifeofadishwasher.com>2022-02-14 05:23:36 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2022-02-14 05:23:36 +0000
commit79aa6d906518b8718c84473e630c1b438b1fb429 (patch)
tree72c40b2e0e689d74bc019d7308845e9d8ff5bcd3
parent4931bb0fd929c4b9aa3501dfca4ac14bb5c6e764 (diff)
mail/mutt: Update to 2.2.0
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt/distinfo6
-rw-r--r--mail/mutt/files/extra-patch-ifdef14
-rw-r--r--mail/mutt/files/extra-patch-maildir-mtime6
-rw-r--r--mail/mutt/files/extra-patch-reverse_reply32
-rw-r--r--mail/mutt/files/extra-patch-smartdate4
-rw-r--r--mail/mutt/files/extra-smime-sender10
-rw-r--r--mail/mutt/files/patch-date-conditional10
-rw-r--r--mail/mutt/files/patch-dgc-deepif6
9 files changed, 46 insertions, 44 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index c985519f4550..dd358d7fed5e 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -1,7 +1,7 @@
# Created by: Udo Schweigert
PORTNAME= mutt
-DISTVERSION= 2.1.5
+DISTVERSION= 2.2.0
CATEGORIES+= mail
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
https://bitbucket.org/mutt/mutt/downloads/ \
diff --git a/mail/mutt/distinfo b/mail/mutt/distinfo
index 422b2d7a41e0..6bce2b16bcc2 100644
--- a/mail/mutt/distinfo
+++ b/mail/mutt/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1640911132
-SHA256 (mutt/mutt-2.1.5.tar.gz) = 92a309e47e363a97d62425bcb71adceae5ab5c4c413dbcac37fa98ed70c12be0
-SIZE (mutt/mutt-2.1.5.tar.gz) = 5414049
+TIMESTAMP = 1644704304
+SHA256 (mutt/mutt-2.2.0.tar.gz) = e84597f06d03ca82f8ca3b5ec8bc294c150709b43ed2a0177bf479c3e3345314
+SIZE (mutt/mutt-2.2.0.tar.gz) = 5503348
SHA256 (mutt/mutt-2.1.0.vc.greeting) = d43686bbd88539c7b50cc198d15c146f579af344c26b83c4018c50f65f5c6dac
SIZE (mutt/mutt-2.1.0.vc.greeting) = 2003
SHA256 (mutt/patch-1.13.0.vvv.initials.xz) = 8b25ad6596bd57d94f6551e7e73ceb8da620468e96fb507b2f51545d5b3eaa02
diff --git a/mail/mutt/files/extra-patch-ifdef b/mail/mutt/files/extra-patch-ifdef
index c0416b81c705..477c82f88186 100644
--- a/mail/mutt/files/extra-patch-ifdef
+++ b/mail/mutt/files/extra-patch-ifdef
@@ -1,10 +1,10 @@
---- PATCHES.orig 2021-06-13 21:49:46 UTC
+--- PATCHES.orig 2022-02-12 23:46:24 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.4.cd.ifdef.1
---- init.c.orig 2021-05-26 22:40:56 UTC
+--- init.c.orig 2022-01-25 19:33:16 UTC
+++ init.c
-@@ -678,6 +678,52 @@ static mbchar_table *parse_mbchar_table (const char *s
+@@ -715,6 +715,52 @@ static mbchar_table *parse_mbchar_table (const char *s
return t;
}
@@ -20,7 +20,7 @@
+ if (!(res = (mutt_option_index (tmp->data) != -1)))
+ for (i = 0; !res && i < MENU_MAX; i++)
+ {
-+ const struct binding_t *b = km_get_table (Menus[i].value);
++ const struct menu_func_op_t *b = km_get_table (Menus[i].value);
+
+ if (!b)
+ continue;
@@ -57,9 +57,9 @@
static int parse_unignore (BUFFER *buf, BUFFER *s, union pointer_long_t udata, BUFFER *err)
{
do
---- init.h.orig 2021-06-13 21:49:46 UTC
+--- init.h.orig 2022-02-12 23:46:24 UTC
+++ init.h
-@@ -4787,6 +4787,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
+@@ -4926,6 +4926,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
static int parse_unlists (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_alias (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_unalias (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
@@ -67,7 +67,7 @@
static int parse_echo (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_ignore (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_unignore (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
-@@ -4854,6 +4855,7 @@ const struct command_t Commands[] = {
+@@ -4993,6 +4994,7 @@ const struct command_t Commands[] = {
{ "hdr_order", parse_list, {.p=&HeaderOrderList} },
#ifdef HAVE_ICONV
{ "iconv-hook", mutt_parse_hook, {.l=MUTT_ICONVHOOK} },
diff --git a/mail/mutt/files/extra-patch-maildir-mtime b/mail/mutt/files/extra-patch-maildir-mtime
index 722eb952383a..0047da9e24dc 100644
--- a/mail/mutt/files/extra-patch-maildir-mtime
+++ b/mail/mutt/files/extra-patch-maildir-mtime
@@ -1,8 +1,8 @@
---- PATCHES.orig 2021-06-13 21:49:47 UTC
+--- PATCHES.orig 2022-02-12 23:46:24 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.7.ust.maildir-mtime.2
---- browser.c.orig 2021-05-23 18:20:50 UTC
+--- browser.c.orig 2022-01-25 19:33:16 UTC
+++ browser.c
@@ -32,6 +32,7 @@
#ifdef USE_IMAP
@@ -42,7 +42,7 @@
if (tmp && Context && !tmp->nopoll &&
!mutt_strcmp (tmp->realpath, Context->realpath))
{
-@@ -680,6 +697,7 @@ static int examine_mailboxes (MUTTMENU *menu, struct b
+@@ -684,6 +701,7 @@ static int examine_mailboxes (MUTTMENU *menu, struct b
s.st_mtime = st2.st_mtime;
}
diff --git a/mail/mutt/files/extra-patch-reverse_reply b/mail/mutt/files/extra-patch-reverse_reply
index ada407240849..35efc80cec42 100644
--- a/mail/mutt/files/extra-patch-reverse_reply
+++ b/mail/mutt/files/extra-patch-reverse_reply
@@ -1,10 +1,10 @@
---- PATCHES.orig 2021-06-13 21:49:47 UTC
+--- PATCHES.orig 2022-02-12 23:46:24 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.6.cb.reverse_reply.2
---- init.h.orig 2021-06-13 21:49:46 UTC
+--- init.h.orig 2022-02-12 23:46:24 UTC
+++ init.h
-@@ -3322,6 +3322,13 @@ struct option_t MuttVars[] = {
+@@ -3430,6 +3430,13 @@ struct option_t MuttVars[] = {
** In either case, a missing real name will be filled in afterwards
** using the value of $$realname.
*/
@@ -15,12 +15,12 @@
+ ** headers of reply mails you send, like $reverse_alias does in the index.
+ ** When unset, the headers taken from the original mail are left unchanged.
+ */
- { "rfc2047_parameters", DT_BOOL, R_NONE, {.l=OPTRFC2047PARAMS}, {.l=0} },
+ { "rfc2047_parameters", DT_BOOL, R_NONE, {.l=OPTRFC2047PARAMS}, {.l=1} },
/*
** .pp
---- mutt.h.orig 2021-06-13 21:49:46 UTC
+--- mutt.h.orig 2022-02-12 23:46:24 UTC
+++ mutt.h
-@@ -525,6 +525,7 @@ enum
+@@ -533,6 +533,7 @@ enum
OPTREVALIAS,
OPTREVNAME,
OPTREVREAL,
@@ -28,32 +28,32 @@
OPTRFC2047PARAMS,
OPTSAVEADDRESS,
OPTSAVEEMPTY,
---- protos.h.orig 2021-05-23 18:20:51 UTC
+--- protos.h.orig 2022-02-09 20:12:23 UTC
+++ protos.h
-@@ -85,6 +85,7 @@ char* mutt_extract_message_id (const char *, const cha
+@@ -86,6 +86,7 @@ char* mutt_extract_message_id (const char *, const cha
ADDRESS *mutt_get_address (ENVELOPE *, char **);
ADDRESS *mutt_lookup_alias (const char *s);
ADDRESS *mutt_remove_duplicates (ADDRESS *);
+ADDRESS *mutt_reverse_address (ADDRESS *);
+ ADDRESS *mutt_remove_adrlist_group_delimiters (ADDRESS *);
ADDRESS *mutt_expand_aliases (ADDRESS *);
ADDRESS *mutt_parse_adrlist (ADDRESS *, const char *);
-
---- send.c.orig 2021-05-28 19:33:58 UTC
+--- send.c.orig 2022-01-15 20:43:36 UTC
+++ send.c
-@@ -739,6 +739,10 @@ void mutt_fix_reply_recipients (ENVELOPE *env)
+@@ -744,6 +744,10 @@ void mutt_fix_reply_recipients (ENVELOPE *env)
/* the CC field can get cluttered, especially with lists */
env->to = mutt_remove_duplicates (env->to);
env->cc = mutt_remove_duplicates (env->cc);
+ if (option (OPTREVREPLY)){
-+ env->to = mutt_reverse_address (env->to);
-+ env->cc = mutt_reverse_address (env->cc);
++ env->to = mutt_reverse_address (env->to);
++ env->cc = mutt_reverse_address (env->cc);
+ }
env->cc = mutt_remove_xrefs (env->to, env->cc);
if (env->cc && !env->to)
---- sendlib.c.orig 2021-05-23 18:20:51 UTC
+--- sendlib.c.orig 2022-01-22 23:36:22 UTC
+++ sendlib.c
-@@ -3044,6 +3044,35 @@ static void set_noconv_flags (BODY *b, short flag)
+@@ -3093,6 +3093,37 @@ static void set_noconv_flags (BODY *b, short flag)
}
}
@@ -86,6 +86,8 @@
+ return addr;
+}
+
++
++
int mutt_write_fcc (const char *path, SEND_CONTEXT *sctx, const char *msgid, int post, const char *fcc)
{
HEADER *hdr;
diff --git a/mail/mutt/files/extra-patch-smartdate b/mail/mutt/files/extra-patch-smartdate
index 4b707194df7e..40ce4ca583d7 100644
--- a/mail/mutt/files/extra-patch-smartdate
+++ b/mail/mutt/files/extra-patch-smartdate
@@ -1,4 +1,4 @@
---- hdrline.c.orig 2021-06-13 21:49:46 UTC
+--- hdrline.c.orig 2022-02-12 23:46:24 UTC
+++ hdrline.c
@@ -249,6 +249,89 @@ static char *apply_subject_mods (ENVELOPE *env)
* %Y = `x-label:' field (if present, tree unfolded, and != parent's x-label)
@@ -105,7 +105,7 @@
if (!do_locales)
setlocale (LC_TIME, "");
---- mutt.h.orig 2021-06-13 21:49:47 UTC
+--- mutt.h.orig 2022-02-12 23:46:24 UTC
+++ mutt.h
@@ -168,6 +168,16 @@ typedef enum
MUTT_WRITE_HEADER_MIME
diff --git a/mail/mutt/files/extra-smime-sender b/mail/mutt/files/extra-smime-sender
index 243fdc38f030..99aa1a45254c 100644
--- a/mail/mutt/files/extra-smime-sender
+++ b/mail/mutt/files/extra-smime-sender
@@ -1,4 +1,4 @@
---- commands.c.orig 2021-05-23 18:20:50 UTC
+--- commands.c.orig 2021-09-08 11:03:24 UTC
+++ commands.c
@@ -302,7 +302,7 @@ int mutt_display_message (HEADER *cur)
{
@@ -9,9 +9,9 @@
mutt_message ( _("S/MIME signature successfully verified."));
else
mutt_error ( _("S/MIME certificate owner does not match sender."));
---- init.h.orig 2021-06-13 21:49:47 UTC
+--- init.h.orig 2022-02-12 23:46:24 UTC
+++ init.h
-@@ -3819,6 +3819,15 @@ struct option_t MuttVars[] = {
+@@ -3927,6 +3927,15 @@ struct option_t MuttVars[] = {
** to determine the key to use. It will ask you to supply a key, if it can't find one.
** (S/MIME only)
*/
@@ -27,9 +27,9 @@
{ "smime_self_encrypt_as", DT_SYN, R_NONE, {.p="smime_default_key"}, {.p=0} },
{ "smime_default_key", DT_STR, R_NONE, {.p=&SmimeDefaultKey}, {.p=0} },
/*
---- mutt.h.orig 2021-06-13 21:49:47 UTC
+--- mutt.h.orig 2022-02-12 23:46:24 UTC
+++ mutt.h
-@@ -609,6 +609,7 @@ enum
+@@ -617,6 +617,7 @@ enum
OPTSMIMEISDEFAULT,
OPTSMIMESELFENCRYPT,
OPTASKCERTLABEL,
diff --git a/mail/mutt/files/patch-date-conditional b/mail/mutt/files/patch-date-conditional
index 3144ba5bf621..35bf404ed230 100644
--- a/mail/mutt/files/patch-date-conditional
+++ b/mail/mutt/files/patch-date-conditional
@@ -1,8 +1,8 @@
---- PATCHES.orig 2021-06-13 21:49:47 UTC
+--- PATCHES.orig 2022-02-12 23:46:24 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.0.ats.date_conditional.1
---- hdrline.c.orig 2021-06-13 21:49:47 UTC
+--- hdrline.c.orig 2022-02-12 23:46:24 UTC
+++ hdrline.c
@@ -428,6 +428,53 @@ hdr_format_str (char *dest,
const char *cp;
@@ -58,9 +58,9 @@
p = dest;
---- muttlib.c.orig 2021-05-23 18:20:51 UTC
+--- muttlib.c.orig 2021-12-30 20:58:19 UTC
+++ muttlib.c
-@@ -1677,7 +1677,16 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1681,7 +1681,16 @@ void mutt_FormatString (char *dest, /* output buffer
if (*src == '?')
{
flags |= MUTT_FORMAT_OPTIONAL;
@@ -78,7 +78,7 @@
}
else
{
-@@ -1693,12 +1702,12 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1697,12 +1706,12 @@ void mutt_FormatString (char *dest, /* output buffer
count++;
}
*cp = 0;
diff --git a/mail/mutt/files/patch-dgc-deepif b/mail/mutt/files/patch-dgc-deepif
index 7f1515b6aefe..a91d183f5f90 100644
--- a/mail/mutt/files/patch-dgc-deepif
+++ b/mail/mutt/files/patch-dgc-deepif
@@ -1,6 +1,6 @@
---- muttlib.c.orig 2021-06-13 21:49:47 UTC
+--- muttlib.c.orig 2022-02-12 23:46:24 UTC
+++ muttlib.c
-@@ -1720,6 +1720,12 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1724,6 +1724,12 @@ void mutt_FormatString (char *dest, /* output buffer
count = 0;
while (count < sizeof (ifstring) && *src && *src != '?' && *src != '&')
{
@@ -13,7 +13,7 @@
*cp++ = *src++;
count++;
}
-@@ -1732,7 +1738,13 @@ void mutt_FormatString (char *dest, /* output buffer
+@@ -1736,7 +1742,13 @@ void mutt_FormatString (char *dest, /* output buffer
count = 0;
while (count < sizeof (elsestring) && *src && *src != '?')
{