aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 15:00:25 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 18:01:10 +0000
commit79cb9f7b2d242a72d7fefd09e68bf0f92d6f97e8 (patch)
tree6579d09f1bc8138571dd00ee871c868365a77b81
parent654b28e1df871df5dd5f9ceae3f42d973229f3b3 (diff)
downloadports-79cb9f7b2d242a72d7fefd09e68bf0f92d6f97e8.tar.gz
ports-79cb9f7b2d242a72d7fefd09e68bf0f92d6f97e8.zip
games/avp: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--games/avp/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/games/avp/Makefile b/games/avp/Makefile
index dfd871f34e56..f4b74cceb1c5 100644
--- a/games/avp/Makefile
+++ b/games/avp/Makefile
@@ -20,6 +20,12 @@ LDFLAGS_i386= -Wl,-znotext
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} \
${STAGEDIR}${PREFIX}/bin/