aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-03-10 22:49:41 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-03-10 22:49:41 +0000
commit79f8f9c8f54b8de3d324d30ce9a19649bbe69e69 (patch)
tree1580de617e0e18fa9d9e22b6eff4cc8053511475
parent4747a5be5b7e9758b7a7c7b50093613115cfbf12 (diff)
downloadports-79f8f9c8f54b8de3d324d30ce9a19649bbe69e69.tar.gz
ports-79f8f9c8f54b8de3d324d30ce9a19649bbe69e69.zip
*/*: convert Makefile patches to MAKE_ARGS after "Move man pages to share/man"
Replaced patches for Makefiles with "MAKE_ARGS+=MANDIR=${PREFIX}/share/man" Reported by: danfe, mat Approved by: portmgr (blanket)
-rw-r--r--net/mpd5/Makefile2
-rw-r--r--net/mpd5/files/patch-doc_Makefile11
-rw-r--r--ports-mgmt/dialog4ports/Makefile2
-rw-r--r--ports-mgmt/dialog4ports/files/patch-Makefile8
-rw-r--r--security/unix-selfauth-helper/Makefile2
-rw-r--r--security/unix-selfauth-helper/files/patch-Makefile11
-rw-r--r--sysutils/lmmon/Makefile2
-rw-r--r--sysutils/lmmon/files/patch-Makefile.in11
-rw-r--r--sysutils/pftop/Makefile2
-rw-r--r--sysutils/pftop/files/patch-Makefile11
10 files changed, 10 insertions, 52 deletions
diff --git a/net/mpd5/Makefile b/net/mpd5/Makefile
index 705406f0ba6a..d7e05072dd64 100644
--- a/net/mpd5/Makefile
+++ b/net/mpd5/Makefile
@@ -14,6 +14,8 @@ LICENSE= BSD3CLAUSE
USES= cpe
+MAKE_ARGS+= MANDIR=${PREFIX}/share/man/man
+
CPE_VENDOR= mpd_project
OPTIONS_DEFINE= DOCS NG_IPACCT RADIUS
diff --git a/net/mpd5/files/patch-doc_Makefile b/net/mpd5/files/patch-doc_Makefile
deleted file mode 100644
index fe713858648c..000000000000
--- a/net/mpd5/files/patch-doc_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.orig 2020-09-06 14:33:02 UTC
-+++ doc/Makefile
-@@ -13,7 +13,7 @@ MPD_DOC_FILES+= mpd*.html
- MPD_DOC_FILES+= mpd.ps
-
- MAN8= mpd5.8
--MANDIR= ${PREFIX}/man/man
-+MANDIR= ${PREFIX}/share/man/man
-
- depend:
-
diff --git a/ports-mgmt/dialog4ports/Makefile b/ports-mgmt/dialog4ports/Makefile
index e8167ac67393..3858acd7b3ab 100644
--- a/ports-mgmt/dialog4ports/Makefile
+++ b/ports-mgmt/dialog4ports/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD2CLAUSE
USES= uidfix
+MAKE_ARGS+= MAN1DIR=${PREFIX}/share/man/man1
+
# CCACHE has options, so may need d4p, make d4p not ccache friendly
# to avoid circular dependency
NO_CCACHE= yes
diff --git a/ports-mgmt/dialog4ports/files/patch-Makefile b/ports-mgmt/dialog4ports/files/patch-Makefile
index 66827294bd3a..642df2acd2ce 100644
--- a/ports-mgmt/dialog4ports/files/patch-Makefile
+++ b/ports-mgmt/dialog4ports/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig 2016-07-08 14:49:08 UTC
+++ Makefile
-@@ -5,10 +5,15 @@ RM?= rm
+@@ -5,7 +5,12 @@ RM?= rm
MAN= ${PROG}.1.gz
PROG= dialog4ports
CFLAGS+= -Wall -pedantic
@@ -13,8 +13,4 @@
+LDADD+= -lm
PREFIX?= /usr/local
BINDIR= ${PREFIX}/bin
--MAN1DIR= ${PREFIX}/man/man1
-+MAN1DIR= ${PREFIX}/share/man/man1
- BSD_INSTALL_PROGRAM?= install -m 0555
- BSD_INSTALL_DATA?= install -m 0444
-
+ MAN1DIR= ${PREFIX}/man/man1
diff --git a/security/unix-selfauth-helper/Makefile b/security/unix-selfauth-helper/Makefile
index 0205a4391eef..9273cdff3650 100644
--- a/security/unix-selfauth-helper/Makefile
+++ b/security/unix-selfauth-helper/Makefile
@@ -12,6 +12,8 @@ LICENSE= BSD2CLAUSE
USES= tar:xz
+MAKE_ARGS+= MANDIR=${PREFIX}/share/man/man
+
PLIST_FILES= etc/pam.d/unix-selfauth \
libexec/unix-selfauth-helper \
share/man/man8/unix-selfauth-helper.8.gz
diff --git a/security/unix-selfauth-helper/files/patch-Makefile b/security/unix-selfauth-helper/files/patch-Makefile
deleted file mode 100644
index 3c97ad8f1a76..000000000000
--- a/security/unix-selfauth-helper/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2023-07-13 18:59:16 UTC
-+++ Makefile
-@@ -9,7 +9,7 @@ BINMODE= 4555
- DIRS+= MAN8DIR
- MAN= ${PROG}.8
- MAN8= ${MAN}
--MANDIR= ${PREFIX}/man/man
-+MANDIR= ${PREFIX}/share/man/man
- MAN8DIR= ${MANDIR}8
-
- CONFS= unix-selfauth
diff --git a/sysutils/lmmon/Makefile b/sysutils/lmmon/Makefile
index 60467ba561e7..1e20f4f4dc43 100644
--- a/sysutils/lmmon/Makefile
+++ b/sysutils/lmmon/Makefile
@@ -11,7 +11,7 @@ LICENSE= BSD2CLAUSE
USES= ncurses uidfix
GNU_CONFIGURE= yes
-MAKE_ARGS+= LDFLAGS="${LDFLAGS} -lncurses"
+MAKE_ARGS+= LDFLAGS="${LDFLAGS} -lncurses" MANDIR=${PREFIX}/share/man/man
ONLY_FOR_ARCHS= i386 amd64
diff --git a/sysutils/lmmon/files/patch-Makefile.in b/sysutils/lmmon/files/patch-Makefile.in
deleted file mode 100644
index 6846b4ece712..000000000000
--- a/sysutils/lmmon/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 1999-11-02 13:33:30 UTC
-+++ Makefile.in
-@@ -9,7 +9,7 @@ SRCS= lmmon.c
-
- PREFIX= @prefix@
- BINDIR= $(PREFIX)/bin
--MANDIR= $(PREFIX)/man/man
-+MANDIR= $(PREFIX)/share/man/man
-
- PROG= lmmon
- MAN8= lmmon.8
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index db045837aed4..13f7bf3f98a5 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -21,7 +21,7 @@ ALTQ_DESC= ALTQ support for queue statistics
.include <bsd.port.options.mk>
-MAKE_ARGS= LOCALBASE="${PREFIX}"
+MAKE_ARGS= LOCALBASE="${PREFIX}" MANDIR=${PREFIX}/share/man/man
CFLAGS+= -DHAVE_SNPRINTF=1 -DHAVE_VSNPRINTF=1
diff --git a/sysutils/pftop/files/patch-Makefile b/sysutils/pftop/files/patch-Makefile
deleted file mode 100644
index 33dccc89d8fe..000000000000
--- a/sysutils/pftop/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2023-11-13 12:00:08 UTC
-+++ Makefile
-@@ -13,7 +13,7 @@ MAN= pftop.8
- CFLAGS+= -Wall -Wno-unneeded-internal-declaration -DOS_LEVEL=${OSLEVEL}
- LDADD+= -L${LOCALBASE}/lib -lcurses -lpfctl
-
--MANDIR=${LOCALBASE}/man/man
-+MANDIR=${LOCALBASE}/share/man/man
- BINDIR=${LOCALBASE}/sbin
-
- .y.c: