aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-28 23:09:22 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-28 23:26:34 +0000
commit7ae57c39257d8456f5cf5f1902e82c5a55f8f73d (patch)
treeb4ecf1af1fd2104189606784bf5575d44bd4daf3
parent40159dc4fb5273245b90cf57e0b0d5ccd2925a71 (diff)
downloadports-7ae57c39257d8456f5cf5f1902e82c5a55f8f73d.tar.gz
ports-7ae57c39257d8456f5cf5f1902e82c5a55f8f73d.zip
print/py-glyphsets: Add py-glyphsets 0.2.1
glyphsets helps evaluate coverage of glyph sets in font projects If you are a font developer or typeface designer, see the "Lib/glyphsets/encodings/GF Glyph Sets" subdirectory which provides glyph set definition "standards" that are typically useful sets to draw. On the other hand, the nam files on the "Lib/glyphsets/encodings" directory are probably more useful for expert web developers. Those files explain how the Unicode Range subsets are defined, typically per script (writing system), in the Google Fonts css API. WWW: https://github.com/googlefonts/glyphsets
-rw-r--r--print/Makefile1
-rw-r--r--print/py-glyphsets/Makefile29
-rw-r--r--print/py-glyphsets/distinfo3
-rw-r--r--print/py-glyphsets/files/patch-setup.py20
-rw-r--r--print/py-glyphsets/pkg-descr12
5 files changed, 65 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 7a06889f0f29..b29cdf29114b 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -181,6 +181,7 @@
SUBDIR += py-fonttools
SUBDIR += py-fpdf
SUBDIR += py-frescobaldi
+ SUBDIR += py-glyphsets
SUBDIR += py-glyphtools
SUBDIR += py-pdf
SUBDIR += py-pdf2
diff --git a/print/py-glyphsets/Makefile b/print/py-glyphsets/Makefile
new file mode 100644
index 000000000000..d400293413eb
--- /dev/null
+++ b/print/py-glyphsets/Makefile
@@ -0,0 +1,29 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= glyphsets
+PORTVERSION= 0.2.1
+DISTVERSIONPREFIX= v
+CATEGORIES= print python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python API for evaluating coverage of glyph sets in font projects
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=4:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fonttools>=0:print/py-fonttools@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+GH_ACCOUNT= googlefonts
+USE_GITHUB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/print/py-glyphsets/distinfo b/print/py-glyphsets/distinfo
new file mode 100644
index 000000000000..8ad4359a2074
--- /dev/null
+++ b/print/py-glyphsets/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643382486
+SHA256 (googlefonts-glyphsets-v0.2.1_GH0.tar.gz) = dab3c915f1137eb5a16ea22b679b9e1408d1184134946b1905d90268fe46fe82
+SIZE (googlefonts-glyphsets-v0.2.1_GH0.tar.gz) = 1265612
diff --git a/print/py-glyphsets/files/patch-setup.py b/print/py-glyphsets/files/patch-setup.py
new file mode 100644
index 000000000000..dfecdc954a3b
--- /dev/null
+++ b/print/py-glyphsets/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig 2021-12-17 07:16:14 UTC
++++ setup.py
+@@ -24,7 +24,7 @@ with open('README.md') as f:
+
+ setup(
+ name="glyphsets",
+- use_scm_version={"write_to": "Lib/glyphsets/_version.py"},
++ use_scm_version={"fallback_version": "%%PORTVERSION%%", "write_to": "Lib/glyphsets/_version.py"},
+ url='https://github.com/googlefonts/glyphsets/',
+ description='A python API for evaluating coverage of glyph sets in font projects.',
+ long_description=long_description,
+@@ -52,7 +52,7 @@ setup(
+ 'Programming Language :: Python :: 3'
+ ],
+ python_requires=">=3.7",
+- setup_requires=['setuptools_scm>=4,<6.1'],
++ setup_requires=['setuptools_scm>=4'],
+ install_requires=[
+ 'setuptools',
+ 'FontTools[ufo]',
diff --git a/print/py-glyphsets/pkg-descr b/print/py-glyphsets/pkg-descr
new file mode 100644
index 000000000000..95dcb19d7041
--- /dev/null
+++ b/print/py-glyphsets/pkg-descr
@@ -0,0 +1,12 @@
+glyphsets helps evaluate coverage of glyph sets in font projects
+
+If you are a font developer or typeface designer, see the
+"Lib/glyphsets/encodings/GF Glyph Sets" subdirectory which provides glyph set
+definition "standards" that are typically useful sets to draw.
+
+On the other hand, the nam files on the "Lib/glyphsets/encodings" directory are
+probably more useful for expert web developers. Those files explain how the
+Unicode Range subsets are defined, typically per script (writing system), in the
+Google Fonts css API.
+
+WWW: https://github.com/googlefonts/glyphsets