aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-01-08 02:51:53 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-01-08 02:51:53 +0000
commit7b0210d18c1e01935e60be8e3987c969f54283a0 (patch)
tree5da9eaa2e0694df28b45a93447bc86ef208d3ad4
parentfa73e6b7884b10336c35d56b4d402e37e2d386a0 (diff)
downloadports-7b0210d18c1e01935e60be8e3987c969f54283a0.tar.gz
ports-7b0210d18c1e01935e60be8e3987c969f54283a0.zip
category/port: science/cdf
- Bump portrevision of dependent port graphics/opendx.
-rw-r--r--graphics/opendx/Makefile2
-rw-r--r--science/cdf/Makefile14
-rw-r--r--science/cdf/distinfo5
-rw-r--r--science/cdf/files/patch-Makefile36
-rw-r--r--science/cdf/files/patch-src_include_cdfdist.h11
-rw-r--r--science/cdf/files/patch-src_include_cdflib.h4
-rw-r--r--science/cdf/files/patch-src_tests_Makefile6
-rw-r--r--science/cdf/pkg-plist10
8 files changed, 63 insertions, 25 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index db04c9ddcbf9..207725ea7181 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -2,7 +2,7 @@
PORTNAME= opendx
PORTVERSION= 4.4.4
-PORTREVISION= 33
+PORTREVISION= 34
CATEGORIES= graphics math java
MASTER_SITES= http://www.sfr-fresh.com/unix/misc/
DISTNAME= dx-${PORTVERSION}
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index b28618d5e5a1..1798ffba19fe 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -1,11 +1,9 @@
# Created by: Thierry Thomas <thierry@pompo.net>
PORTNAME= cdf3
-PORTVERSION= 3.3.0
-PORTREVISION= 13
+PORTVERSION= 3.8.0
CATEGORIES= science
-MASTER_SITES= LOCAL/thierry/${PORTNAME} \
- ftp://cdaweb.gsfc.nasa.gov/pub/cdf/dist/cdf${VER}/unix/
+MASTER_SITES= https://spdf.gsfc.nasa.gov/pub/software/cdf/dist/cdf38_0/
DISTNAME= cdf${VER}-dist-cdf
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
@@ -21,7 +19,7 @@ BROKEN_aarch64= fails to compile: error: use of undeclared identifier FP1ZEROsi
BROKEN_armv6= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
BROKEN_armv7= fails to compile: error: use of undeclared identifier FP1ZEROsingle; did you mean FP1zeroSingle?
-USES= fortran ncurses
+USES= fortran ncurses gmake
USE_LDCONFIG= yes
MAKE_FLAGS= INSTALLDIR=${STAGEDIR}${PREFIX} OS=freebsd ENV=gnu \
FORTRAN=yes FC_freebsd=${F77}
@@ -39,6 +37,8 @@ PORTDOCS= CDF_copyright.txt CHANGES.txt Release.notes Welcome.txt
OPTIONS_DEFINE= DOCS EXAMPLES
+MAKE_ARGS+= OS=freebsd ENV=gnu all
+
post-patch:
.for def in ${DEFS}
@${REINPLACE_CMD} -e 's|<path>|${PREFIX}|' \
@@ -46,13 +46,11 @@ post-patch:
.endfor
post-install:
- ${MV} ${STAGEDIR}${PREFIX}/lib/libcdf.so \
- ${STAGEDIR}${PREFIX}/lib/libcdf.so.0
- ${LN} -sf libcdf.so.0 ${STAGEDIR}${PREFIX}/lib/libcdf.so
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
${SED} -i '' 's,${STAGEDIR},,g' ${STAGEDIR}${PREFIX}/bin/definitions.?
+ ${RM} -f ${STAGEDIR}${PREFIX}/CDFLeapSeconds.txt
.include <bsd.port.mk>
diff --git a/science/cdf/distinfo b/science/cdf/distinfo
index 976cb58de1dd..29df170e422b 100644
--- a/science/cdf/distinfo
+++ b/science/cdf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cdf3-3.3.0/cdf33_0-dist-cdf.tar.gz) = 2cb49e9c0d282cdd3737c55df3df0f4b62bb701a07ecfa11c5372a0416bfa81f
-SIZE (cdf3-3.3.0/cdf33_0-dist-cdf.tar.gz) = 985719
+TIMESTAMP = 1641605085
+SHA256 (cdf3-3.8.0/cdf38_0-dist-cdf.tar.gz) = 30a8bc22819791717c0e58ade52cfc1c41c6b5e45a0314718e322874d99fe078
+SIZE (cdf3-3.8.0/cdf38_0-dist-cdf.tar.gz) = 1251571
diff --git a/science/cdf/files/patch-Makefile b/science/cdf/files/patch-Makefile
index bbdabded187a..6205a62a5b89 100644
--- a/science/cdf/files/patch-Makefile
+++ b/science/cdf/files/patch-Makefile
@@ -1,24 +1,44 @@
---- Makefile.orig 2009-05-13 14:17:26 UTC
+--- Makefile.orig 2020-12-09 21:33:32 UTC
+++ Makefile
-@@ -601,14 +601,14 @@ RANLIB_freebsd=yes
+@@ -47,7 +47,7 @@
+
+ .SILENT:
+
+-SHELL=/bin/bash
++SHELL=${LOCALBASE}/bin/bash
+ NULL=true
+ PART=all
+ TARGET=
+@@ -102,6 +102,9 @@ else
+ MAKE=make
+ endif
+ endif
++ifeq ("$(OS)","freebsd")
++ MAKE=gmake
++endif
+ RANLIB=ranlib
+
+ WHICHOS=$(shell uname)
+@@ -747,15 +750,15 @@ RANLIB_freebsd=yes
FC_freebsd=f77
CURSES_freebsd_gnu=yes
-CC_freebsd_gnu=gcc
-LD_freebsd_gnu=gcc
-LDOPTIONS_freebsd_gnu=-shared
-+CC_freebsd_gnu=$(CC)
-+LD_freebsd_gnu=$(CC)
++CC_freebsd_gnu=${CC}
++LD_freebsd_gnu=${CC}
+LDOPTIONS_freebsd_gnu=-shared -Wl,-soname,libcdf.so.0
PIC_freebsd_gnu=-fPIC
-COPTIONS_freebsd_gnu=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DMALLOC_CHECK_=0
++COPTIONS_freebsd_gnu=${CFLAGS} -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DMALLOC_CHECK_=0
+ COPTIONSZlib_freebsd_gnu=-DHAVE_STDARG_H -DHAVE_UNISTD_H
-COPTIONSld_freebsd_gnu=
-FOPTIONS_freebsd_gnu=
-FOPTIONSld_freebsd_gnu=
-+COPTIONS_freebsd_gnu=$(CFLAGS) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DMALLOC_CHECK_=0
-+COPTIONSld_freebsd_gnu=$(LDFLAGS)
-+FOPTIONS_freebsd_gnu=$(FFLAGS)
-+FOPTIONSld_freebsd_gnu=$(LDFLAGS)
++COPTIONSld_freebsd_gnu=${LDFLAGS}
++FOPTIONS_freebsd_gnu=${FFLAGS}
++FOPTIONSld_freebsd_gnu=${LDFLAGS}
CURSESLIB_freebsd_gnu=-lncurses
SYSLIBSexe_freebsd_gnu=-lm -lc
SYSLIBSshr_freebsd_gnu=-lm -lc
diff --git a/science/cdf/files/patch-src_include_cdfdist.h b/science/cdf/files/patch-src_include_cdfdist.h
new file mode 100644
index 000000000000..6e3d27a36448
--- /dev/null
+++ b/science/cdf/files/patch-src_include_cdfdist.h
@@ -0,0 +1,11 @@
+--- src/include/cdfdist.h.orig 2022-01-08 02:20:38 UTC
++++ src/include/cdfdist.h
+@@ -567,7 +567,7 @@ typedef sChar sByte;
+ # if defined(__DARWIN_64_BIT_INO_T)
+ # define STAT stat
+ # else
+-# define STAT stat64
++# define STAT stat
+ # endif
+ # endif
+ # endif
diff --git a/science/cdf/files/patch-src_include_cdflib.h b/science/cdf/files/patch-src_include_cdflib.h
index cf0878f2eab6..5628e139984d 100644
--- a/science/cdf/files/patch-src_include_cdflib.h
+++ b/science/cdf/files/patch-src_include_cdflib.h
@@ -1,6 +1,6 @@
---- src/include/cdflib.h.orig 2009-05-12 12:37:37 UTC
+--- src/include/cdflib.h.orig 2019-10-16 16:22:18 UTC
+++ src/include/cdflib.h
-@@ -375,8 +375,7 @@
+@@ -401,8 +401,7 @@
#elif defined(unix) && !defined(AIX) && !defined(Mach) && !defined(hpux) || \
defined(__MINGW32__)
# if (defined(linux) && !defined(__ICC)) || defined(__CYGWIN__) || \
diff --git a/science/cdf/files/patch-src_tests_Makefile b/science/cdf/files/patch-src_tests_Makefile
index a24ac2704728..8861eee8e1a4 100644
--- a/science/cdf/files/patch-src_tests_Makefile
+++ b/science/cdf/files/patch-src_tests_Makefile
@@ -1,6 +1,6 @@
---- src/tests/Makefile.orig 2009-05-12 18:09:12 UTC
+--- src/tests/Makefile.orig 2019-10-16 16:22:18 UTC
+++ src/tests/Makefile
-@@ -33,16 +33,16 @@
+@@ -40,17 +40,17 @@
SHELL=/bin/sh
NULL=true
@@ -14,6 +14,7 @@
-COPTIONSld=
-SYSLIBS=
-SHAREDEXT=
+-MAKE=make
+#FORTRAN=
+#FCx=
+#CCx=
@@ -24,6 +25,7 @@
+#COPTIONSld=
+#SYSLIBS=
+#SHAREDEXT=
++MAKE=gmake
INCLUDEcdf=../include
diff --git a/science/cdf/pkg-plist b/science/cdf/pkg-plist
index fd98519af8a8..3df1997a9fac 100644
--- a/science/cdf/pkg-plist
+++ b/science/cdf/pkg-plist
@@ -6,6 +6,7 @@ bin/cdfedit
bin/cdfexport
bin/cdfinquire
bin/cdfirsdump
+bin/cdfleapsecondsinfo
bin/cdfmerge
bin/cdfstats
bin/cdfvalidate
@@ -37,10 +38,12 @@ lib/cdf/help/cdfinq.olh
lib/cdf/help/cdfinqj.olh
lib/cdf/help/cdfirsdump.olh
lib/cdf/help/cdfirsdumpj.olh
+lib/cdf/help/cdfleaptableinfo.olh
+lib/cdf/help/cdfleaptableinfoj.olh
lib/cdf/help/cdfmerge.olh
lib/cdf/help/cdfmergej.olh
-lib/cdf/help/cdfstatj.olh
lib/cdf/help/cdfstats.olh
+lib/cdf/help/cdfstatsj.olh
lib/cdf/help/cdfxp.ilh
lib/cdf/help/cdfvalidate.olh
lib/cdf/help/cdfvalidatej.olh
@@ -48,12 +51,13 @@ lib/cdf/help/skt2cdf.olh
lib/cdf/help/skt2cdfj.olh
lib/libcdf.a
lib/libcdf.so
-lib/libcdf.so.0
+lib/libcdf.3.8.0.so
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/OperateAttributes.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/OperateCDF.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/OperateVariables.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cacsst2.cdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cacsst2.skt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cdf.inc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/d103a2x.cdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1.c
@@ -62,6 +66,8 @@ lib/libcdf.so.0
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2.f
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geocpi0.cdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geocpi0.skt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geocpi1.cdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/geocpi2.cdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ij01r39.cdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read_example1.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/zfia10x.cdf