aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-02 16:10:45 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-02 16:10:45 +0000
commit7d86d4acc375046dc7bd42672fd598371c006dab (patch)
treea0d4d449313a3896f19f7765c836da32cb6187ca
parent19d02a98d9e7f63d574ecbf0fdb73c001f2e7846 (diff)
downloadports-7d86d4acc375046dc7bd42672fd598371c006dab.tar.gz
ports-7d86d4acc375046dc7bd42672fd598371c006dab.zip
Adding MPFI, a Multiple Precision Floating-point Interval library.
To be used by SageMath.
Notes
Notes: svn path=/head/; revision=530383
-rw-r--r--math/Makefile1
-rw-r--r--math/mpfi/Makefile26
-rw-r--r--math/mpfi/distinfo3
-rw-r--r--math/mpfi/files/patch-tests_mpfi-tests.h10
-rw-r--r--math/mpfi/pkg-descr17
-rw-r--r--math/mpfi/pkg-plist6
6 files changed, 63 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index d237e6c463ee..9349a52d4411 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -399,6 +399,7 @@
SUBDIR += moo
SUBDIR += mpc
SUBDIR += mpexpr
+ SUBDIR += mpfi
SUBDIR += mpfr
SUBDIR += mpfrc++
SUBDIR += mpir
diff --git a/math/mpfi/Makefile b/math/mpfi/Makefile
new file mode 100644
index 000000000000..ef29cb54dd13
--- /dev/null
+++ b/math/mpfi/Makefile
@@ -0,0 +1,26 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= mpfi
+PORTVERSION= 1.5.4
+CATEGORIES= math
+MASTER_SITES= https://gforge.inria.fr/frs/download.php/file/38111/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Multiple Precision Floating-point Interval library
+
+LICENSE= LGPL3 GPLv3
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= makeinfo:print/texinfo
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
+
+USES= autoreconf libtool localbase
+
+INFO= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/mpfi/distinfo b/math/mpfi/distinfo
new file mode 100644
index 000000000000..409b16808dcf
--- /dev/null
+++ b/math/mpfi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585759151
+SHA256 (mpfi-1.5.4.tar.gz) = 3b3938595d720af17973deaf727cfc0dd41c8b16c20adc103a970f4a43ae3a56
+SIZE (mpfi-1.5.4.tar.gz) = 261696
diff --git a/math/mpfi/files/patch-tests_mpfi-tests.h b/math/mpfi/files/patch-tests_mpfi-tests.h
new file mode 100644
index 000000000000..7bca2b4922d8
--- /dev/null
+++ b/math/mpfi/files/patch-tests_mpfi-tests.h
@@ -0,0 +1,10 @@
+--- tests/mpfi-tests.h.orig 2019-08-01 20:07:19 UTC
++++ tests/mpfi-tests.h
+@@ -27,6 +27,7 @@ MA 02110-1301, USA. */
+ #ifndef __MPFI_TESTS_H__
+ #define __MPFI_TESTS_H__
+
++#include <sys/types.h>
+ #include <stdlib.h>
+
+ #include "mpfi_io.h"
diff --git a/math/mpfi/pkg-descr b/math/mpfi/pkg-descr
new file mode 100644
index 000000000000..80a27dbde752
--- /dev/null
+++ b/math/mpfi/pkg-descr
@@ -0,0 +1,17 @@
+MPFI is a library for interval arithmetic, which is built upon the MPFR
+multiple precision floating-point arithmetic.
+
+MPFI is intended to be a portable library written in C for arbitrary
+precision interval arithmetic with intervals represented using MPFR
+reliable floating-point numbers. It is based on the GNU MP library and
+on the MPFR library. The purpose of an arbitrary precision interval
+arithmetic is on the one hand to get "guaranteed" results, thanks to
+interval computation, and on the other hand to obtain accurate results,
+thanks to multiple precision arithmetic. The MPFI library is built upon
+MPFR in order to benefit from the correct rounding provided, for each
+operation or function, by MPFR. Further advantages of using MPFR are
+its portability and compliance with the IEEE 754 standard for
+floating-point arithmetic.
+
+WWW: http://perso.ens-lyon.fr/nathalie.revol/software.html
+www: http://mpfi.gforge.inria.fr/
diff --git a/math/mpfi/pkg-plist b/math/mpfi/pkg-plist
new file mode 100644
index 000000000000..52ca3dd62023
--- /dev/null
+++ b/math/mpfi/pkg-plist
@@ -0,0 +1,6 @@
+include/mpfi.h
+include/mpfi_io.h
+lib/libmpfi.a
+lib/libmpfi.so
+lib/libmpfi.so.0
+lib/libmpfi.so.0.0.0