aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2022-05-12 18:20:07 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2022-05-12 18:20:07 +0000
commit7de2d9ab3d9a54300b874077cf96f57912247b64 (patch)
treefeea2b418ba0dee4fcbfb15d34927c27fd5c081d
parent78939306fb9039387ba7d88d8193634d3c36a196 (diff)
downloadports-7de2d9ab3d9a54300b874077cf96f57912247b64.tar.gz
ports-7de2d9ab3d9a54300b874077cf96f57912247b64.zip
devel/pcre2: enable compression support for pcre2grep
PR: 263935 Reported by: David Siebörger <drs-freebsd@sieborger__dot__nom__dot__za>
-rw-r--r--devel/pcre2/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/pcre2/Makefile b/devel/pcre2/Makefile
index c9a14faf6b57..a2cef5df7c3e 100644
--- a/devel/pcre2/Makefile
+++ b/devel/pcre2/Makefile
@@ -21,13 +21,17 @@ CONFIGURE_ARGS= --enable-pcre2-16 \
--enable-pcre2-32
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS LIBBZ2 LIBZ
OPTIONS_RADIO= CLI
OPTIONS_RADIO_CLI= LIBEDIT READLINE
+LIBBZ2_DESC= Using pcre2grep with .bz2 files
+LIBZ_DESC= Using pcre2grep with .gz files
+
+LIBBZ2_CONFIGURE_ON= --enable-pcre2grep-libbz2
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_ENABLE= pcre2test-libedit
-
+LIBZ_CONFIGURE_ON= --enable-pcre2grep-libz
READLINE_USES= readline
READLINE_CONFIGURE_ENABLE= pcre2test-libreadline