aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-08-17 23:43:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-08-18 00:29:59 +0000
commit7e0eeca6bb238a8cc201b921c52a97fd856dd255 (patch)
tree3f2e397fbf95c6c0bbc34b7c71096d51d2896cd8
parente87bbc49e209147793ceb0e6ba09d436fdc88113 (diff)
downloadports-7e0eeca6bb238a8cc201b921c52a97fd856dd255.tar.gz
ports-7e0eeca6bb238a8cc201b921c52a97fd856dd255.zip
x11-wm/gamescope: bundle libliftoff, preparing for update
This reverts commit ef2d0a35dd40b8b59bf9f94b3887d26631b3465d.
-rw-r--r--x11-wm/gamescope/Makefile6
-rw-r--r--x11-wm/gamescope/distinfo2
-rw-r--r--x11-wm/gamescope/files/patch-private-libs26
3 files changed, 31 insertions, 3 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index 9627b0cef72b..24b79d7eeb8d 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -15,13 +15,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= glslangValidator:graphics/glslang \
evdev-proto>0:devel/evdev-proto \
- libliftoff>=0.2.0<0.3.0:graphics/libliftoff \
vulkan-headers>0:graphics/vulkan-headers \
wayland-protocols>=1.17:graphics/wayland-protocols \
wlroots>=0.15.0<0.16.0:x11-toolkits/wlroots
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libdrm.so:graphics/libdrm \
- libliftoff.so:graphics/libliftoff \
libvulkan.so:graphics/vulkan-loader \
libwayland-server.so:graphics/wayland \
libwlroots.so:x11-toolkits/wlroots \
@@ -29,12 +27,14 @@ LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
USES= compiler:c++11-lib meson pkgconfig sdl xorg
USE_GITHUB= yes
+USE_GITLAB= nodefault
USE_SDL= sdl2
USE_XORG= x11 xcomposite xdamage xext xfixes xrender xres xtst xxf86vm
GH_ACCOUNT= Plagman
GH_TUPLE= nothings:stb:af1a5bc:stb/subprojects/stb
+GL_TUPLE= https://gitlab.freedesktop.org:emersion:libliftoff:378ccb4f84a2473fe73dbdc56fe35a0d2ee661cc:libliftoff/subprojects/libliftoff
PLIST_FILES= bin/${PORTNAME}
-MESON_ARGS= --force-fallback-for= # allow system wlroots + libliftoff
+MESON_ARGS= --force-fallback-for=libliftoff # allow system wlroots
OPTIONS_DEFINE= PIPEWIRE
OPTIONS_DEFAULT=PIPEWIRE
diff --git a/x11-wm/gamescope/distinfo b/x11-wm/gamescope/distinfo
index 21147e921445..3d4543ad6a04 100644
--- a/x11-wm/gamescope/distinfo
+++ b/x11-wm/gamescope/distinfo
@@ -3,6 +3,8 @@ SHA256 (Plagman-gamescope-3.11.32_GH0.tar.gz) = e0a4ff5b8cc7aa1d1d8e7c9cd124a7f2
SIZE (Plagman-gamescope-3.11.32_GH0.tar.gz) = 187530
SHA256 (nothings-stb-af1a5bc_GH0.tar.gz) = 3facf6e6f8c3e1715e1a088f22bad9c9202973f9369fb3f088f46cced3f64058
SIZE (nothings-stb-af1a5bc_GH0.tar.gz) = 1387334
+SHA256 (emersion-libliftoff-378ccb4f84a2473fe73dbdc56fe35a0d2ee661cc_GL0.tar.gz) = 7f296842c84e536432c38d069518c705be04c4c44937bc19a28e887e84ee9103
+SIZE (emersion-libliftoff-378ccb4f84a2473fe73dbdc56fe35a0d2ee661cc_GL0.tar.gz) = 31371
SHA256 (2a84a44f6897.patch) = fd892d4477885926b0ef5793d5222764afa2ba334fd25c4cc671c89812e100b5
SIZE (2a84a44f6897.patch) = 2931
SHA256 (e0927f7bce95.patch) = 6bbab2f37d7e76a1eade6d81bc0b441cc09f0020143bafb53555b767bf056600
diff --git a/x11-wm/gamescope/files/patch-private-libs b/x11-wm/gamescope/files/patch-private-libs
new file mode 100644
index 000000000000..a50ea41a00bf
--- /dev/null
+++ b/x11-wm/gamescope/files/patch-private-libs
@@ -0,0 +1,26 @@
+libliftoff package is too old. Keep it private to gamescope package for now.
+
+--- subprojects/libliftoff/meson.build.orig 2020-05-26 19:30:31 UTC
++++ subprojects/libliftoff/meson.build
+@@ -38,7 +38,7 @@ liftoff_lib = library(
+ include_directories: liftoff_inc,
+ version: meson.project_version(),
+ dependencies: liftoff_deps,
+- install: true,
++ install: not meson.is_subproject(),
+ )
+
+ liftoff = declare_dependency(
+@@ -47,6 +47,7 @@ liftoff = declare_dependency(
+ dependencies: liftoff_deps,
+ )
+
++if not meson.is_subproject()
+ install_headers('include/libliftoff.h')
+
+ pkgconfig = import('pkgconfig')
+@@ -60,3 +61,4 @@ pkgconfig.generate(
+
+ subdir('example')
+ subdir('test')
++endif