aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-03-28 09:03:22 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-03-28 09:04:25 +0000
commit7ebf05a43c714fed2dfa4e47222775ec66af4e44 (patch)
treeba73b338667adeda10afab5041eace083d102e0f
parente29e9c167dab5452e4e52737390579dc3e7ecd3f (diff)
downloadports-7ebf05a43c714fed2dfa4e47222775ec66af4e44.tar.gz
ports-7ebf05a43c714fed2dfa4e47222775ec66af4e44.zip
devel/efl: Simplify EMF option group handling.
-rw-r--r--devel/efl/Makefile31
1 files changed, 6 insertions, 25 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index b72262b8ca6c..75cb663dfc9f 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -132,8 +132,12 @@ IBUS_LIB_DEPENDS= libibus-1.0.so:textproc/ibus
IBUS_USES= gnome
IBUS_USE= GNOME=glib20
IBUS_MESON_TRUE= glib
+IBUS_VARS_OFF= ibus_disabler=ibus
SCIM_LIB_DEPENDS= libscim-1.0.so:textproc/scim
+SCIM_VARS_OFF= scim_disabler=scim
+
+XIM_VARS_OFF= xim_disabler=xim
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
@@ -187,32 +191,9 @@ SDL_MESON_TRUE= sdl
.include <bsd.port.options.mk>
-ECORE-IMF-LOADERS-DISABLER-BASE= -Decore-imf-loaders-disabler=
-ECORE-IMF-LOADERS-DISABLER:= ${ECORE-IMF-LOADERS-DISABLER-BASE}
-
-.if empty(PORT_OPTIONS:MIBUS)
-ECORE-IMF-LOADERS-DISABLER:= "${ECORE-IMF-LOADERS-DISABLER-BASE}ibus"
-.endif
-
-.if empty(PORT_OPTIONS:MSCIM)
-.if ${ECORE-IMF-LOADERS-DISABLER} != ${ECORE-IMF-LOADERS-DISABLER-BASE}
-ECORE-IMF-LOADERS-DISABLER-BASE:=${ECORE-IMF-LOADERS-DISABLER}
-ECORE-IMF-LOADERS-DISABLER:= "${ECORE-IMF-LOADERS-DISABLER-BASE},scim"
-.else
-ECORE-IMF-LOADERS-DISABLER:= "${ECORE-IMF-LOADERS-DISABLER-BASE}scim"
-.endif
-.endif
-
-.if empty(PORT_OPTIONS:MXIM)
-.if ${ECORE-IMF-LOADERS-DISABLER} != ${ECORE-IMF-LOADERS-DISABLER-BASE}
-ECORE-IMF-LOADERS-DISABLER-BASE:=${ECORE-IMF-LOADERS-DISABLER}
-ECORE-IMF-LOADERS-DISABLER:= "${ECORE-IMF-LOADERS-DISABLER-BASE},xim"
-.else
-ECORE-IMF-LOADERS-DISABLER:= "${ECORE-IMF-LOADERS-DISABLER-BASE}xim"
-.endif
-.endif
+IMF_DISABLERS= ${IBUS_DISABLER} ${SCIM_DISABLER} ${XIM_DISABLER}
-MESON_ARGS+= ${ECORE-IMF-LOADERS-DISABLER}
+MESON_ARGS+= -Decore-imf-loaders-disabler="${IMF_DISABLERS:ts,}"
EVAS-LOADERS-DISABLER-BASE= -Devas-loaders-disabler=
EVAS-LOADERS-DISABLER:= ${EVAS-LOADERS-DISABLER-BASE}