aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@ninth-nine.com>2022-06-25 12:37:56 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2022-06-25 12:40:20 +0000
commit7ec953eb84b41b8acefcd303877f875fd56f62d6 (patch)
treee9990b843f46e5a1f4281a2a152c94d15a5fada3
parente00d3e8258542fe05115ca8a350cad5ac4f215f9 (diff)
downloadports-7ec953eb84b41b8acefcd303877f875fd56f62d6.tar.gz
ports-7ec953eb84b41b8acefcd303877f875fd56f62d6.zip
net/slackcat: Add new port
Slackcat is a simple commandline utility to post snippets to Slack. WWW: https://github.com/bcicen/slackcat PR: 264874
-rw-r--r--net/Makefile1
-rw-r--r--net/slackcat/Makefile23
-rw-r--r--net/slackcat/distinfo5
-rw-r--r--net/slackcat/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ae8f37429e32..0be6ab909265 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1426,6 +1426,7 @@
SUBDIR += sipsak
SUBDIR += skstream
SUBDIR += sl2tps
+ SUBDIR += slackcat
SUBDIR += smb4k
SUBDIR += smcroute
SUBDIR += smm++
diff --git a/net/slackcat/Makefile b/net/slackcat/Makefile
new file mode 100644
index 000000000000..bd70c0d57b87
--- /dev/null
+++ b/net/slackcat/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= slackcat
+DISTVERSION= 1.7.3
+CATEGORIES= net
+MASTER_SITES= https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${DISTVERSIONFULL}/:gomod
+DISTFILES= go.mod:gomod
+
+MAINTAINER= nork@ninth-nine.com
+COMMENT= Simple commandline utility to post snippets to Slack
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= bcicen
+GH_TAGNAME= 5c4e4410002c
+
+GO_MODULE= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+GO_BUILDFLAGS= -ldflags="-s -w -X main.version=${DISTVERSION} -X main.build=${GH_TAGNAME}"
+
+PLIST_FILES= bin/slackcat
+
+.include <bsd.port.mk>
diff --git a/net/slackcat/distinfo b/net/slackcat/distinfo
new file mode 100644
index 000000000000..699e69efd289
--- /dev/null
+++ b/net/slackcat/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1656123971
+SHA256 (go/net_slackcat/bcicen-slackcat-1.7.3-5c4e4410002c_GH0/go.mod) = 98640a46a3b3a14c84f7df4e83548785e563c11de563893623766350452ce8e0
+SIZE (go/net_slackcat/bcicen-slackcat-1.7.3-5c4e4410002c_GH0/go.mod) = 355
+SHA256 (go/net_slackcat/bcicen-slackcat-1.7.3-5c4e4410002c_GH0/bcicen-slackcat-1.7.3-5c4e4410002c_GH0.tar.gz) = 680a799ad877d4165a84fc176bb4dc922e0f24ab4ff457715fe1bbefa3785ea2
+SIZE (go/net_slackcat/bcicen-slackcat-1.7.3-5c4e4410002c_GH0/bcicen-slackcat-1.7.3-5c4e4410002c_GH0.tar.gz) = 28255
diff --git a/net/slackcat/pkg-descr b/net/slackcat/pkg-descr
new file mode 100644
index 000000000000..88ed6f90cc72
--- /dev/null
+++ b/net/slackcat/pkg-descr
@@ -0,0 +1,3 @@
+Slackcat is a simple commandline utility to post snippets to Slack.
+
+WWW: https://github.com/bcicen/slackcat