aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-07-13 09:47:48 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-07-13 09:48:01 +0000
commit7f1fbb2020e286621e3107c2bf369f9973e99112 (patch)
treee065239567355b93bd3f55c719c7982bc1fdd606
parentdbb8d98297cc87b08dcf8a8f44b287a5bc03ed83 (diff)
downloadports-7f1fbb2020e286621e3107c2bf369f9973e99112.tar.gz
ports-7f1fbb2020e286621e3107c2bf369f9973e99112.zip
net/echoping: fix the segmentation fault at dns.c:111
Add missing prototype for to_upper() which returns char *. Without it, compiler assumed that it returns an int, which results in segmentation fault in init() at dns.c when trying process its result which had been cast to char *, albeit needlessly (this code does lots of bogus casts). PR: 220294
-rw-r--r--net/echoping/Makefile2
-rw-r--r--net/echoping/files/patch-echoping.h8
2 files changed, 9 insertions, 1 deletions
diff --git a/net/echoping/Makefile b/net/echoping/Makefile
index f0edfac1fb28..b9c3e52f89d0 100644
--- a/net/echoping/Makefile
+++ b/net/echoping/Makefile
@@ -2,7 +2,7 @@
PORTNAME= echoping
PORTVERSION= 6.0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MAINTAINER= ports@FreeBSD.org
diff --git a/net/echoping/files/patch-echoping.h b/net/echoping/files/patch-echoping.h
index 6614c1d56d6e..f411f7383f8e 100644
--- a/net/echoping/files/patch-echoping.h
+++ b/net/echoping/files/patch-echoping.h
@@ -43,3 +43,11 @@
/* My functions */
+@@ -198,6 +186,7 @@ int TLS_readline ();
+ #endif
+ /* util.c */
+ char *random_string ();
++char *to_upper(char *);
+ void tvsub ();
+ void tvadd ();
+ void tvavg ();