aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-09-30 15:56:09 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-09-30 22:13:44 +0000
commit7f9480c704826bce8020a898e57695f78e0bd811 (patch)
treee7c4ef68ac93f8e0663105a057fcc22cdaed89c2
parentb559c289f7e95e25cdf904e030563ee0c7d528c1 (diff)
downloadports-7f9480c704826bce8020a898e57695f78e0bd811.tar.gz
ports-7f9480c704826bce8020a898e57695f78e0bd811.zip
sysutils/qlogtools: include errno.h for errno
errno must be accessed by a macro from errno.h.
-rw-r--r--sysutils/qlogtools/Makefile2
-rw-r--r--sysutils/qlogtools/files/patch-qfilelog.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/qlogtools/Makefile b/sysutils/qlogtools/Makefile
index d9eddf79c7fe..fea7fc1733b4 100644
--- a/sysutils/qlogtools/Makefile
+++ b/sysutils/qlogtools/Makefile
@@ -1,6 +1,6 @@
PORTNAME= qlogtools
PORTVERSION= 3.1
-PORTREVISION= 4
+PORTREVISION= 6
CATEGORIES= sysutils
MASTER_SITES= http://untroubled.org/${PORTNAME}/
diff --git a/sysutils/qlogtools/files/patch-qfilelog.c b/sysutils/qlogtools/files/patch-qfilelog.c
new file mode 100644
index 000000000000..aab6050e60f8
--- /dev/null
+++ b/sysutils/qlogtools/files/patch-qfilelog.c
@@ -0,0 +1,14 @@
+--- qfilelog.c.orig
++++ qfilelog.c
+@@ -1,10 +1,9 @@
++#include <errno.h>
+ #include <fcntl.h>
+ #include <signal.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+-
+-extern int errno;
+
+ #define PAUSE sleep(60)
+