aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-09-23 18:43:09 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-09-23 18:53:14 +0000
commit8070a5c317c8ef15e6545af047c989e3d1b4d3cc (patch)
tree8822d37542912c20e0e17f7a98a4a5d54f548e07
parente7a7133e75d1b3ec98f8010310a7fee824e30f54 (diff)
downloadports-8070a5c317c8ef15e6545af047c989e3d1b4d3cc.tar.gz
ports-8070a5c317c8ef15e6545af047c989e3d1b4d3cc.zip
games/exult: Cleanup LIB_DEPENDS
-rw-r--r--games/exult/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index c9fe7e380030..a674d8b672ac 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -1,6 +1,6 @@
PORTNAME= exult
DISTVERSION?= 1.8
-PORTREVISION?= 3
+PORTREVISION?= 4
PORTEPOCH= 1
CATEGORIES= games
@@ -11,20 +11,17 @@ WWW= http://exult.info
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libogg.so:audio/libogg \
- libpng.so:graphics/png \
+LIB_DEPENDS= libogg.so:audio/libogg \
+ libpng16.so:graphics/png \
libvorbis.so:audio/libvorbis
USES= autoreconf compiler:c++17-lang gmake libtool localbase \
pkgconfig sdl xorg
-
-USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
-USE_SDL= mixer2 sdl2
+USE_GNOME= cairo gdkpixbuf2
+USE_SDL= sdl2
USE_XORG= x11 xext
GNU_CONFIGURE= yes
-
CONFIGURE_ARGS= --disable-static \
--enable-shared \
--with-icondir=${PREFIX}/share/pixmaps
@@ -60,19 +57,20 @@ FLUIDSYNTH_CONFIGURE_ENABLE= fluidsynth
GIMP_LIB_DEPENDS= libbabl-0.1.so:x11/babl \
libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libgegl-0.4.so:graphics/gegl \
libgegl-npd-0.4.so:graphics/gegl \
libgimp-2.0.so:graphics/gimp-app \
libharfbuzz.so:print/harfbuzz \
libjson-glib-1.0.so:devel/json-glib
GIMP_USES= gnome
-GIMP_USE= GNOME=gtk20 \
- pango
+GIMP_USE= GNOME=gtk20,pango
+
GIMP_CONFIGURE_ENABLE= gimp-plugin
STUDIO_LIB_DEPENDS?= libharfbuzz.so:print/harfbuzz
STUDIO_USES= gnome
-STUDIO_USE= GNOME=libglade2
+STUDIO_USE= GNOME=gtk30
STUDIO_CONFIGURE_ENABLE= exult-studio exult-studio-support
post-install-DOCS-on: