aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2022-11-14 14:06:02 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2022-11-14 14:06:43 +0000
commit80ccb4096cf564c09f65cba6e0900f33b4bc8a08 (patch)
tree49de1d0f6f390617e41c5d859ede001b903bf55f
parent6f0f3fd5750c86ff0b97a707939944803f9560d9 (diff)
downloadports-80ccb4096cf564c09f65cba6e0900f33b4bc8a08.tar.gz
ports-80ccb4096cf564c09f65cba6e0900f33b4bc8a08.zip
devel/libnfc: Update to 1.8.0
* Switch mastersite to github * Fix nfc-scan-device for ACR_122_USB * Bump PORTREVISION of dependencies because of shared library bump PR: 261667 Submitted by: Stefan Ehmann Approved by: maintainer timeout (ca. 9 months)
-rw-r--r--devel/libfreefare/Makefile2
-rw-r--r--devel/libnfc/Makefile8
-rw-r--r--devel/libnfc/distinfo5
-rw-r--r--devel/libnfc/files/patch-libnfc_drivers_acr122__usb.c12
-rw-r--r--devel/libnfc/pkg-plist6
-rw-r--r--sysutils/nfcutils/Makefile1
6 files changed, 24 insertions, 10 deletions
diff --git a/devel/libfreefare/Makefile b/devel/libfreefare/Makefile
index ce32310bd214..a32a4e1575f7 100644
--- a/devel/libfreefare/Makefile
+++ b/devel/libfreefare/Makefile
@@ -1,7 +1,7 @@
PORTNAME= libfreefare
PORTVERSION= 0.4.0
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= romain@FreeBSD.org
diff --git a/devel/libnfc/Makefile b/devel/libnfc/Makefile
index 4394e47970e1..f5c604c0ec3e 100644
--- a/devel/libnfc/Makefile
+++ b/devel/libnfc/Makefile
@@ -1,9 +1,7 @@
PORTNAME= libnfc
-PORTVERSION= 1.7.1
-PORTREVISION= 5
+PORTVERSION= 1.8.0
CATEGORIES= devel
-MASTER_SITES= http://dl.bintray.com/nfc-tools/sources/ \
- http://romain.blogreen.org/distfiles/
+MASTER_SITES= https://github.com/nfc-tools/libnfc/releases/download/libnfc-${PORTVERSION}/
MAINTAINER= romain@FreeBSD.org
COMMENT= Near Field Communication (NFC) library
@@ -25,8 +23,8 @@ PN532_UART_DESC=PN532 UART driver
PN53X_USB_DESC= PN53X USB driver
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
USES= gmake libtool pathfix pkgconfig readline tar:bzip2
+USE_LDCONFIG= yes
MAKE_ENV= INSTALL_STRIP_FLAG="${STRIP}"
CFLAGS+= -D__BSD_VISIBLE
diff --git a/devel/libnfc/distinfo b/devel/libnfc/distinfo
index efdc3cc7a755..c9134874ad22 100644
--- a/devel/libnfc/distinfo
+++ b/devel/libnfc/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libnfc-1.7.1.tar.bz2) = 945e74d8e27683f9b8a6f6e529557b305d120df347a960a6a7ead6cb388f4072
-SIZE (libnfc-1.7.1.tar.bz2) = 484309
+TIMESTAMP = 1643747630
+SHA256 (libnfc-1.8.0.tar.bz2) = 6d9ad31c86408711f0a60f05b1933101c7497683c2e0d8917d1611a3feba3dd5
+SIZE (libnfc-1.8.0.tar.bz2) = 553511
diff --git a/devel/libnfc/files/patch-libnfc_drivers_acr122__usb.c b/devel/libnfc/files/patch-libnfc_drivers_acr122__usb.c
new file mode 100644
index 000000000000..c4e7373cdc2f
--- /dev/null
+++ b/devel/libnfc/files/patch-libnfc_drivers_acr122__usb.c
@@ -0,0 +1,12 @@
+--- libnfc/drivers/acr122_usb.c.orig 2022-02-01 22:26:36 UTC
++++ libnfc/drivers/acr122_usb.c
+@@ -419,6 +419,9 @@ acr122_usb_open(const nfc_context *context, const nfc_
+ continue;
+ // Reset device
+ usb_reset(data.pudh);
++ // Reopen the device
++ if ((data.pudh = usb_open(dev)) == NULL)
++ continue;
+ // Retrieve end points
+ acr122_usb_get_end_points(dev, &data);
+ // Claim interface
diff --git a/devel/libnfc/pkg-plist b/devel/libnfc/pkg-plist
index 983103eb9cf7..0d8148ec5d9e 100644
--- a/devel/libnfc/pkg-plist
+++ b/devel/libnfc/pkg-plist
@@ -1,4 +1,5 @@
bin/nfc-anticol
+bin/nfc-barcode
bin/nfc-dep-initiator
bin/nfc-dep-target
bin/nfc-emulate-forum-tag2
@@ -23,10 +24,11 @@ include/nfc/nfc-types.h
include/nfc/nfc.h
lib/libnfc.a
lib/libnfc.so
-lib/libnfc.so.5
-lib/libnfc.so.5.0.1
+lib/libnfc.so.6
+lib/libnfc.so.6.0.0
libdata/pkgconfig/libnfc.pc
man/man1/nfc-anticol.1.gz
+man/man1/nfc-barcode.1.gz
man/man1/nfc-dep-initiator.1.gz
man/man1/nfc-dep-target.1.gz
man/man1/nfc-emulate-forum-tag2.1.gz
diff --git a/sysutils/nfcutils/Makefile b/sysutils/nfcutils/Makefile
index 9f9ab8d916db..b0ae9cf38f44 100644
--- a/sysutils/nfcutils/Makefile
+++ b/sysutils/nfcutils/Makefile
@@ -1,5 +1,6 @@
PORTNAME= nfcutils
PORTVERSION= 0.1.2
+PORTREVISION= 1
DISTVERSIONPREFIX=v
CATEGORIES= sysutils