aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-02-14 11:41:11 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-02-14 11:41:11 +0000
commit80ef111f0369fb10e3a890613460fe45cb1a97ba (patch)
tree2864b2cfb90fe2d8ec62f77f6651719002a028b2
parent53ee61160a2db42a9ef06c5fd363794716b4404e (diff)
downloadports-80ef111f0369fb10e3a890613460fe45cb1a97ba.tar.gz
ports-80ef111f0369fb10e3a890613460fe45cb1a97ba.zip
mail/exim: unbreak build with LLVM15 (+)
Pass -Wno-int-conversion to CFLAGS fixes error with strict conversion rules introduced in LLVM15 error: incompatible pointer to integer conversion passing 'char *' to parameter of type 'BOOL' (aka 'unsigned int') [-Wint-conversion]
-rw-r--r--mail/exim/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 2242ff7608fa..9b628a088d3d 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -21,6 +21,9 @@ USES= compiler cpe tar:bzip2 perl5
USE_CSTD= c99
USE_PERL5= run
+# LLVM15 workaround
+CFLAGS= -Wno-int-conversion
+
# Exim build system is job unsafe atm
MAKE_JOBS_UNSAFE= yes
# One can tune the following "hidden" knobs: