aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonald Klop <ronald@FreeBSD.org>2024-10-31 07:26:24 +0000
committerRonald Klop <ronald@FreeBSD.org>2024-10-31 07:31:04 +0000
commit812019cddd4afbd26b841d056fb5d27624fac4e1 (patch)
tree28957971b3d0ff7629934a77a313c685bf52c4ab
parent46cf76000b4840d6bed1e1e5ba1e9603706cda61 (diff)
databases/mongodb70: unbreak on 15 + llvm 19.1.2
stick to <= llvm18 on FreeBSD 15 fixes: In file included from src/third_party/mozjs/platform/x86_64/freebsd/build/Unified_cpp_js_src4.cpp:20: In file included from src/third_party/mozjs/extract/js/src/jsapi.cpp:42: In file included from src/third_party/mozjs/extract/js/src/gc/PublicIterators.h:17: In file included from src/third_party/mozjs/extract/js/src/gc/Zone.h:33: In file included from src/third_party/mozjs/extract/js/src/vm/JSScript.h:41: In file included from src/third_party/mozjs/extract/js/src/vm/SharedImmutableStringsCache.h:22: src/third_party/mozjs/extract/js/src/threading/ExclusiveData.h:113:29: error: reference to non-static member function must be called 113 | : lock_(std::move(rhs.lock)), value_(std::move(rhs.value_)) { | ~~~~^~~~ 1 error generated.
-rw-r--r--databases/mongodb70/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/mongodb70/Makefile b/databases/mongodb70/Makefile
index 1c6014f85129..68707fd1a4dc 100644
--- a/databases/mongodb70/Makefile
+++ b/databases/mongodb70/Makefile
@@ -104,6 +104,12 @@ NOAVX_MAKE_ARGS= --experimental-optimization="-sandybridge"
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_MAKE_ARGS= --use-sasl-client
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1500026 # llvm 19.1.2 import
+USES+= llvm:max=18,build
+.endif
+
.include <bsd.port.pre.mk>
ALL_TARGET= install-core