aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZsolt Udvari <uzsolt@FreeBSD.org>2025-02-08 19:48:01 +0000
committerZsolt Udvari <uzsolt@FreeBSD.org>2025-02-08 19:49:46 +0000
commit812104b95d12f74690395988e00d7b266830d118 (patch)
tree6353e1fbb06dd90ffadb282084ec96862c826ed7
parent02fe0e57819d1d81395e1db21c8a06ea226447a1 (diff)
devel/R-cran-purrr: Update to 1.0.4
Add TEST_DEPENDS. Add LICENSE_FILE. Change WWW to canonical form as cran suggests. Changelog: https://cran.r-project.org/web/packages/purrr/news/news.html Reported by: portscout
-rw-r--r--devel/R-cran-purrr/Makefile20
-rw-r--r--devel/R-cran-purrr/distinfo6
-rw-r--r--devel/R-cran-purrr/pkg-descr6
3 files changed, 23 insertions, 9 deletions
diff --git a/devel/R-cran-purrr/Makefile b/devel/R-cran-purrr/Makefile
index a281b25d4819..482cbe2e8357 100644
--- a/devel/R-cran-purrr/Makefile
+++ b/devel/R-cran-purrr/Makefile
@@ -1,21 +1,31 @@
PORTNAME= purrr
-PORTVERSION= 1.0.2
+DISTVERSION= 1.0.4
CATEGORIES= devel
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= uzsolt@FreeBSD.org
COMMENT= Functional Programming Tools
-WWW= https://cran.r-project.org/web/packages/purrr/
+WWW= https://cran.r-project.org/package=purrr
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
-CRAN_DEPENDS= R-cran-cli>=3.4.0:devel/R-cran-cli \
+CRAN_DEPENDS= R-cran-cli>=3.6.1:devel/R-cran-cli \
R-cran-lifecycle>=1.0.3:devel/R-cran-lifecycle \
R-cran-magrittr>=1.5.0:devel/R-cran-magrittr \
- R-cran-rlang>=0.4.10:devel/R-cran-rlang \
- R-cran-vctrs>=0.5.0:devel/R-cran-vctrs
+ R-cran-rlang>=1.1.1:devel/R-cran-rlang \
+ R-cran-vctrs>=0.6.3:devel/R-cran-vctrs
BUILD_DEPENDS= ${CRAN_DEPENDS}
RUN_DEPENDS= ${CRAN_DEPENDS}
+TEST_DEPENDS= R-cran-covr>0:devel/R-cran-covr \
+ R-cran-dplyr>0:math/R-cran-dplyr \
+ R-cran-httr>0:www/R-cran-httr \
+ R-cran-knitr>0:print/R-cran-knitr \
+ R-cran-lubridate>0:devel/R-cran-lubridate \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown \
+ R-cran-testthat>=3.0.0:devel/R-cran-testthat \
+ R-cran-tibble>0:devel/R-cran-tibble \
+ R-cran-tidyselect>0:devel/R-cran-tidyselect
USES= cran:auto-plist,compiles
diff --git a/devel/R-cran-purrr/distinfo b/devel/R-cran-purrr/distinfo
index b16a34199ef2..ef3188893e91 100644
--- a/devel/R-cran-purrr/distinfo
+++ b/devel/R-cran-purrr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1691754983
-SHA256 (purrr_1.0.2.tar.gz) = 2c1bc6bb88433dff0892b41136f2f5c23573b335ff35a4775c72aa57b48bbb63
-SIZE (purrr_1.0.2.tar.gz) = 220868
+TIMESTAMP = 1739018697
+SHA256 (purrr_1.0.4.tar.gz) = 6c013724651c5daae56a7b8e126baef958d30d4c01dd0dda3d17fc43409b8e54
+SIZE (purrr_1.0.4.tar.gz) = 256912
diff --git a/devel/R-cran-purrr/pkg-descr b/devel/R-cran-purrr/pkg-descr
index 9726f864bdae..1a3ea0aed9ad 100644
--- a/devel/R-cran-purrr/pkg-descr
+++ b/devel/R-cran-purrr/pkg-descr
@@ -1 +1,5 @@
-A complete and consistent functional programming toolkit for R.
+purrr enhances R's functional programming (FP) toolkit by providing a complete
+and consistent set of tools for working with functions and vectors. If you've
+never heard of FP before, the best place to start is the family of map()
+functions which allow you to replace many for loops with code that is both more
+succinct and easier to read.