aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-25 19:38:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-25 19:51:13 +0000
commit81583132f052015c83b9555da1f61efe00a68779 (patch)
tree4d43b8283ad385f6c14a704fc293b76c4e724378
parent623eeaccd2b35ace169682640f8a15a1a2ebd815 (diff)
downloadports-81583132f052015c83b9555da1f61efe00a68779.tar.gz
ports-81583132f052015c83b9555da1f61efe00a68779.zip
math/mfem: Add SUPERLU option
-rw-r--r--math/mfem/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/mfem/Makefile b/math/mfem/Makefile
index 8e298e41a2fd..4f1d71b3f041 100644
--- a/math/mfem/Makefile
+++ b/math/mfem/Makefile
@@ -1,7 +1,7 @@
PORTNAME= mfem
DISTVERSIONPREFIX= v
DISTVERSION= 4.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -17,6 +17,7 @@ USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_TESTING_ON= MFEM_ENABLE_TESTING # tests are broken, see https://github.com/mfem/mfem/issues/3163
+OPTIONS_DEFINE= SUPERLU
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= NOMPI MPICH OPENMPI
OPTIONS_DEFAULT= MPICH # should be the same choice as in science/hypre
@@ -35,4 +36,9 @@ OPENMPI_CMAKE_ON= -DTPL_ENABLE_MPI=ON
OPENMPI_LIB_DEPENDS= libHYPRE.so:science/hypre \
libmetis.so:math/metis
+SUPERLU_DESC= Enable SuperLU use
+SUPERLU_CMAKE_BOOL= MFEM_USE_SUPERLU
+SUPERLU_CMAKE_ON= -DSuperLUDist_DIR=${LOCALBASE} -DSuperLUDist_INCLUDE_DIRS=${LOCALBASE}/include/superlu
+SUPERLU_BROKEN= build fails, see https://github.com/mfem/mfem/issues/3171
+
.include <bsd.port.mk>