aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-09 08:04:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-09 08:04:00 +0000
commit815aec4ad2d0127f8b3e3ee89a56584a7bb11cba (patch)
treee40a78cf317c820ec7b14c8ea79b4c33e6632e01
parentd4e4c868fc1d7ebe5862b15746339537223e982d (diff)
downloadports-815aec4ad2d0127f8b3e3ee89a56584a7bb11cba.tar.gz
ports-815aec4ad2d0127f8b3e3ee89a56584a7bb11cba.zip
Address some problems with this port:
- Install more complete set of manual pages - Do not patch+sed(1) the script, just put in on SHEBANG_FILES - Remove patches which apparently were to avoid dependency on GNU make, but they are incomplete and did not do the job well (e.g., tests were broken due to circular dependencies) - Unbreak the tests by calling /bin/sh rather than /bin/bash
Notes
Notes: svn path=/head/; revision=564772
-rw-r--r--sysutils/lttng-ust/Makefile11
-rw-r--r--sysutils/lttng-ust/files/patch-doc_examples_demo-tracef_Makefile9
-rw-r--r--sysutils/lttng-ust/files/patch-doc_examples_demo-tracelog_Makefile9
-rw-r--r--sysutils/lttng-ust/files/patch-doc_examples_hello-static-lib_Makefile9
-rw-r--r--sysutils/lttng-ust/files/patch-tests_gcc-weak-hidden_Makefile.am22
-rw-r--r--sysutils/lttng-ust/files/patch-tests_ust-elf_Makefile.am11
-rw-r--r--sysutils/lttng-ust/files/patch-tools_lttng-gen-tp8
-rw-r--r--sysutils/lttng-ust/pkg-plist6
8 files changed, 14 insertions, 71 deletions
diff --git a/sysutils/lttng-ust/Makefile b/sysutils/lttng-ust/Makefile
index ea42a7f20ab2..9e0ef3b7e58d 100644
--- a/sysutils/lttng-ust/Makefile
+++ b/sysutils/lttng-ust/Makefile
@@ -16,21 +16,24 @@ LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING
LICENSE_FILE_MIT= ${WRKSRC}/COPYING
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
+BUILD_DEPENDS= asciidoc:textproc/asciidoc \
+ xmlto:textproc/xmlto
LIB_DEPENDS= liburcu.so:sysutils/liburcu
-USES= autoreconf libtool localbase pathfix python \
- shebangfix tar:bzip2
+USES= autoreconf gmake libtool localbase pathfix python \
+ shebangfix tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
# XXX: build fails if cmake is detected, see PR 253327
CONFIGURE_ENV= ac_cv_prog_HAVE_CMAKE=no
INSTALL_TARGET= install-strip
+SHEBANG_FILES= tools/lttng-gen-tp
TEST_TARGET= check
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|%%PYTHON_VERSION%%|${PYTHON_VERSION}|g' \
- ${PATCH_WRKSRC}/tools/lttng-gen-tp
+ @${GREP} -Rl --null '#!/bin/bash' ${WRKSRC}/tests | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e '/#!/s,bash,sh,'
.include <bsd.port.mk>
diff --git a/sysutils/lttng-ust/files/patch-doc_examples_demo-tracef_Makefile b/sysutils/lttng-ust/files/patch-doc_examples_demo-tracef_Makefile
index 9d73c3c04ca8..09a33aa87229 100644
--- a/sysutils/lttng-ust/files/patch-doc_examples_demo-tracef_Makefile
+++ b/sysutils/lttng-ust/files/patch-doc_examples_demo-tracef_Makefile
@@ -15,12 +15,3 @@
LOCAL_CPPFLAGS += -I.
all: demo-tracef
-@@ -31,7 +27,7 @@ demo-tracef.o: demo-tracef.c
-
- demo-tracef: demo-tracef.o
- $(CC) $(LDFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(AM_CFLAGS) \
-- -o $@ $< $(LIBS)
-+ -o $@ demo-tracef.o $(LIBS)
-
- .PHONY: clean
- clean:
diff --git a/sysutils/lttng-ust/files/patch-doc_examples_demo-tracelog_Makefile b/sysutils/lttng-ust/files/patch-doc_examples_demo-tracelog_Makefile
index 259ee0327d49..e5f97e40a1e9 100644
--- a/sysutils/lttng-ust/files/patch-doc_examples_demo-tracelog_Makefile
+++ b/sysutils/lttng-ust/files/patch-doc_examples_demo-tracelog_Makefile
@@ -15,12 +15,3 @@
LOCAL_CPPFLAGS += -I.
all: demo-tracelog
-@@ -31,7 +27,7 @@ demo-tracelog.o: demo-tracelog.c
-
- demo-tracelog: demo-tracelog.o
- $(CC) $(LDFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(AM_CFLAGS) \
-- -o $@ $< $(LIBS)
-+ -o $@ demo-tracelog.o $(LIBS)
-
- .PHONY: clean
- clean:
diff --git a/sysutils/lttng-ust/files/patch-doc_examples_hello-static-lib_Makefile b/sysutils/lttng-ust/files/patch-doc_examples_hello-static-lib_Makefile
index 3ada1c673ebd..92782b8b891a 100644
--- a/sysutils/lttng-ust/files/patch-doc_examples_hello-static-lib_Makefile
+++ b/sysutils/lttng-ust/files/patch-doc_examples_hello-static-lib_Makefile
@@ -1,6 +1,6 @@
--- doc/examples/hello-static-lib/Makefile.orig 2016-08-08 21:25:36 UTC
+++ doc/examples/hello-static-lib/Makefile
-@@ -14,19 +14,15 @@
+@@ -14,13 +14,9 @@
#
# This makefile is purposefully kept simple to support GNU and BSD make.
@@ -16,10 +16,3 @@
all: hello
- lttng-ust-provider-hello.o: tp.c ust_tests_hello.h
- $(CC) $(CPPFLAGS) $(LOCAL_CPPFLAGS) $(CFLAGS) $(AM_CPPFLAGS) \
-- $(AM_CFLAGS) -c -o $@ $<
-+ $(AM_CFLAGS) -c -o $@ tp.c
-
- lttng-ust-provider-hello.a: lttng-ust-provider-hello.o
- ar -rc $@ lttng-ust-provider-hello.o
diff --git a/sysutils/lttng-ust/files/patch-tests_gcc-weak-hidden_Makefile.am b/sysutils/lttng-ust/files/patch-tests_gcc-weak-hidden_Makefile.am
deleted file mode 100644
index 1e0f29deeeca..000000000000
--- a/sysutils/lttng-ust/files/patch-tests_gcc-weak-hidden_Makefile.am
+++ /dev/null
@@ -1,22 +0,0 @@
---- tests/gcc-weak-hidden/Makefile.am.orig 2016-10-18 22:44:06 UTC
-+++ tests/gcc-weak-hidden/Makefile.am
-@@ -1,17 +1,9 @@
- AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
-
--noinst_LTLIBRARIES = libgcc-wh.la
--libgcc_wh_la_SOURCES = c.c d.c
--
--noinst_PROGRAMS = test-gcc-wh
--test_gcc_wh_SOURCES = main.c b.c
--test_gcc_wh_LDADD = $(top_builddir)/tests/utils/libtap.a \
-- $(builddir)/libgcc-wh.la
--
- noinst_SCRIPTS = test_gcc_weak_hidden
- CLEANFILES = $(noinst_SCRIPTS)
- EXTRA_DIST = test_gcc_weak_hidden.in
-
--$(noinst_SCRIPTS): %: %.in
-- sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
-+$(noinst_SCRIPTS): $(noinst_SCRIPTS).in *
-+ sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $(noinst_SCRIPTS).in > $@
- chmod +x $@
diff --git a/sysutils/lttng-ust/files/patch-tests_ust-elf_Makefile.am b/sysutils/lttng-ust/files/patch-tests_ust-elf_Makefile.am
deleted file mode 100644
index f791ae10fe3d..000000000000
--- a/sysutils/lttng-ust/files/patch-tests_ust-elf_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/ust-elf/Makefile.am.orig 2016-10-18 22:44:06 UTC
-+++ tests/ust-elf/Makefile.am
-@@ -23,6 +23,6 @@ EXTRA_DIST = test_ust_elf.in \
- $(srcdir)/data/pic/hello.c \
- $(srcdir)/data/pic/libhello.c
-
--$(noinst_SCRIPTS): %: %.in
-- sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
-+$(noinst_SCRIPTS): $(noinst_SCRIPTS).in *
-+ sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $(noinst_SCRIPTS).in > $@
- chmod +x $@
diff --git a/sysutils/lttng-ust/files/patch-tools_lttng-gen-tp b/sysutils/lttng-ust/files/patch-tools_lttng-gen-tp
deleted file mode 100644
index b2f25419b7fb..000000000000
--- a/sysutils/lttng-ust/files/patch-tools_lttng-gen-tp
+++ /dev/null
@@ -1,8 +0,0 @@
---- tools/lttng-gen-tp.orig 2017-01-08 00:38:50 UTC
-+++ tools/lttng-gen-tp
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env %%PYTHON_VERSION%%
- #
- # Copyright (c) 2012 Yannick Brosseau <yannick.brosseau@gmail.com>
- #
diff --git a/sysutils/lttng-ust/pkg-plist b/sysutils/lttng-ust/pkg-plist
index 0e536a05ba9e..ad6fed7c7d4d 100644
--- a/sysutils/lttng-ust/pkg-plist
+++ b/sysutils/lttng-ust/pkg-plist
@@ -69,7 +69,13 @@ lib/liblttng-ust.so
lib/liblttng-ust.so.0
lib/liblttng-ust.so.0.0.0
libdata/pkgconfig/lttng-ust.pc
+man/man1/lttng-gen-tp.1.gz
man/man3/do_tracepoint.3.gz
+man/man3/lttng-ust-cyg-profile.3.gz
+man/man3/lttng-ust-dl.3.gz
+man/man3/lttng-ust.3.gz
+man/man3/tracef.3.gz
+man/man3/tracelog.3.gz
man/man3/tracepoint.3.gz
man/man3/tracepoint_enabled.3.gz
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog