aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-06-17 01:19:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-06-17 01:20:37 +0000
commit816f2d3ce2f0c7686daddbe302638dfe7aa07d98 (patch)
tree264877b1786196d952ad85db3662857a96fa4647
parentc8875afebacf9b1f5e57564f2a48d6ed64541b33 (diff)
devel/py-PyPubSub: New port: Python Publish-Subscribe Package
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-PyPubSub/Makefile22
-rw-r--r--devel/py-PyPubSub/distinfo3
-rw-r--r--devel/py-PyPubSub/pkg-descr7
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fd73936b3a61..1c72d965d34e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4277,6 +4277,7 @@
SUBDIR += py-PyExecJS
SUBDIR += py-PyGithub
SUBDIR += py-PyLD
+ SUBDIR += py-PyPubSub
SUBDIR += py-PyUtilib
SUBDIR += py-QtPy
SUBDIR += py-RPyC
diff --git a/devel/py-PyPubSub/Makefile b/devel/py-PyPubSub/Makefile
new file mode 100644
index 000000000000..924c721ea0f5
--- /dev/null
+++ b/devel/py-PyPubSub/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= PyPubSub
+DISTVERSIONPREFIX= v
+DISTVERSION= 4.0.3
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python Publish-Subscribe Package
+WWW= https://github.com/schollii/pypubsub
+
+LICENSE= BSD3CLAUSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= schollii
+GH_PROJECT= pypubsub
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-PyPubSub/distinfo b/devel/py-PyPubSub/distinfo
new file mode 100644
index 000000000000..75cd7d18f9f1
--- /dev/null
+++ b/devel/py-PyPubSub/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1718580324
+SHA256 (schollii-pypubsub-v4.0.3_GH0.tar.gz) = 0df83daa1cb0021bab858ff6812d836c9712dea59a5172be1888bb554c3a89a2
+SIZE (schollii-pypubsub-v4.0.3_GH0.tar.gz) = 174033
diff --git a/devel/py-PyPubSub/pkg-descr b/devel/py-PyPubSub/pkg-descr
new file mode 100644
index 000000000000..7754bd241f8a
--- /dev/null
+++ b/devel/py-PyPubSub/pkg-descr
@@ -0,0 +1,7 @@
+Provides a publish-subscribe API to facilitate event-based or message-based
+architecture in a single-process application. It is pure Python and works on
+Python 3.3+. It is centered on the notion of a topic; senders publish messages
+of a given topic, and listeners subscribe to messages of a given topic, all
+inside the same process. The package also supports a variety of advanced
+features that facilitate debugging and maintaining topics and messages in larger
+desktop- or server-based applications.