aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2022-09-30 17:02:48 +0000
committerXin LI <delphij@FreeBSD.org>2022-09-30 22:28:03 +0000
commit82665ce295c0cdd2494bf09356d169ef28442a0a (patch)
tree8794f9091bec69df9d4aae1deb0469f34b5d6ed6
parentcd28784c67bfe64bd95afc8136732dba6750bf27 (diff)
downloadports-82665ce295c0cdd2494bf09356d169ef28442a0a.tar.gz
ports-82665ce295c0cdd2494bf09356d169ef28442a0a.zip
sysutils/e2fsprogs: Fix qsort_r detection for POSIX qsort_r(3).
PR: ports/266227 Exp-run by: antoine Approved by: portmgr
-rw-r--r--sysutils/e2fsprogs/Makefile2
-rw-r--r--sysutils/e2fsprogs/files/patch-lib_support_sort__r.h21
2 files changed, 22 insertions, 1 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index f45b04a5762e..9a89d8de14f6 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -13,7 +13,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.46.5
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= sysutils
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
diff --git a/sysutils/e2fsprogs/files/patch-lib_support_sort__r.h b/sysutils/e2fsprogs/files/patch-lib_support_sort__r.h
new file mode 100644
index 000000000000..dec89ce8ef9a
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-lib_support_sort__r.h
@@ -0,0 +1,21 @@
+--- lib/support/sort_r.h.orig 2021-12-30 05:54:33 UTC
++++ lib/support/sort_r.h
+@@ -25,7 +25,8 @@ void sort_r(void *base, size_t nel, size_t width,
+ #define _SORT_R_INLINE inline
+
+ #if (defined __gnu_hurd__ || defined __GNU__ || \
+- defined __linux__ || defined __MINGW32__ || defined __GLIBC__)
++ defined __linux__ || defined __MINGW32__ || defined __GLIBC__ || \
++ defined qsort_r)
+ # define _SORT_R_LINUX
+ #elif (defined __APPLE__ || defined __MACH__ || defined __DARWIN__ || \
+ defined __FreeBSD__ || defined __DragonFly__)
+@@ -263,7 +264,7 @@ static _SORT_R_INLINE void sort_r_simple(void *base, s
+ #if defined _SORT_R_LINUX
+
+ typedef int(* __compar_d_fn_t)(const void *, const void *, void *);
+- extern void qsort_r(void *base, size_t nel, size_t width,
++ extern void (qsort_r)(void *base, size_t nel, size_t width,
+ __compar_d_fn_t __compar, void *arg)
+ __attribute__((nonnull (1, 4)));
+