aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2024-02-12 17:43:18 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2024-02-18 15:11:21 +0000
commit839480a783cf3bfc4d2f442d4c7f315837f5641d (patch)
tree84447f9dcf956eccc2e0e3cc4af48f832ebac63b
parent8df0d56eb4383ec4e86ce578c55a7cdab9854849 (diff)
www/py-dj42-django-auditlog: New port
Django app that keeps a log of changes made to an object
-rw-r--r--www/Makefile1
-rw-r--r--www/py-dj42-django-auditlog/Makefile26
-rw-r--r--www/py-dj42-django-auditlog/distinfo3
-rw-r--r--www/py-dj42-django-auditlog/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index dc33108d5025..755157508c8e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1490,6 +1490,7 @@
SUBDIR += py-daphne
SUBDIR += py-dj-database-url
SUBDIR += py-dj42-django-allauth
+ SUBDIR += py-dj42-django-auditlog
SUBDIR += py-dj42-django-auth-ldap
SUBDIR += py-dj42-django-compression-middleware
SUBDIR += py-dj42-django-cors-headers
diff --git a/www/py-dj42-django-auditlog/Makefile b/www/py-dj42-django-auditlog/Makefile
new file mode 100644
index 000000000000..b5c810461086
--- /dev/null
+++ b/www/py-dj42-django-auditlog/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= django-auditlog
+PORTVERSION= 2.3.0
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj42-
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Django app that keeps a log of changes made to an object
+WWW= https://github.com/jazzband/django-auditlog
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django42>=2.2:www/py-django42@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.4.2:devel/py-dateutil@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist pep517
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}*${PORTNAME}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-dj42-django-auditlog/distinfo b/www/py-dj42-django-auditlog/distinfo
new file mode 100644
index 000000000000..c4d6ad6233fe
--- /dev/null
+++ b/www/py-dj42-django-auditlog/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1707579871
+SHA256 (django-auditlog-2.3.0.tar.gz) = b9d3acebb64f3f2785157efe3f2f802e0929aafc579d85bbfb9827db4adab532
+SIZE (django-auditlog-2.3.0.tar.gz) = 51768
diff --git a/www/py-dj42-django-auditlog/pkg-descr b/www/py-dj42-django-auditlog/pkg-descr
new file mode 100644
index 000000000000..3287e3ab624d
--- /dev/null
+++ b/www/py-dj42-django-auditlog/pkg-descr
@@ -0,0 +1,4 @@
+Auditlog is a reusable app for Django that makes logging object changes a
+breeze. Auditlog tries to use as much as Python and Django's built in
+functionality to keep the list of dependencies as short as possible. Also,
+Auditlog aims to be fast and simple to use.