aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-11-23 15:45:25 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-12-04 11:48:58 +0000
commit83f9c8601b1dfcfc6025ac27c26ea95cd3c47737 (patch)
treec811de17c52c9865d5dbd0fe38e04620154c00f9
parenta03106812ab7f7716f7747bbace2b4aa9db38b6d (diff)
converters/wkhtmltopdf: Always build with default GCC
- Building with the default GCC version (12) always works. - GCC 13, soon to become the default GCC version, also works. - It simplifies the port. - The port will not build with llvm 16. PR: 269313 Approved by: pi (maintainer)
-rw-r--r--converters/wkhtmltopdf/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index bbff58274f82..97a70a82afad 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wkhtmltopdf
PORTVERSION= 0.12.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MAINTAINER= pi@FreeBSD.org
@@ -20,7 +20,8 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
-USES= compiler gmake iconv jpeg perl5 pkgconfig ssl xorg
+USES= gmake iconv jpeg perl5 pkgconfig ssl xorg
+USE_GCC= yes
USE_XORG= x11 xext xrender
USE_PERL5= build
USE_LDCONFIG= yes
@@ -56,10 +57,6 @@ MAKE_ARGS= INSTALL_ROOT="${STAGEDIR}${PREFIX}"
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "powerpc" || ${CHOSEN_COMPILER_TYPE} == gcc
-USE_GCC= 10
-.endif
-
pre-patch:
${RMDIR} ${WRKSRC}/qt
${LN} -s ../qt-${WKQT_TAGNAME} ${WRKSRC}/qt