aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2022-05-08 09:21:44 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2022-05-08 11:00:37 +0000
commit846e6c502da76de2a1c624aeb219898107fbffb5 (patch)
tree7decb59ce1dc8513378c613a6fc10a99a781e8a5
parent3b700c91b790206a594af5ff942c9c99894f7e4c (diff)
downloadports-846e6c502da76de2a1c624aeb219898107fbffb5.tar.gz
ports-846e6c502da76de2a1c624aeb219898107fbffb5.zip
net/rsync: Fix unexpected changes caused by previous rsync commit
* Remove python dependency introduced in last commit, we keep USES=python to fix the rrsync shebang but add PYTHON_NO_DEPENDS=yes since Python itself is not wanted. Add a pkg-message to notify users. * Fix patching issues on manpages and sample files which abusively transformes all etc paths into /usr/local/etc. * Install missing rrsync manpage Also add forgotten items in last commit * version 3.2.4 fixes CVE-2018-25032 in bundled zlib * remove upstreamed patch to fix time limit options (patch-io.c) PR: 263787 PR: 263794 Reported by: <jamie@catflap.org> Reported by: <freebsd@oldach.net> Security: CVE-2018-25032 in the bundled zlib
-rw-r--r--net/rsync/Makefile8
-rw-r--r--net/rsync/pkg-message8
-rw-r--r--net/rsync/pkg-plist1
3 files changed, 15 insertions, 2 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index a558a11d612e..dc13b0c295a3 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rsync
DISTVERSION= 3.2.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://www.mirrorservice.org/sites/rsync.samba.org/src/ \
http://rsync.mirror.garr.it/src/ \
@@ -20,6 +21,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
libzstd.so:archivers/zstd
USES= cpe python shebangfix ssl
+PYTHON_NO_DEPENDS= yes
CPE_VENDOR= samba
CPE_PRODUCT= rsync
USE_RC_SUBR= rsyncd
@@ -88,14 +90,16 @@ CONFIGURE_ARGS+= ac_cv_search_libiconv_open=no
.endif
post-patch:
- @${REINPLACE_CMD} -e 's:/etc/:${ETCDIR}/:g' \
- ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
+ @${REINPLACE_CMD} -e 's:/etc/r{1,2}sync:${ETCDIR}/:g' \
+ -e 's:/etc/letsencrypt:${PREFIX}/etc/letsencrypt:g' \
+ ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
@${REINPLACE_CMD} -e 's|/usr/bin/rsync|${PREFIX}/bin/rsync|g' ${WRKSRC}/support/rrsync
post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${FILESDIR}/rsyncd.conf.sample ${STAGEDIR}${ETCDIR}/
${INSTALL_SCRIPT} ${WRKSRC}/support/rrsync ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/rrsync.1 ${STAGEDIR}${PREFIX}/man/man1/
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net/rsync/pkg-message b/net/rsync/pkg-message
new file mode 100644
index 000000000000..2710aeb697ba
--- /dev/null
+++ b/net/rsync/pkg-message
@@ -0,0 +1,8 @@
+[
+{ type: install
+ message: <<EOM
+Some scripts provided by rsync such as rrsync requires
+python which is not installed by default
+EOM
+}
+]
diff --git a/net/rsync/pkg-plist b/net/rsync/pkg-plist
index 89a3d1f59034..a5ef927bc707 100644
--- a/net/rsync/pkg-plist
+++ b/net/rsync/pkg-plist
@@ -1,6 +1,7 @@
bin/rsync
bin/rsync-ssl
sbin/rrsync
+man/man1/rrsync.1.gz
man/man1/rsync.1.gz
man/man1/rsync-ssl.1.gz
man/man5/rsyncd.conf.5.gz