aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2025-02-06 10:26:50 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2025-02-06 13:11:07 +0000
commit84c1cefbbf7cbe6e08f0c570e2ce88d6aee09cfc (patch)
tree28f4a3f5f403176a77cbca16863a8e863d81b505
parent8b365d28b30d5926db4cb2b02aebf8dd226d21a4 (diff)
emulators/wine-proton: Fix build with GCC 14
Disable warnings about incompatible integer to pointer and pointer to integer conversions, which are treated as errors. This is a lighter version of adding the -fpermissive flag, which has been used to fix other ports failing build with GCC 14. PR: 284488 Approved by: maintainer (Alex S <iwtcex@gmail.com>)
-rw-r--r--emulators/wine-proton/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/wine-proton/Makefile b/emulators/wine-proton/Makefile
index 1915b52c6b1a..30e58d1a6aa7 100644
--- a/emulators/wine-proton/Makefile
+++ b/emulators/wine-proton/Makefile
@@ -96,7 +96,7 @@ CONFIGURE_ARGS= --verbose \
CONFIGURE_ENV= CPPBIN="false" CPPFLAGS="" FLEX="${LOCALBASE}/bin/flex" JXRLIB_CFLAGS="-I${LOCALBASE}/include/jxrlib"
-CFLAGS+= -D__NR_futex="-1" -Werror=implicit-function-declaration
+CFLAGS+= -D__NR_futex="-1" -Werror=implicit-function-declaration -Wno-int-conversion
CFLAGS_i386+= -mpreferred-stack-boundary=4 -mstackrealign
PIE_UNSAFE= yes