aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:06:42 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:06:42 +0000
commit84c433288141f1b708da9542ae7fd90e6272544b (patch)
tree5c08bdf136cdb5cd493d7fe7555b0f0f163b5ad9
parent6f35a7bf121af695812797c5715c25ab174646d9 (diff)
downloadports-84c433288141f1b708da9542ae7fd90e6272544b.tar.gz
ports-84c433288141f1b708da9542ae7fd90e6272544b.zip
net/py-trio-websocket: Add py-trio-websocket 0.10.2
Trio WebSocket implements both server and client aspects of the the WebSocket protocol, striving for safety, correctness, and ergonomics. It is based on the wsproto project, which is a Sans-IO state machine that implements the majority of the WebSocket protocol, including framing, codecs, and events. This library handles I/O using the Trio framework. This library passes the Autobahn Test Suite.
-rw-r--r--net/Makefile1
-rw-r--r--net/py-trio-websocket/Makefile23
-rw-r--r--net/py-trio-websocket/distinfo3
-rw-r--r--net/py-trio-websocket/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e2b24f199b7e..0d589edc29c8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1154,6 +1154,7 @@
SUBDIR += py-tofu
SUBDIR += py-transip
SUBDIR += py-trio
+ SUBDIR += py-trio-websocket
SUBDIR += py-tweepy
SUBDIR += py-twitter-tools
SUBDIR += py-txamqp
diff --git a/net/py-trio-websocket/Makefile b/net/py-trio-websocket/Makefile
new file mode 100644
index 000000000000..dd66e862e96f
--- /dev/null
+++ b/net/py-trio-websocket/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= trio-websocket
+PORTVERSION= 0.10.2
+CATEGORIES= net python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= WebSocket library for Trio
+WWW= https://github.com/HyperionGray/trio-websocket
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}exceptiongroup>=0:devel/py-exceptiongroup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}trio>=0.11:net/py-trio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wsproto>=0.14:net/py-wsproto@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-trio-websocket/distinfo b/net/py-trio-websocket/distinfo
new file mode 100644
index 000000000000..5763d90d81ae
--- /dev/null
+++ b/net/py-trio-websocket/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1684104292
+SHA256 (trio-websocket-0.10.2.tar.gz) = af13e9393f9051111300287947ec595d601758ce3d165328e7d36325135a8d62
+SIZE (trio-websocket-0.10.2.tar.gz) = 26079
diff --git a/net/py-trio-websocket/pkg-descr b/net/py-trio-websocket/pkg-descr
new file mode 100644
index 000000000000..0d6224460bb0
--- /dev/null
+++ b/net/py-trio-websocket/pkg-descr
@@ -0,0 +1,6 @@
+Trio WebSocket implements both server and client aspects of the the WebSocket
+protocol, striving for safety, correctness, and ergonomics. It is based on the
+wsproto project, which is a Sans-IO state machine that implements the majority
+of the WebSocket protocol, including framing, codecs, and events. This library
+handles I/O using the Trio framework. This library passes the Autobahn Test
+Suite.