aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-09 03:05:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-09 03:24:22 +0000
commit85d1c982fae904a1f416820660b71a32f302965f (patch)
tree91eb16a5202e560ca020adae1f85f339d89d3bf8
parent1355fac5a87ad66df739f001ec4a14564a27a99a (diff)
science/py-ipygany: New port: 3-D scientific visualization in Jupyter Notebooks
-rw-r--r--science/Makefile1
-rw-r--r--science/py-ipygany/Makefile25
-rw-r--r--science/py-ipygany/distinfo3
-rw-r--r--science/py-ipygany/pkg-descr16
4 files changed, 45 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index e0461a394c02..5a98d961e81c 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -345,6 +345,7 @@
SUBDIR += py-hiphive
SUBDIR += py-hoomd-blue
SUBDIR += py-inequality
+ SUBDIR += py-ipygany
SUBDIR += py-jupyter_jsmol
SUBDIR += py-kim-query
SUBDIR += py-kimpy
diff --git a/science/py-ipygany/Makefile b/science/py-ipygany/Makefile
new file mode 100644
index 000000000000..873bf96dc592
--- /dev/null
+++ b/science/py-ipygany/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= ipygany
+DISTVERSION= 0.5.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= 3-D scientific visualization in Jupyter Notebooks
+WWW= https://github.com/martinRenou/ipygany
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-packaging>0:devel/py-jupyter-packaging@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipywidgets>0:devel/py-ipywidgets@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traittypes>0:devel/py-traittypes@${PY_FLAVOR} \
+ ${PYNUMPY}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipydatawidgets>0:devel/py-ipydatawidgets@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils concurrent autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-ipygany/distinfo b/science/py-ipygany/distinfo
new file mode 100644
index 000000000000..6876c1258901
--- /dev/null
+++ b/science/py-ipygany/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673223117
+SHA256 (ipygany-0.5.0.tar.gz) = a665e0875bd9500d4f11082770540d46361bd3cfa85b7814e38403c108918b3d
+SIZE (ipygany-0.5.0.tar.gz) = 21814458
diff --git a/science/py-ipygany/pkg-descr b/science/py-ipygany/pkg-descr
new file mode 100644
index 000000000000..519ae6b634b7
--- /dev/null
+++ b/science/py-ipygany/pkg-descr
@@ -0,0 +1,16 @@
+ipygany is a Jupyter Interactive Widgets library for 3-D mesh analysis.
+
+Features:
+ipygany has many features including:
+* VTK loader for displaying your computation results in the Jupyter Notebook
+* Structured and Unstructured grids support
+* 2-D cell based meshes support (quads, triangles...) as well as 3-D cell based
+ meshes support (tetrahedrons, quadratic tetrahedrons...)
+* Animations
+* IsoColor effect
+* Warp effect
+* IsoSurface computation
+* Threshold effect (for visualizing only the parts that are inside of a range
+ of data)
+* Point cloud visualization
+* Water effect, for nice water visualization with real-time caustics