aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-02 23:01:36 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-02-02 23:01:36 +0000
commit8607332fb8268becd08f7e6cfbc853bc76e2cc43 (patch)
tree6769185b315d077bc170e382d1377e599de410a5
parentde6c517f8ee2f37a4e1a68889a79d8fc3151b9c4 (diff)
downloadports-8607332fb8268becd08f7e6cfbc853bc76e2cc43.tar.gz
ports-8607332fb8268becd08f7e6cfbc853bc76e2cc43.zip
www/gitlab-pages: Fix bulk build warning
In the previous commit a duplicate USE_FETCH target was added similar to the one in Mk/Uses/go.mk. However this is possible using a different number and target name compared to what is already predefined as it conflicts. Reported by: bulk build Approved by: portmgr (just-fix-it)
-rw-r--r--www/gitlab-pages/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/gitlab-pages/Makefile b/www/gitlab-pages/Makefile
index 9a97306037d6..da241eeec460 100644
--- a/www/gitlab-pages/Makefile
+++ b/www/gitlab-pages/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gitlab-pages
PORTVERSION= 15.8.1
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www
@@ -29,8 +30,8 @@ MASTER_SITES+= https://gitlab.com/gitlab-org/gitlab-pages/-/raw/v${DISTVERSION}/
DISTFILES+= go.mod
DIST_SUBDIR= go/${PKGORIGIN:S,/,_,g}/${DISTNAME}
EXTRACT_ONLY+= ${DISTFILES:N*.mod\:*:N*.mod:C/:.*//}
-_USES_fetch+= 800:go-post-fetch
-go-post-fetch:
+_USES_fetch+= 900:go-post-fetch-gitlab
+go-post-fetch-gitlab:
@${ECHO_MSG} "===> Fetching ${PORTNAME} dependencies";
@(cd ${DISTDIR}/${DIST_SUBDIR}; \
[ -e go.mod ] || ${RLN} ${GO_MODFILE} go.mod; \