aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-09-24 11:53:25 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-09-24 11:57:56 +0000
commit8611d2f3b64cca532c0ede5b8d63ee6057c0f0c5 (patch)
tree5478f67a183183738b3ccbad83d6f5bfb94905e6
parent6aa75791903534f48af15f960712d3631696f1f2 (diff)
downloadports-8611d2f3b64cca532c0ede5b8d63ee6057c0f0c5.tar.gz
ports-8611d2f3b64cca532c0ede5b8d63ee6057c0f0c5.zip
www/py-dj32-django-graphiql-debug-toolbar: Add new port
This package is an extension for Django Debug Toolbar which enables support for debugging GraphiQL queries in Django Projects. WWW: https://github.com/flavors/django-graphiql-debug-toolbar NB: This port is assigned to Django 3.2 and www/py-django-graphiql-debug-toolbar was used as a template.
-rw-r--r--www/Makefile1
-rw-r--r--www/py-dj32-django-graphiql-debug-toolbar/Makefile22
-rw-r--r--www/py-dj32-django-graphiql-debug-toolbar/distinfo3
-rw-r--r--www/py-dj32-django-graphiql-debug-toolbar/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3269fe0f29f3..0b8c2f140771 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1459,6 +1459,7 @@
SUBDIR += py-dj32-django-cors-headers
SUBDIR += py-dj32-django-debug-toolbar
SUBDIR += py-dj32-django-filter
+ SUBDIR += py-dj32-django-graphiql-debug-toolbar
SUBDIR += py-dj32-django-js-asset
SUBDIR += py-dj32-django-modelcluster
SUBDIR += py-dj32-django-mptt
diff --git a/www/py-dj32-django-graphiql-debug-toolbar/Makefile b/www/py-dj32-django-graphiql-debug-toolbar/Makefile
new file mode 100644
index 000000000000..5c1f9041597d
--- /dev/null
+++ b/www/py-dj32-django-graphiql-debug-toolbar/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= django-graphiql-debug-toolbar
+DISTVERSION= 0.2.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}dj32-
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Django Debug Toolbar for GraphiQL IDE
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2:www/py-django32@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj32-graphene-django>=2.0.0:devel/py-dj32-graphene-django@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj32-django-debug-toolbar>=3.1:www/py-dj32-django-debug-toolbar@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-dj32-django-graphiql-debug-toolbar/distinfo b/www/py-dj32-django-graphiql-debug-toolbar/distinfo
new file mode 100644
index 000000000000..559e6602138b
--- /dev/null
+++ b/www/py-dj32-django-graphiql-debug-toolbar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630337959
+SHA256 (django-graphiql-debug-toolbar-0.2.0.tar.gz) = aec7a9e096594123d9fc359a583da794a0020b5391d941dda584ce1e667e0afd
+SIZE (django-graphiql-debug-toolbar-0.2.0.tar.gz) = 5000
diff --git a/www/py-dj32-django-graphiql-debug-toolbar/pkg-descr b/www/py-dj32-django-graphiql-debug-toolbar/pkg-descr
new file mode 100644
index 000000000000..328c55ac2ba0
--- /dev/null
+++ b/www/py-dj32-django-graphiql-debug-toolbar/pkg-descr
@@ -0,0 +1,4 @@
+This package is an extension for Django Debug Toolbar which enables support
+for debugging GraphiQL queries in Django Projects.
+
+WWW: https://github.com/flavors/django-graphiql-debug-toolbar