aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-08-27 14:01:44 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-08-27 14:08:28 +0000
commit8697e0292acea3afe4b1ffaf3741fbebb0002b60 (patch)
tree1eb4b9122ec6edae771660b28605d7bd5338d014
parente77d0c6195b9504aff9e8651b429b359d246a4f1 (diff)
downloadports-8697e0292acea3afe4b1ffaf3741fbebb0002b60.tar.gz
ports-8697e0292acea3afe4b1ffaf3741fbebb0002b60.zip
textproc/libxml2: update to 2.10.1 release (+)
-rw-r--r--textproc/libxml2/Makefile10
-rw-r--r--textproc/libxml2/distinfo6
-rw-r--r--textproc/libxml2/files/patch-Makefile.in39
-rw-r--r--textproc/libxml2/files/patch-config.h.in7
-rw-r--r--textproc/libxml2/files/patch-configure4
-rw-r--r--textproc/libxml2/files/patch-git-01-b66ce0bba83febe2f4d119097a0391f5d886c3b486
-rw-r--r--textproc/libxml2/pkg-plist152
7 files changed, 32 insertions, 272 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index d1b2b8f2099c..fcc16f538fb6 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libxml2
-DISTVERSION= 2.9.14
+DISTVERSION= 2.10.1
PORTREVISION?= 0
CATEGORIES?= textproc gnome
MASTER_SITES= GNOME/sources/${PORTNAME}/${DISTVERSION:R}/
@@ -31,13 +31,12 @@ TEST_TARGET= check
PLIST_SUB+= LIBVERSION=${DISTVERSION}
# Don't build with Python support unless requested
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --with-html-subdir=${PORTNAME} \
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/share/ \
--with-lzma=/usr \
--${LIBXML2_SLAVE:Dwith:Uwithout}-python${LIBXML2_SLAVE:D=${PYTHON_CMD}:U}
-OPTIONS_DEFINE= DOCS ICU MEM_DEBUG READLINE THREAD_ALLOC
-OPTIONS_DEFAULT= READLINE
+OPTIONS_DEFINE= DOCS ICU MEM_DEBUG READLINE STATIC THREAD_ALLOC
+OPTIONS_DEFAULT= READLINE STATIC
OPTIONS_SUB= yes
MEM_DEBUG_DESC= Memory debugging (DEVELOPERS ONLY!)
@@ -50,6 +49,7 @@ MEM_DEBUG_CONFIGURE_WITH= mem-debug
READLINE_LIB_DEPENDS= libreadline.so:devel/readline
READLINE_CONFIGURE_WITH= history \
readline
+STATIC_CONFIGURE_ENABLE= static
THREAD_ALLOC_CONFIGURE_WITH= thread-alloc
post-patch:
diff --git a/textproc/libxml2/distinfo b/textproc/libxml2/distinfo
index 29f3b2d89177..b22a4f72a66b 100644
--- a/textproc/libxml2/distinfo
+++ b/textproc/libxml2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658072133
-SHA256 (gnome/libxml2-2.9.14.tar.xz) = 60d74a257d1ccec0475e749cba2f21559e48139efba6ff28224357c7c798dfee
-SIZE (gnome/libxml2-2.9.14.tar.xz) = 3129968
+TIMESTAMP = 1661451657
+SHA256 (gnome/libxml2-2.10.1.tar.xz) = 21a9e13cc7c4717a6c36268d0924f92c3f67a1ece6b7ff9d588958a6db9fb9d8
+SIZE (gnome/libxml2-2.10.1.tar.xz) = 2697480
diff --git a/textproc/libxml2/files/patch-Makefile.in b/textproc/libxml2/files/patch-Makefile.in
index ad6ff8409168..5142015394f5 100644
--- a/textproc/libxml2/files/patch-Makefile.in
+++ b/textproc/libxml2/files/patch-Makefile.in
@@ -1,24 +1,24 @@
---- Makefile.in.orig 2021-06-09 19:53:33 UTC
+--- Makefile.in.orig 2022-08-25 18:24:09 UTC
+++ Makefile.in
-@@ -760,7 +760,7 @@ man_MANS = xml2-config.1 libxml.3
- m4datadir = $(datadir)/aclocal
+@@ -708,7 +708,7 @@ runtest_CFLAGS = $(EXTRA_CFLAGS) $(THREAD_CFLAGS)
m4data_DATA = libxml.m4
runtest_SOURCES = runtest.c
+ runtest_CFLAGS = $(EXTRA_CFLAGS) $(THREAD_CFLAGS)
-runtest_LDFLAGS =
+runtest_LDFLAGS = -pthread
runtest_DEPENDENCIES = $(DEPS)
- runtest_LDADD = $(BASE_THREAD_LIBS) $(RDL_LIBS) $(LDADDS)
+ runtest_LDADD = $(BASE_THREAD_LIBS) $(THREAD_LIBS) $(LDADDS)
testrecurse_SOURCES = testrecurse.c
-@@ -808,7 +808,7 @@ testC14N_LDFLAGS =
- testC14N_DEPENDENCIES = $(DEPS)
- testC14N_LDADD = $(LDADDS)
+@@ -741,7 +741,7 @@ testThreads_CFLAGS = $(EXTRA_CFLAGS) $(THREAD_CFLAGS)
+ xmlcatalog_LDADD = $(RDL_LIBS) $(LDADDS)
testThreads_SOURCES = testThreads.c
+ testThreads_CFLAGS = $(EXTRA_CFLAGS) $(THREAD_CFLAGS)
-testThreads_LDFLAGS =
+testThreads_LDFLAGS = -pthread
testThreads_DEPENDENCIES = $(DEPS)
- testThreads_LDADD = $(BASE_THREAD_LIBS) $(LDADDS)
- testURI_SOURCES = testURI.c
-@@ -1285,7 +1285,7 @@ am--depfiles: $(am__depfiles_remade)
+ testThreads_LDADD = $(BASE_THREAD_LIBS) $(THREAD_LIBS) $(LDADDS)
+ testAutomata_SOURCES = testAutomata.c
+@@ -1146,7 +1146,7 @@ am--depfiles: $(am__depfiles_remade)
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(COMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
.c.lo:
@@ -27,21 +27,12 @@
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@@ -1774,7 +1774,7 @@ check-am: all-am
+@@ -1898,7 +1898,7 @@ check: check-recursive
$(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS)
- check: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) check-recursive
--all-am: Makefile $(PROGRAMS) $(LTLIBRARIES) $(SCRIPTS) $(MANS) $(DATA) \
-+all-am: Makefile $(LTLIBRARIES) $(SCRIPTS) $(MANS) $(DATA) \
+ $(MAKE) $(AM_MAKEFLAGS) check-local
+ check: check-recursive
+-all-am: Makefile $(PROGRAMS) $(LTLIBRARIES) $(SCRIPTS) $(DATA) \
++all-am: Makefile $(LTLIBRARIES) $(SCRIPTS) $(DATA) \
config.h
install-binPROGRAMS: install-libLTLIBRARIES
-@@ -1911,7 +1911,7 @@ info: info-recursive
-
- info-am:
-
--install-data-am: install-cmakeDATA install-data-local \
-+install-data-am: install-cmakeDATA \
- install-m4dataDATA install-man install-pkgconfigDATA
-
- install-dvi: install-dvi-recursive
diff --git a/textproc/libxml2/files/patch-config.h.in b/textproc/libxml2/files/patch-config.h.in
index 326dbd57c71e..0ac56e4df62f 100644
--- a/textproc/libxml2/files/patch-config.h.in
+++ b/textproc/libxml2/files/patch-config.h.in
@@ -1,7 +1,8 @@
---- config.h.in.orig 2018-03-05 15:54:17 UTC
+--- config.h.in.orig 2022-08-25 11:16:02 UTC
+++ config.h.in
-@@ -1,5 +1,8 @@
- /* config.h.in. Generated from configure.ac by autoheader. */
+@@ -3,6 +3,9 @@
+ /* A form that will not confuse apibuild.py */
+ #undef ATTRIBUTE_DESTRUCTOR
+/* XXX */
+#define HAVE_VFSCANF
diff --git a/textproc/libxml2/files/patch-configure b/textproc/libxml2/files/patch-configure
index 59a6d53a2ef6..72722092990b 100644
--- a/textproc/libxml2/files/patch-configure
+++ b/textproc/libxml2/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-10-30 19:14:22 UTC
+--- configure.orig 2022-08-25 11:16:02 UTC
+++ configure
-@@ -15525,6 +15525,8 @@ fi
+@@ -15204,6 +15204,8 @@ fi
fi
fi
;;
diff --git a/textproc/libxml2/files/patch-git-01-b66ce0bba83febe2f4d119097a0391f5d886c3b4 b/textproc/libxml2/files/patch-git-01-b66ce0bba83febe2f4d119097a0391f5d886c3b4
deleted file mode 100644
index b5d302151dfe..000000000000
--- a/textproc/libxml2/files/patch-git-01-b66ce0bba83febe2f4d119097a0391f5d886c3b4
+++ /dev/null
@@ -1,86 +0,0 @@
-From b66ce0bba83febe2f4d119097a0391f5d886c3b4 Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Tue, 1 Mar 2022 12:39:02 +0100
-Subject: [PATCH] Don't include ICU headers in public headers
-
-There's no need to make these implementation details public.
----
- configure.ac | 2 --
- encoding.c | 14 ++++++++++++++
- include/libxml/encoding.h | 21 +++------------------
- 3 files changed, 17 insertions(+), 20 deletions(-)
-
-diff --git a/encoding.c b/encoding.c
-index 0847934a..bfa5a304 100644
---- encoding.c
-+++ encoding.c
-@@ -48,6 +48,20 @@
- #include "buf.h"
- #include "enc.h"
-
-+#ifdef LIBXML_ICU_ENABLED
-+#include <unicode/ucnv.h>
-+/* Size of pivot buffer, same as icu/source/common/ucnv.cpp CHUNK_SIZE */
-+#define ICU_PIVOT_BUF_SIZE 1024
-+typedef struct _uconv_t uconv_t;
-+struct _uconv_t {
-+ UConverter *uconv; /* for conversion between an encoding and UTF-16 */
-+ UConverter *utf8; /* for conversion between UTF-8 and UTF-16 */
-+ UChar pivot_buf[ICU_PIVOT_BUF_SIZE];
-+ UChar *pivot_source;
-+ UChar *pivot_target;
-+};
-+#endif
-+
- static xmlCharEncodingHandlerPtr xmlUTF16LEHandler = NULL;
- static xmlCharEncodingHandlerPtr xmlUTF16BEHandler = NULL;
-
-diff --git a/include/libxml/encoding.h b/include/libxml/encoding.h
-index c875af6f..77f137f4 100644
---- include/libxml/encoding.h
-+++ include/libxml/encoding.h
-@@ -27,9 +27,7 @@
- #ifdef LIBXML_ICONV_ENABLED
- #include <iconv.h>
- #endif
--#ifdef LIBXML_ICU_ENABLED
--#include <unicode/ucnv.h>
--#endif
-+
- #ifdef __cplusplus
- extern "C" {
- #endif
-@@ -128,19 +126,6 @@ typedef int (* xmlCharEncodingOutputFunc)(unsigned char *out, int *outlen,
- * Block defining the handlers for non UTF-8 encodings.
- * If iconv is supported, there are two extra fields.
- */
--#ifdef LIBXML_ICU_ENABLED
--/* Size of pivot buffer, same as icu/source/common/ucnv.cpp CHUNK_SIZE */
--#define ICU_PIVOT_BUF_SIZE 1024
--struct _uconv_t {
-- UConverter *uconv; /* for conversion between an encoding and UTF-16 */
-- UConverter *utf8; /* for conversion between UTF-8 and UTF-16 */
-- UChar pivot_buf[ICU_PIVOT_BUF_SIZE];
-- UChar *pivot_source;
-- UChar *pivot_target;
--};
--typedef struct _uconv_t uconv_t;
--#endif
--
- typedef struct _xmlCharEncodingHandler xmlCharEncodingHandler;
- typedef xmlCharEncodingHandler *xmlCharEncodingHandlerPtr;
- struct _xmlCharEncodingHandler {
-@@ -152,8 +137,8 @@ struct _xmlCharEncodingHandler {
- iconv_t iconv_out;
- #endif /* LIBXML_ICONV_ENABLED */
- #ifdef LIBXML_ICU_ENABLED
-- uconv_t *uconv_in;
-- uconv_t *uconv_out;
-+ struct _uconv_t *uconv_in;
-+ struct _uconv_t *uconv_out;
- #endif /* LIBXML_ICU_ENABLED */
- };
-
---
-GitLab
-
diff --git a/textproc/libxml2/pkg-plist b/textproc/libxml2/pkg-plist
index fe7dbf5df243..382f8b64fe39 100644
--- a/textproc/libxml2/pkg-plist
+++ b/textproc/libxml2/pkg-plist
@@ -1,7 +1,6 @@
bin/xml2-config
bin/xmlcatalog
bin/xmllint
-include/libxml2/libxml/DOCBparser.h
include/libxml2/libxml/HTMLparser.h
include/libxml2/libxml/HTMLtree.h
include/libxml2/libxml/SAX.h
@@ -49,67 +48,19 @@ include/libxml2/libxml/xpath.h
include/libxml2/libxml/xpathInternals.h
include/libxml2/libxml/xpointer.h
lib/cmake/libxml2/libxml2-config.cmake
-lib/libxml2.a
+%%STATIC%%lib/libxml2.a
lib/libxml2.so
lib/libxml2.so.2
lib/libxml2.so.%%LIBVERSION%%
-lib/xml2Conf.sh
libdata/pkgconfig/libxml-2.0.pc
man/man1/xml2-config.1.gz
man/man1/xmlcatalog.1.gz
man/man1/xmllint.1.gz
-man/man3/libxml.3.gz
share/aclocal/libxml.m4
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk0.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk1.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk10.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk11.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk12.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk13.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk14.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk15.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk16.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk17.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk18.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk19.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk2.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk20.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk21.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk22.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk23.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk24.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk25.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk26.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk27.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk28.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk29.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk3.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk4.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk5.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk6.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk7.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk8.html
-%%PORTDOCS%%%%DOCSDIR%%/APIchunk9.html
-%%PORTDOCS%%%%DOCSDIR%%/APIconstructors.html
-%%PORTDOCS%%%%DOCSDIR%%/APIfiles.html
-%%PORTDOCS%%%%DOCSDIR%%/APIfunctions.html
-%%PORTDOCS%%%%DOCSDIR%%/APIsymbols.html
-%%PORTDOCS%%%%DOCSDIR%%/DOM.gif
-%%PORTDOCS%%%%DOCSDIR%%/DOM.html
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
-%%PORTDOCS%%%%DOCSDIR%%/Libxml2-Logo-180x168.gif
-%%PORTDOCS%%%%DOCSDIR%%/Libxml2-Logo-90x34.gif
-%%PORTDOCS%%%%DOCSDIR%%/XMLinfo.html
-%%PORTDOCS%%%%DOCSDIR%%/XSLT.html
-%%PORTDOCS%%%%DOCSDIR%%/architecture.html
-%%PORTDOCS%%%%DOCSDIR%%/bugs.html
-%%PORTDOCS%%%%DOCSDIR%%/catalog.html
-%%PORTDOCS%%%%DOCSDIR%%/contribs.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp/general.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp/home.png
%%PORTDOCS%%%%DOCSDIR%%/devhelp/index.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp/left.png
-%%PORTDOCS%%%%DOCSDIR%%/devhelp/libxml2-DOCBparser.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp/libxml2-HTMLparser.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp/libxml2-HTMLtree.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp/libxml2-SAX.html
@@ -160,113 +111,23 @@ share/aclocal/libxml.m4
%%PORTDOCS%%%%DOCSDIR%%/devhelp/right.png
%%PORTDOCS%%%%DOCSDIR%%/devhelp/style.css
%%PORTDOCS%%%%DOCSDIR%%/devhelp/up.png
-%%PORTDOCS%%%%DOCSDIR%%/docs.html
-%%PORTDOCS%%%%DOCSDIR%%/downloads.html
-%%PORTDOCS%%%%DOCSDIR%%/encoding.html
-%%PORTDOCS%%%%DOCSDIR%%/entities.html
-%%PORTDOCS%%%%DOCSDIR%%/example.html
-%%PORTDOCS%%%%DOCSDIR%%/examples/examples.xml
-%%PORTDOCS%%%%DOCSDIR%%/examples/examples.xsl
%%PORTDOCS%%%%DOCSDIR%%/examples/index.html
%%PORTDOCS%%%%DOCSDIR%%/examples/io1.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/io1.res
%%PORTDOCS%%%%DOCSDIR%%/examples/io2.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/io2.res
%%PORTDOCS%%%%DOCSDIR%%/examples/parse1.c
%%PORTDOCS%%%%DOCSDIR%%/examples/parse2.c
%%PORTDOCS%%%%DOCSDIR%%/examples/parse3.c
%%PORTDOCS%%%%DOCSDIR%%/examples/parse4.c
%%PORTDOCS%%%%DOCSDIR%%/examples/reader1.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/reader1.res
%%PORTDOCS%%%%DOCSDIR%%/examples/reader2.c
%%PORTDOCS%%%%DOCSDIR%%/examples/reader3.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/reader3.res
%%PORTDOCS%%%%DOCSDIR%%/examples/reader4.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/reader4.res
-%%PORTDOCS%%%%DOCSDIR%%/examples/test1.xml
-%%PORTDOCS%%%%DOCSDIR%%/examples/test2.xml
-%%PORTDOCS%%%%DOCSDIR%%/examples/test3.xml
%%PORTDOCS%%%%DOCSDIR%%/examples/testWriter.c
%%PORTDOCS%%%%DOCSDIR%%/examples/tree1.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/tree1.res
%%PORTDOCS%%%%DOCSDIR%%/examples/tree2.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/tree2.res
-%%PORTDOCS%%%%DOCSDIR%%/examples/tst.xml
-%%PORTDOCS%%%%DOCSDIR%%/examples/writer.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples/xmllint.c
%%PORTDOCS%%%%DOCSDIR%%/examples/xpath1.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/xpath1.res
%%PORTDOCS%%%%DOCSDIR%%/examples/xpath2.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/xpath2.res
-%%PORTDOCS%%%%DOCSDIR%%/guidelines.html
-%%PORTDOCS%%%%DOCSDIR%%/help.html
-%%PORTDOCS%%%%DOCSDIR%%/html/book1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/home.png
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/left.png
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-DOCBparser.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-HTMLparser.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-HTMLtree.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-SAX.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-SAX2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-c14n.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-catalog.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-chvalid.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-debugXML.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-dict.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-encoding.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-entities.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-globals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-hash.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-lib.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-list.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-nanoftp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-nanohttp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-parser.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-parserInternals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-pattern.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-relaxng.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-schemasInternals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-schematron.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-threads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-tree.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-uri.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-valid.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xinclude.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xlink.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlIO.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlautomata.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlerror.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlexports.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlmemory.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlmodule.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlreader.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlregexp.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlsave.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlschemas.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlschemastypes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlstring.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlunicode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlversion.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xmlwriter.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xpath.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xpathInternals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/libxml-xpointer.html
-%%PORTDOCS%%%%DOCSDIR%%/html/right.png
-%%PORTDOCS%%%%DOCSDIR%%/html/up.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/interface.html
-%%PORTDOCS%%%%DOCSDIR%%/intro.html
-%%PORTDOCS%%%%DOCSDIR%%/library.html
-%%PORTDOCS%%%%DOCSDIR%%/libxml.gif
-%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
-%%PORTDOCS%%%%DOCSDIR%%/news.html
-%%PORTDOCS%%%%DOCSDIR%%/python.html
-%%PORTDOCS%%%%DOCSDIR%%/redhat.gif
-%%PORTDOCS%%%%DOCSDIR%%/searches.html
-%%PORTDOCS%%%%DOCSDIR%%/smallfootonly.gif
-%%PORTDOCS%%%%DOCSDIR%%/structure.gif
-%%PORTDOCS%%%%DOCSDIR%%/threads.html
-%%PORTDOCS%%%%DOCSDIR%%/tree.html
%%PORTDOCS%%%%DOCSDIR%%/tutorial/apa.html
%%PORTDOCS%%%%DOCSDIR%%/tutorial/apb.html
%%PORTDOCS%%%%DOCSDIR%%/tutorial/apc.html
@@ -316,12 +177,5 @@ share/aclocal/libxml.m4
%%PORTDOCS%%%%DOCSDIR%%/tutorial/includexpath.c
%%PORTDOCS%%%%DOCSDIR%%/tutorial/index.html
%%PORTDOCS%%%%DOCSDIR%%/tutorial/ix01.html
-%%PORTDOCS%%%%DOCSDIR%%/upgrade.html
-%%PORTDOCS%%%%DOCSDIR%%/w3c.png
-%%PORTDOCS%%%%DOCSDIR%%/xml.html
-%%PORTDOCS%%%%DOCSDIR%%/xmlcatalog_man.html
-%%PORTDOCS%%%%DOCSDIR%%/xmldtd.html
-%%PORTDOCS%%%%DOCSDIR%%/xmlio.html
+%%PORTDOCS%%%%DOCSDIR%%/xmlcatalog.html
%%PORTDOCS%%%%DOCSDIR%%/xmllint.html
-%%PORTDOCS%%%%DOCSDIR%%/xmlmem.html
-%%PORTDOCS%%%%DOCSDIR%%/xmlreader.html