aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-06-25 16:36:53 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-06-25 16:36:53 +0000
commit86aa24afc629aefb9501fc55b6cdf1b94ce717e3 (patch)
tree93fe55e2a201b78efbd3850401ee4d90e5da046a
parent58b5fdee521ea32eaa8b7b01998d8cd5b88c9bcb (diff)
downloadports-86aa24afc629aefb9501fc55b6cdf1b94ce717e3.tar.gz
ports-86aa24afc629aefb9501fc55b6cdf1b94ce717e3.zip
math/eclib: work-around to build with clang 16
Adding "CXXFLAGS+=-std=c++11" to fix the build on 14-CURRENT. Without that, it fails with this error: In file included from unimod.cc:24: In file included from ./eclib/unimod.h:27: In file included from ./eclib/interface.h:51: ./eclib/templates.h:64:12: error: no member named 'ptr_fun' in namespace 'std' using std::ptr_fun; ~~~~~^ --- interface.lo --- In file included from interface.cc:24: In file included from ./eclib/interface.h:51: ./eclib/templates.h:64:12: error: no member named 'ptr_fun' in namespace 'std' using std::ptr_fun; ~~~~~^ 1 error generated. *** [interface.lo] Error code 1 PR: 271047 Reported by: pkg-fallout
-rw-r--r--math/eclib/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/eclib/Makefile b/math/eclib/Makefile
index 2bba0ad45dd2..528c05998935 100644
--- a/math/eclib/Makefile
+++ b/math/eclib/Makefile
@@ -21,6 +21,7 @@ USES= autoreconf compiler:c++11-lang libtool localbase
OPTIONS_DEFINE= DOCS
+CXXFLAGS+= -std=c++11
LIBS+= "-lm"
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-flint=${LOCALBASE} --with-boost=${LOCALBASE}