aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2024-02-20 20:27:45 +0000
committerRene Ladan <rene@FreeBSD.org>2024-02-20 20:27:45 +0000
commit871eef72050d4bd637a3478718365b4a3626dc19 (patch)
tree2125d0ecdb3833b999c646969a72414d35a48fb2
parent087e74e94f201ee26ab7ef5992806d4854077cec (diff)
downloadports-871eef72050d4bd637a3478718365b4a3626dc19.tar.gz
ports-871eef72050d4bd637a3478718365b4a3626dc19.zip
audio/play: Remove expired port
2024-02-19 audio/play: Upstream vaporized and last release was in 2000
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/play/Makefile39
-rw-r--r--audio/play/distinfo2
-rw-r--r--audio/play/files/patch-encode__riff.c54
-rw-r--r--audio/play/files/patch-play.c10
-rw-r--r--audio/play/pkg-descr2
7 files changed, 1 insertions, 108 deletions
diff --git a/MOVED b/MOVED
index da8ae0507362..eee13163dcb2 100644
--- a/MOVED
+++ b/MOVED
@@ -2991,3 +2991,4 @@ security/sssd-devel|security/sssd2|2024-02-12|Port is stable
audio/taglib-extras||2024-02-17|Incompatible with taglib 2.x and unmaintained upstream since 2015
security/py-pysha3||2024-02-17|Merged into python standard library since version 3.6
graphics/qcustomplot-qt5|graphics/qcustomplot|2024-02-19|Renamed to support flavors
+audio/play||2024-02-20|Has expired: Upstream vaporized and last release was in 2000
diff --git a/audio/Makefile b/audio/Makefile
index e332b72b1163..77214476b00d 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -604,7 +604,6 @@
SUBDIR += plasma6-ocean-sound-theme
SUBDIR += plasma6-oxygen-sounds
SUBDIR += plasma6-plasma-pa
- SUBDIR += play
SUBDIR += playgsf
SUBDIR += playmidi
SUBDIR += playumidi
diff --git a/audio/play/Makefile b/audio/play/Makefile
deleted file mode 100644
index 898bc32a2035..000000000000
--- a/audio/play/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-PORTNAME= play
-PORTVERSION= 1.0
-PORTREVISION= 3
-CATEGORIES= audio
-MASTER_SITES= PORTS_JP
-
-MAINTAINER= bofh@FreeBSD.org
-COMMENT= Simple audio file player
-
-LICENSE= NONE
-
-DEPRECATED= Upstream vaporized and last release was in 2000
-EXPIRATION_DATE= 2024-02-19
-
-USES= uidfix
-
-MAKE_ARGS= CFLAGS="${CFLAGS}" MANDIR="${PREFIX}/share/man/ja/man" BINDIR="${PREFIX}/bin"
-# XXX PIE static libraries are not supported by base system /usr/share/mk
-MAKE_ARGS+= WITHOUT_PIE=true
-
-CONFLICTS= sox
-
-PLIST_FILES= bin/play share/man/ja/man1/play.1.gz
-
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
-CFLAGS+= -Wno-error=int-conversion
-.if ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 )
-CFLAGS+= -Wno-error=incompatible-function-pointer-types
-.endif
-.endif
-
-post-patch:
-.for file in play_audio.c mixer_ctl.c encode_sun.c speed.c
- @${REINPLACE_CMD} '/soundcard\.h/s,machine,sys,' ${WRKSRC}/${file}
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/audio/play/distinfo b/audio/play/distinfo
deleted file mode 100644
index 46289a7e9b34..000000000000
--- a/audio/play/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (play-1.0.tar.gz) = 13d0af4be4e22a267b1b3c195b5bdfaefd1b10d9f51df9c0fa4b25edecbb3d7b
-SIZE (play-1.0.tar.gz) = 6301
diff --git a/audio/play/files/patch-encode__riff.c b/audio/play/files/patch-encode__riff.c
deleted file mode 100644
index 9965314a2953..000000000000
--- a/audio/play/files/patch-encode__riff.c
+++ /dev/null
@@ -1,54 +0,0 @@
---- encode_riff.c.orig 1997-03-25 15:25:07 UTC
-+++ encode_riff.c
-@@ -11,7 +11,7 @@ static char rcsid[] =
- #include <signal.h>
- #include <err.h>
-
--#include <machine/soundcard.h>
-+#include <sys/soundcard.h>
-
- #include "play.h"
- #include "encode_riff.h"
-@@ -74,7 +74,7 @@ int play_riff(char *audio_file, riff_hea
- char *bufp;
- char *device;
- int devfd, filefd;
-- int stat, len, buf_size, format, data_length;
-+ int stat, len, buf_size, format = 0, data_length;
-
- if (!f_hasdsp) {
- fprintf(stderr, "%s: %s: needs DSP for play\n", myname, audio_file);
-@@ -109,7 +109,12 @@ int play_riff(char *audio_file, riff_hea
- warn("%s", device);
- stat = FAIL; goto failplay0;
- }
-+#if 0
-+ /* this (at least under fbsd) means that you want to set play format
-+ * to headerp->sample_size which is a nonsense */
- if (ioctl(devfd, SNDCTL_DSP_SAMPLESIZE, &headerp->sample_size) < 0) {
-+#endif
-+ if (ioctl(devfd, SNDCTL_DSP_SAMPLESIZE, &format) < 0) {
- warn("%s", device);
- stat = FAIL; goto failplay0;
- }
-@@ -121,11 +126,6 @@ int play_riff(char *audio_file, riff_hea
- warn("%s", device);
- stat = FAIL; goto failplay0;
- }
-- /* XXX */
-- if (ioctl(devfd, SNDCTL_DSP_SETFMT, &format) < 0) {
-- warn("%s", device);
-- stat = FAIL; goto failplay0;
-- }
- if (headerp->channels > 1) {
- int ch = headerp->channels;
- if (ioctl(devfd, SNDCTL_DSP_STEREO, &ch) < 0) {
-@@ -163,6 +163,8 @@ int play_riff(char *audio_file, riff_hea
- warn("read");
- stat = FAIL; goto failplay2;
- }
-+/* printf("len = %10d, len = %10d\n", stat, len); */
-+ stat = (len < stat)? len : stat;
- if (write(devfd, bufp, stat) < 0) {
- warn("write");
- stat = FAIL; goto failplay2;
diff --git a/audio/play/files/patch-play.c b/audio/play/files/patch-play.c
deleted file mode 100644
index e8a74e8aa5e8..000000000000
--- a/audio/play/files/patch-play.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- play.c.orig 1997-03-25 15:25:12 UTC
-+++ play.c
-@@ -4,6 +4,7 @@ static char rcsid[] = "$Id: play.c,v 1.7
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include <fcntl.h>
- #include <err.h>
- #include <signal.h>
diff --git a/audio/play/pkg-descr b/audio/play/pkg-descr
deleted file mode 100644
index 1a200961d14d..000000000000
--- a/audio/play/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-play is a command-line based audio player.
-supported formats: RIFF and U-Law.