aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-23 06:00:30 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-10 08:18:13 +0000
commit87d2395554dec5d4f8422971a444bc8118ccdb87 (patch)
tree4f09d2baec3c64987c3bf3a49ca868cb4f3a5d95
parent5e5077f7d5ac99dc50bc2e5ada159a3c557854f3 (diff)
downloadports-87d2395554dec5d4f8422971a444bc8118ccdb87.tar.gz
ports-87d2395554dec5d4f8422971a444bc8118ccdb87.zip
x11/wapanel: add new port
Simple panel/status bar/task bar for your custom stacking Wayland-based desktop. Features: - Good configurability - Config hot reload - Exposed API for writing custom applets - Custom themes with CSS https://firstbober.github.io/wapanel/
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wapanel/Makefile35
-rw-r--r--x11/wapanel/distinfo3
-rw-r--r--x11/wapanel/pkg-descr10
-rw-r--r--x11/wapanel/pkg-plist17
5 files changed, 66 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index fbcdd04cfb00..a225318786a3 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -369,6 +369,7 @@
SUBDIR += virtboard
SUBDIR += virtualgl
SUBDIR += wallutils
+ SUBDIR += wapanel
SUBDIR += waybar
SUBDIR += wayland-logout
SUBDIR += wbar
diff --git a/x11/wapanel/Makefile b/x11/wapanel/Makefile
new file mode 100644
index 000000000000..1882b4052705
--- /dev/null
+++ b/x11/wapanel/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= wapanel
+DISTVERSION= 1.0.2
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Desktop bar for Wayfire and other wlroots compositors
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= toml11>0:devel/toml11 \
+ wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+
+USES= compiler:c++17-lang gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= gdkpixbuf2 gtk30
+GH_ACCOUNT= Firstbober
+MESON_ARGS= -Dsystem_toml11=true
+
+OPTIONS_DEFINE= PULSEAUDIO
+OPTIONS_DEFAULT=PULSEAUDIO
+OPTIONS_SUB= yes
+
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PULSEAUDIO_MESON_TRUE= volume-control
+
+post-patch:
+# Respect PREFIX for *.desktop
+ @${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},' \
+ ${WRKSRC}/src/applets/task-switcher/task_switcher.cc \
+ ${WRKSRC}/thirdparty/xdgpp/xdg.hpp
+
+.include <bsd.port.mk>
diff --git a/x11/wapanel/distinfo b/x11/wapanel/distinfo
new file mode 100644
index 000000000000..88609b56062f
--- /dev/null
+++ b/x11/wapanel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619157630
+SHA256 (Firstbober-wapanel-1.0.2_GH0.tar.gz) = ef6844a3a437a86e8dada9ba561b96475211cd662438467df92a194696fb1b16
+SIZE (Firstbober-wapanel-1.0.2_GH0.tar.gz) = 905639
diff --git a/x11/wapanel/pkg-descr b/x11/wapanel/pkg-descr
new file mode 100644
index 000000000000..6a5879f9e0b9
--- /dev/null
+++ b/x11/wapanel/pkg-descr
@@ -0,0 +1,10 @@
+Simple panel/status bar/task bar for your custom stacking
+Wayland-based desktop.
+
+Features:
+- Good configurability
+- Config hot reload
+- Exposed API for writing custom applets
+- Custom themes with CSS
+
+WWW: https://firstbober.github.io/wapanel/
diff --git a/x11/wapanel/pkg-plist b/x11/wapanel/pkg-plist
new file mode 100644
index 000000000000..e3057e9ef4da
--- /dev/null
+++ b/x11/wapanel/pkg-plist
@@ -0,0 +1,17 @@
+bin/wapanel
+include/wapanel-appletapi/appletapi.h
+lib/libwapanel-appletapi.a
+lib/wapanel/applets/libwapanel-applet-activator.so
+lib/wapanel/applets/libwapanel-applet-app-finder.so
+lib/wapanel/applets/libwapanel-applet-clock.so
+lib/wapanel/applets/libwapanel-applet-separator.so
+lib/wapanel/applets/libwapanel-applet-task-switcher.so
+%%PULSEAUDIO%%lib/wapanel/applets/libwapanel-applet-volume-control.so
+libdata/pkgconfig/wapanel-appletapi.pc
+%%DATADIR%%/3RD_PARTY_LICENSES
+%%DATADIR%%/icons/hicolor/scalable/actions/wapa-account.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/wapa-cog.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/wapa-folder.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/wapa-logo-nocolor-dark.svg
+%%DATADIR%%/wapanel.css
+%%DATADIR%%/wapanel.toml