aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Hall <hsw@bitmark.com>2024-11-27 12:19:45 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-11-27 13:37:52 +0000
commit880b364108f5a935b6e62264a5b6a62428476d99 (patch)
tree00821fe505ffff2b1bc51fe916ab833790c0a841
parent695b5b4a313e9fad8b6d58d53df7334e61205ea2 (diff)
downloadports-880b364108f5a935b6e62264a5b6a62428476d99.tar.gz
ports-880b364108f5a935b6e62264a5b6a62428476d99.zip
net-p2p/litecoin: Update to 0.21.4 and unbreak with recent Boost
Signed-off-by: Christopher Hall <hsw@bitmark.com> Differential Revision: https://reviews.freebsd.org/D47700 PR: 282875
-rw-r--r--net-p2p/litecoin/Makefile6
-rw-r--r--net-p2p/litecoin/distinfo6
-rw-r--r--net-p2p/litecoin/files/patch-src_wallet_bdb.cpp11
-rw-r--r--net-p2p/litecoin/files/patch-src_wallet_walletutil.cpp20
4 files changed, 36 insertions, 7 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 5d36d15846db..1ac6ffa5db77 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -1,7 +1,7 @@
PORTNAME= litecoin
DISTVERSIONPREFIX= v
-DISTVERSION= 0.21.3
-PORTREVISION= 5
+DISTVERSION= 0.21.4
+PORTREVISION= 0
CATEGORIES= net-p2p finance
MAINTAINER= hsw@bitmark.com
@@ -10,8 +10,6 @@ WWW= https://www.litecoin.org/
LICENSE= MIT
-BROKEN= fails to build with boost-1.85+
-
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libfmt.so:devel/libfmt \
libevent.so:devel/libevent
diff --git a/net-p2p/litecoin/distinfo b/net-p2p/litecoin/distinfo
index 5e11ed280f59..8c88d3b095a7 100644
--- a/net-p2p/litecoin/distinfo
+++ b/net-p2p/litecoin/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1711952975
-SHA256 (litecoin-project-litecoin-v0.21.3_GH0.tar.gz) = e08642fb1d4ca3891981e6fd39f8c9fbc995d0db8b6b1c3f8f8671de8e120f9a
-SIZE (litecoin-project-litecoin-v0.21.3_GH0.tar.gz) = 6531067
+TIMESTAMP = 1731380372
+SHA256 (litecoin-project-litecoin-v0.21.4_GH0.tar.gz) = ba0922213f69c1b1a1d6c3441c5ea3696b538437533555ab74268f075f0de5d3
+SIZE (litecoin-project-litecoin-v0.21.4_GH0.tar.gz) = 6533051
diff --git a/net-p2p/litecoin/files/patch-src_wallet_bdb.cpp b/net-p2p/litecoin/files/patch-src_wallet_bdb.cpp
new file mode 100644
index 000000000000..931bd04ed14d
--- /dev/null
+++ b/net-p2p/litecoin/files/patch-src_wallet_bdb.cpp
@@ -0,0 +1,11 @@
+--- src/wallet/bdb.cpp 2024-03-28 17:05:26.000000000 +0000
++++ src/wallet/bdb.cpp 2024-11-20 13:23:51.628575000 +0000
+@@ -627,7 +627,7 @@
+ return false;
+ }
+
+- fs::copy_file(pathSrc, pathDest, fs::copy_option::overwrite_if_exists);
++ fs::copy_file(pathSrc, pathDest, fs::copy_options::overwrite_existing);
+ LogPrintf("copied %s to %s\n", strFile, pathDest.string());
+ return true;
+ } catch (const fs::filesystem_error& e) {
diff --git a/net-p2p/litecoin/files/patch-src_wallet_walletutil.cpp b/net-p2p/litecoin/files/patch-src_wallet_walletutil.cpp
new file mode 100644
index 000000000000..72c1a8374817
--- /dev/null
+++ b/net-p2p/litecoin/files/patch-src_wallet_walletutil.cpp
@@ -0,0 +1,20 @@
+--- src/wallet/walletutil.cpp 2024-03-28 17:05:26.000000000 +0000
++++ src/wallet/walletutil.cpp 2024-11-20 13:28:06.157704000 +0000
+@@ -58,7 +58,7 @@
+ (ExistsBerkeleyDatabase(it->path()) || ExistsSQLiteDatabase(it->path()))) {
+ // Found a directory which contains wallet.dat btree file, add it as a wallet.
+ paths.emplace_back(path);
+- } else if (it.level() == 0 && it->symlink_status().type() == fs::regular_file && ExistsBerkeleyDatabase(it->path())) {
++ } else if (it.depth() == 0 && it->symlink_status().type() == fs::regular_file && ExistsBerkeleyDatabase(it->path())) {
+ if (it->path().filename() == "wallet.dat") {
+ // Found top-level wallet.dat btree file, add top level directory ""
+ // as a wallet.
+@@ -73,7 +73,7 @@
+ }
+ } catch (const std::exception& e) {
+ LogPrintf("%s: Error scanning %s: %s\n", __func__, it->path().string(), e.what());
+- it.no_push();
++ it.disable_recursion_pending();
+ }
+ }
+