aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2025-02-05 05:08:36 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2025-02-06 05:00:40 +0000
commit88122c70b358d384c2f680cab5e4a81aa7bef8e3 (patch)
tree354c564bec5c7c5fa98bd3dba75420f2f3bb29b1
parented189afb08843f9b4246a380261b30b35a25fcab (diff)
Mk/Uses/samba.mk: Introduce 3 new SAMBA_*_PORT variables
* Introduce 3 new variable, SAMBA_TALLOC_PORT, SAMBA_TDB_PORT and SAMBA_TEVENT_PORT. Proper port origin ("databases/ldb29" for example) is assigned to them depending on the value of SAMBA_DEFAULT. They are intended to be used by ports that works with Samba to specify proper version of talloc, tdb and/or tevent as dependency. * Add item in CHANGES. Reviewed by: 0mp, kiwi Differential Revision: https://reviews.freebsd.org/D48857
-rw-r--r--CHANGES21
-rw-r--r--Mk/Uses/samba.mk12
2 files changed, 33 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 987c8d898ffd..a6af122cf8f1 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,27 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20250205:
+AUTHOR: yasu@FreeBSD.org
+
+ 3 new variables are defined if you add 'USES=samba' in Makefile.
+
+ * SAMBA_TALLOC_PORT
+ * SAMBA_TDB_PORT
+ * SAMBA_TEVENT_PORT
+
+ They are intended to be used by ports that works with Samba to
+ specify proper version of talloc, tdb and/or tevent as dependency
+ such as bellow.
+
+ LIB_DEPENDS= ibtalloc.so:${SAMBA_TALLOC_PORT} \
+ libtdb.so:${SAMBA_TDB_PORT} \
+ libtevent.so:${SAMBA_TEVENT_PORT}
+ USES= samba:env
+
+ You need not use them if port just depends on talloc, tdb and/or
+ tevent and it has nothing to do with Samba.
+
20250203:
AUTHOR: yasu@FreeBSD.org
diff --git a/Mk/Uses/samba.mk b/Mk/Uses/samba.mk
index 3f442b434227..fb949887c604 100644
--- a/Mk/Uses/samba.mk
+++ b/Mk/Uses/samba.mk
@@ -26,15 +26,27 @@ SAMBA_SUFFIX= ${SAMBA_DEFAULT:S/.//}
SAMBA_PORT_416= net/samba416
SAMBA_LDB_PORT_416= databases/ldb25
+SAMBA_TALLOC_PORT_416= devel/talloc
+SAMBA_TDB_PORT_416= databases/tdb
+SAMBA_TEVENT_PORT_416= devel/tevent
SAMBA_PORT_419= net/samba419
SAMBA_LDB_PORT_419= databases/ldb28
+SAMBA_TALLOC_PORT_419= devel/talloc
+SAMBA_TDB_PORT_419= databases/tdb
+SAMBA_TEVENT_PORT_419= devel/tevent
SAMBA_PORT_420= net/samba420
SAMBA_LDB_PORT_420= databases/ldb29
+SAMBA_TALLOC_PORT_420= devel/talloc242
+SAMBA_TDB_PORT_420= databases/tdb1410
+SAMBA_TEVENT_PORT_420= devel/tevent016
SAMBA_PORT= ${SAMBA_PORT_${SAMBA_SUFFIX}}
SAMBA_INCLUDEDIR= ${LOCALBASE}/include/samba4
SAMBA_LIBDIR= ${LOCALBASE}/lib/samba4
SAMBA_LDB_PORT= ${SAMBA_LDB_PORT_${SAMBA_SUFFIX}}
+SAMBA_TALLOC_PORT= ${SAMBA_TALLOC_PORT_${SAMBA_SUFFIX}}
+SAMBA_TDB_PORT= ${SAMBA_TDB_PORT_${SAMBA_SUFFIX}}
+SAMBA_TEVENT_PORT= ${SAMBA_TEVENT_PORT_${SAMBA_SUFFIX}}
. if ${samba_ARGS:Mbuild}
BUILD_DEPENDS+= smbd:${SAMBA_PORT}