aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-08-18 16:38:43 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-08-18 17:34:13 +0000
commit88bf11770da081038e6059fc030676a8a02bd359 (patch)
tree7cae490a6b4f70dc549e5e520fde62d6ff784ddc
parentfb40173923789263a57d3a9a393f220b73a72c70 (diff)
downloadports-88bf11770da081038e6059fc030676a8a02bd359.tar.gz
ports-88bf11770da081038e6059fc030676a8a02bd359.zip
x11-toolkits/gtksourceview2: Fix plist
Fix plist issue reported using Poudriere Approved by: portmgr (blanket, build fix) Sponsored by: Blinkinblox
-rw-r--r--x11-toolkits/gtksourceview2/Makefile24
-rw-r--r--x11-toolkits/gtksourceview2/pkg-plist32
2 files changed, 45 insertions, 11 deletions
diff --git a/x11-toolkits/gtksourceview2/Makefile b/x11-toolkits/gtksourceview2/Makefile
index fbcccbb52749..c125b63cb0b2 100644
--- a/x11-toolkits/gtksourceview2/Makefile
+++ b/x11-toolkits/gtksourceview2/Makefile
@@ -1,23 +1,25 @@
PORTNAME= gtksourceview2
-PORTVERSION= 2.10.5
-PORTREVISION?= 9
+DISTVERSION= 2.10.5
+PORTREVISION= 9
CATEGORIES= x11-toolkits gnome
-MASTER_SITES= GNOME/sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
+MASTER_SITES= GNOME/sources/${PORTNAME:S/2$//}/${DISTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DISTNAME= ${PORTNAME:S/2$//}-${DISTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Widget that adds syntax highlighting to GtkTextView
-USES= tar:bzip2
-
-PORTSCOUT= ignore:1
-
-USES+= gettext gmake gnome libtool localbase pathfix pkgconfig
-USE_LDCONFIG= yes
+USES= gettext gmake gnome libtool localbase pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix gtk20 libxml2 intlhack
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-compile-warnings=no --enable-glade-catalog=no
+
INSTALL_TARGET= install-strip
+PORTSCOUT= ignore:1
+
+CONFIGURE_ARGS= --enable-compile-warnings=no \
+ --enable-glade-catalog=no \
+ --disable-gtk-doc-html
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtksourceview2/pkg-plist b/x11-toolkits/gtksourceview2/pkg-plist
index 75bf801d0479..c6d0293327f4 100644
--- a/x11-toolkits/gtksourceview2/pkg-plist
+++ b/x11-toolkits/gtksourceview2/pkg-plist
@@ -22,6 +22,38 @@ lib/libgtksourceview-2.0.so
lib/libgtksourceview-2.0.so.0
lib/libgtksourceview-2.0.so.0.0.0
libdata/pkgconfig/gtksourceview-2.0.pc
+share/doc/gtksourceview-2.0/GtkSourceBuffer.html
+share/doc/gtksourceview-2.0/GtkSourceCompletion.html
+share/doc/gtksourceview-2.0/GtkSourceCompletionInfo.html
+share/doc/gtksourceview-2.0/GtkSourceCompletionItem.html
+share/doc/gtksourceview-2.0/GtkSourceCompletionProposal.html
+share/doc/gtksourceview-2.0/GtkSourceCompletionProvider.html
+share/doc/gtksourceview-2.0/GtkSourceGutter.html
+share/doc/gtksourceview-2.0/GtkSourceLanguage.html
+share/doc/gtksourceview-2.0/GtkSourceLanguageManager.html
+share/doc/gtksourceview-2.0/GtkSourceMark.html
+share/doc/gtksourceview-2.0/GtkSourcePrintCompositor.html
+share/doc/gtksourceview-2.0/GtkSourceStyle.html
+share/doc/gtksourceview-2.0/GtkSourceStyleScheme.html
+share/doc/gtksourceview-2.0/GtkSourceStyleSchemeManager.html
+share/doc/gtksourceview-2.0/GtkSourceUndoManager.html
+share/doc/gtksourceview-2.0/GtkSourceView.html
+share/doc/gtksourceview-2.0/gtksourceview-2.0-Searching-in-a-GtkSourceBuffer.html
+share/doc/gtksourceview-2.0/gtksourceview-2.0-completioncontext.html
+share/doc/gtksourceview-2.0/gtksourceview-2.0.devhelp
+share/doc/gtksourceview-2.0/gtksourceview-2.0.devhelp2
+share/doc/gtksourceview-2.0/home.png
+share/doc/gtksourceview-2.0/index.html
+share/doc/gtksourceview-2.0/index.sgml
+share/doc/gtksourceview-2.0/lang-reference.html
+share/doc/gtksourceview-2.0/lang-tutorial.html
+share/doc/gtksourceview-2.0/left.png
+share/doc/gtksourceview-2.0/right.png
+share/doc/gtksourceview-2.0/rn01.html
+share/doc/gtksourceview-2.0/rn02.html
+share/doc/gtksourceview-2.0/style-reference.html
+share/doc/gtksourceview-2.0/style.css
+share/doc/gtksourceview-2.0/up.png
share/gtksourceview-2.0/language-specs/R.lang
share/gtksourceview-2.0/language-specs/ada.lang
share/gtksourceview-2.0/language-specs/asp.lang