aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-30 22:02:49 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-30 22:02:49 +0000
commit88fbca657c04c54f92b862556bd84c6404d801af (patch)
tree74233a3e8615020e01ba589fd90d05637c5b5046
parent301ce7554d44c6f1d42e8d1d1f5f758c60e3594c (diff)
downloadports-88fbca657c04c54f92b862556bd84c6404d801af.tar.gz
ports-88fbca657c04c54f92b862556bd84c6404d801af.zip
graphics/geos: Update to 3.10.2
-rw-r--r--graphics/geos/Makefile12
-rw-r--r--graphics/geos/distinfo6
-rw-r--r--graphics/geos/files/patch-tests-geostest-Makefile.in13
-rw-r--r--graphics/geos/files/patch-tests-thread-Makefile.in18
-rw-r--r--graphics/geos/files/patch-tools-CMakeLists.txt11
-rw-r--r--graphics/geos/pkg-plist69
6 files changed, 71 insertions, 58 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index a48356dc805b..09b7a5514ce3 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -1,7 +1,7 @@
# Created by: Leonardo Martins <lmartins@nepe.eee.ufg.br>
PORTNAME= geos
-PORTVERSION= 3.9.2
+PORTVERSION= 3.10.2
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/geos/ \
LOCAL/sunpoet
@@ -12,16 +12,12 @@ COMMENT= Geometry Engine, Open Source
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lang gmake libtool tar:bzip2
+USES= cmake compiler:c++11-lang tar:bzip2
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-TEST_TARGET= check
+CMAKE_OFF= BUILD_BENCHMARKS DISABLE_GEOS_INLINE
+CMAKE_ON= BUILD_SHARED_LIBS
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
-post-configure:
- @${FIND} ${WRKSRC} -name Makefile -exec ${REINPLACE_CMD} -e '/CXXFLAGS = / s| -O2||' {} +
-
.include <bsd.port.mk>
diff --git a/graphics/geos/distinfo b/graphics/geos/distinfo
index d9a49414a183..7b040c549cb2 100644
--- a/graphics/geos/distinfo
+++ b/graphics/geos/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643970986
-SHA256 (geos-3.9.2.tar.bz2) = 44a5a9be21d7d473436bf621c2ddcc3cf5a8bbe3c786e13229618a3b9d861297
-SIZE (geos-3.9.2.tar.bz2) = 4775911
+TIMESTAMP = 1646057841
+SHA256 (geos-3.10.2.tar.bz2) = 50bbc599ac386b4c2b3962dcc411f0040a61f204aaef4eba7225ecdd0cf45715
+SIZE (geos-3.10.2.tar.bz2) = 6714655
diff --git a/graphics/geos/files/patch-tests-geostest-Makefile.in b/graphics/geos/files/patch-tests-geostest-Makefile.in
deleted file mode 100644
index d70e2d84a21c..000000000000
--- a/graphics/geos/files/patch-tests-geostest-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- tests/geostest/Makefile.in.orig 2021-11-01 18:12:44 UTC
-+++ tests/geostest/Makefile.in
-@@ -332,9 +332,8 @@ EXTRA_DIST = \
- testrunner.sh
-
-
--# The -lstdc++ is needed for --disable-shared to work
- geostest_SOURCES = geostest.c
--geostest_LDADD = $(top_builddir)/capi/libgeos_c.la -lstdc++
-+geostest_LDADD = $(top_builddir)/capi/libgeos_c.la
- all: all-am
-
- .SUFFIXES:
diff --git a/graphics/geos/files/patch-tests-thread-Makefile.in b/graphics/geos/files/patch-tests-thread-Makefile.in
deleted file mode 100644
index 7799467bd025..000000000000
--- a/graphics/geos/files/patch-tests-thread-Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- tests/thread/Makefile.in.orig 2021-11-01 18:12:44 UTC
-+++ tests/thread/Makefile.in
-@@ -330,13 +330,11 @@ top_srcdir = @top_srcdir@
- #
- AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/unit/tut -I$(top_builddir)/capi
-
--# The -lstdc++ is needed for --disable-shared to work
- threadtest_SOURCES = threadtest.c
--threadtest_LDADD = $(top_builddir)/capi/libgeos_c.la -lpthread -lstdc++
-+threadtest_LDADD = $(top_builddir)/capi/libgeos_c.la -lpthread
-
--# The -lstdc++ is needed for --disable-shared to work
- badthreadtest_SOURCES = badthreadtest.c
--badthreadtest_LDADD = $(top_builddir)/capi/libgeos_c.la -lpthread -lstdc++
-+badthreadtest_LDADD = $(top_builddir)/capi/libgeos_c.la -lpthread
- all: all-am
-
- .SUFFIXES:
diff --git a/graphics/geos/files/patch-tools-CMakeLists.txt b/graphics/geos/files/patch-tools-CMakeLists.txt
new file mode 100644
index 000000000000..f7a46763edaf
--- /dev/null
+++ b/graphics/geos/files/patch-tools-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- tools/CMakeLists.txt.orig 2022-01-15 21:14:55 UTC
++++ tools/CMakeLists.txt
+@@ -45,7 +45,7 @@ function(configure_install_geos_pc)
+ set(includedir "$\{prefix\}/${CMAKE_INSTALL_INCLUDEDIR}")
+ set(libdir "$\{exec_prefix\}/${CMAKE_INSTALL_LIBDIR}")
+ set(VERSION ${GEOS_VERSION})
+- set(EXTRA_LIBS "-lstdc++")
++ #set(EXTRA_LIBS "-lstdc++")
+ if(HAVE_LIBM)
+ list(APPEND EXTRA_LIBS "-lm")
+ endif()
diff --git a/graphics/geos/pkg-plist b/graphics/geos/pkg-plist
index 561db21f75c9..cf3d44c9299b 100644
--- a/graphics/geos/pkg-plist
+++ b/graphics/geos/pkg-plist
@@ -1,9 +1,10 @@
bin/geos-config
-include/geos.h
+bin/geosop
include/geos/algorithm/Angle.h
include/geos/algorithm/Area.h
include/geos/algorithm/BoundaryNodeRule.h
include/geos/algorithm/CGAlgorithmsDD.h
+include/geos/algorithm/CGAlgorithmsDD.inl
include/geos/algorithm/CentralEndpointIntersector.h
include/geos/algorithm/Centroid.h
include/geos/algorithm/ConvexHull.h
@@ -16,15 +17,18 @@ include/geos/algorithm/InteriorPointPoint.h
include/geos/algorithm/Intersection.h
include/geos/algorithm/Length.h
include/geos/algorithm/LineIntersector.h
+include/geos/algorithm/LineIntersector.inl
include/geos/algorithm/MinimumBoundingCircle.h
include/geos/algorithm/MinimumDiameter.h
include/geos/algorithm/NotRepresentableException.h
include/geos/algorithm/Orientation.h
+include/geos/algorithm/PointInRing.h
include/geos/algorithm/PointLocation.h
include/geos/algorithm/PointLocator.h
include/geos/algorithm/RayCrossingCounter.h
include/geos/algorithm/RayCrossingCounterDD.h
include/geos/algorithm/RobustDeterminant.h
+include/geos/algorithm/SimplePointInRing.h
include/geos/algorithm/construct/LargestEmptyCircle.h
include/geos/algorithm/construct/MaximumInscribedCircle.h
include/geos/algorithm/distance/DiscreteFrechetDistance.h
@@ -106,8 +110,10 @@ include/geos/geom/util/GeometryCombiner.h
include/geos/geom/util/GeometryEditor.h
include/geos/geom/util/GeometryEditorOperation.h
include/geos/geom/util/GeometryExtracter.h
+include/geos/geom/util/GeometryFixer.h
include/geos/geom/util/GeometryTransformer.h
include/geos/geom/util/LinearComponentExtracter.h
+include/geos/geom/util/NoOpGeometryOperation.h
include/geos/geom/util/PointExtracter.h
include/geos/geom/util/PolygonExtracter.h
include/geos/geom/util/ShortCircuitedGeometryVisitor.h
@@ -187,6 +193,10 @@ include/geos/index/strtree/STRtree.h
include/geos/index/strtree/SimpleSTRdistance.h
include/geos/index/strtree/SimpleSTRnode.h
include/geos/index/strtree/SimpleSTRtree.h
+include/geos/index/strtree/TemplateSTRNode.h
+include/geos/index/strtree/TemplateSTRNodePair.h
+include/geos/index/strtree/TemplateSTRtree.h
+include/geos/index/strtree/TemplateSTRtreeDistance.h
include/geos/index/sweepline/SweepLineEvent.h
include/geos/index/sweepline/SweepLineIndex.h
include/geos/index/sweepline/SweepLineInterval.h
@@ -196,6 +206,9 @@ include/geos/io/ByteOrderDataInStream.h
include/geos/io/ByteOrderDataInStream.inl
include/geos/io/ByteOrderValues.h
include/geos/io/CLocalizer.h
+include/geos/io/GeoJSON.h
+include/geos/io/GeoJSONReader.h
+include/geos/io/GeoJSONWriter.h
include/geos/io/ParseException.h
include/geos/io/StringTokenizer.h
include/geos/io/WKBConstants.h
@@ -230,8 +243,10 @@ include/geos/noding/MCIndexNoder.inl
include/geos/noding/MCIndexSegmentSetMutualIntersector.h
include/geos/noding/NodableSegmentString.h
include/geos/noding/NodedSegmentString.h
+include/geos/noding/NodedSegmentString.inl
include/geos/noding/Noder.h
include/geos/noding/NodingIntersectionFinder.h
+include/geos/noding/NodingIntersectionFinder.inl
include/geos/noding/NodingValidator.h
include/geos/noding/Octant.h
include/geos/noding/OrientedCoordinateArray.h
@@ -239,6 +254,7 @@ include/geos/noding/ScaledNoder.h
include/geos/noding/SegmentIntersectionDetector.h
include/geos/noding/SegmentIntersector.h
include/geos/noding/SegmentNode.h
+include/geos/noding/SegmentNode.inl
include/geos/noding/SegmentNodeList.h
include/geos/noding/SegmentPointComparator.h
include/geos/noding/SegmentSetMutualIntersector.h
@@ -258,7 +274,6 @@ include/geos/noding/snapround/MCIndexSnapRounder.h
include/geos/noding/snapround/SnapRoundingIntersectionAdder.h
include/geos/noding/snapround/SnapRoundingNoder.h
include/geos/operation/GeometryGraphOperation.h
-include/geos/operation/IsSimpleOp.h
include/geos/operation/buffer/BufferBuilder.h
include/geos/operation/buffer/BufferInputLineSimplifier.h
include/geos/operation/buffer/BufferOp.h
@@ -289,23 +304,24 @@ include/geos/operation/linemerge/LineSequencer.h
include/geos/operation/overlay/EdgeSetNoder.h
include/geos/operation/overlay/ElevationMatrix.h
include/geos/operation/overlay/ElevationMatrixCell.h
-include/geos/operation/overlay/FuzzyPointLocator.h
include/geos/operation/overlay/LineBuilder.h
include/geos/operation/overlay/MaximalEdgeRing.h
include/geos/operation/overlay/MinimalEdgeRing.h
include/geos/operation/overlay/MinimalEdgeRing.inl
-include/geos/operation/overlay/OffsetPointGenerator.h
include/geos/operation/overlay/OverlayNodeFactory.h
include/geos/operation/overlay/OverlayOp.h
-include/geos/operation/overlay/OverlayResultValidator.h
include/geos/operation/overlay/PointBuilder.h
include/geos/operation/overlay/PolygonBuilder.h
include/geos/operation/overlay/snap/GeometrySnapper.h
include/geos/operation/overlay/snap/LineStringSnapper.h
-include/geos/operation/overlay/snap/SnapIfNeededOverlayOp.h
include/geos/operation/overlay/snap/SnapOverlayOp.h
+include/geos/operation/overlay/validate/FuzzyPointLocator.h
+include/geos/operation/overlay/validate/OffsetPointGenerator.h
+include/geos/operation/overlay/validate/OverlayResultValidator.h
include/geos/operation/overlayng/Edge.h
+include/geos/operation/overlayng/Edge.inl
include/geos/operation/overlayng/EdgeKey.h
+include/geos/operation/overlayng/EdgeKey.inl
include/geos/operation/overlayng/EdgeMerger.h
include/geos/operation/overlayng/EdgeNodingBuilder.h
include/geos/operation/overlayng/EdgeSourceInfo.h
@@ -317,9 +333,11 @@ include/geos/operation/overlayng/LineBuilder.h
include/geos/operation/overlayng/LineLimiter.h
include/geos/operation/overlayng/MaximalEdgeRing.h
include/geos/operation/overlayng/OverlayEdge.h
+include/geos/operation/overlayng/OverlayEdge.inl
include/geos/operation/overlayng/OverlayEdgeRing.h
include/geos/operation/overlayng/OverlayGraph.h
include/geos/operation/overlayng/OverlayLabel.h
+include/geos/operation/overlayng/OverlayLabel.inl
include/geos/operation/overlayng/OverlayLabeller.h
include/geos/operation/overlayng/OverlayMixedPoints.h
include/geos/operation/overlayng/OverlayNG.h
@@ -352,23 +370,26 @@ include/geos/operation/relate/RelateNodeGraph.h
include/geos/operation/relate/RelateOp.h
include/geos/operation/sharedpaths/SharedPathsOp.h
include/geos/operation/union/CascadedPolygonUnion.h
-include/geos/operation/union/CascadedUnion.h
include/geos/operation/union/CoverageUnion.h
-include/geos/operation/union/GeometryListHolder.h
include/geos/operation/union/OverlapUnion.h
include/geos/operation/union/PointGeometryUnion.h
include/geos/operation/union/UnaryUnionOp.h
include/geos/operation/union/UnionStrategy.h
include/geos/operation/valid/ConnectedInteriorTester.h
include/geos/operation/valid/ConsistentAreaTester.h
-include/geos/operation/valid/IndexedNestedShellTester.h
+include/geos/operation/valid/IndexedNestedHoleTester.h
+include/geos/operation/valid/IndexedNestedPolygonTester.h
+include/geos/operation/valid/IsSimpleOp.h
include/geos/operation/valid/IsValidOp.h
include/geos/operation/valid/MakeValid.h
-include/geos/operation/valid/QuadtreeNestedRingTester.h
+include/geos/operation/valid/PolygonIntersectionAnalyzer.h
+include/geos/operation/valid/PolygonNode.h
+include/geos/operation/valid/PolygonRing.h
+include/geos/operation/valid/PolygonRingSelfNode.h
+include/geos/operation/valid/PolygonRingTouch.h
+include/geos/operation/valid/PolygonTopologyAnalyzer.h
include/geos/operation/valid/RepeatedPointRemover.h
include/geos/operation/valid/RepeatedPointTester.h
-include/geos/operation/valid/SimpleNestedRingTester.h
-include/geos/operation/valid/SweeplineNestedRingTester.h
include/geos/operation/valid/TopologyValidationError.h
include/geos/planargraph/DirectedEdge.h
include/geos/planargraph/DirectedEdgeStar.h
@@ -385,7 +406,9 @@ include/geos/precision/CommonBitsRemover.h
include/geos/precision/EnhancedPrecisionOp.h
include/geos/precision/GeometryPrecisionReducer.h
include/geos/precision/MinimumClearance.h
+include/geos/precision/PointwisePrecisionReducerTransformer.h
include/geos/precision/PrecisionReducerCoordinateOperation.h
+include/geos/precision/PrecisionReducerTransformer.h
include/geos/precision/SimpleGeometryPrecisionReducer.h
include/geos/profiler.h
include/geos/shape/fractal/HilbertCode.h
@@ -402,6 +425,12 @@ include/geos/simplify/TopologyPreservingSimplifier.h
include/geos/triangulate/DelaunayTriangulationBuilder.h
include/geos/triangulate/IncrementalDelaunayTriangulator.h
include/geos/triangulate/VoronoiDiagramBuilder.h
+include/geos/triangulate/polygon/ConstrainedDelaunayTriangulator.h
+include/geos/triangulate/polygon/PolygonEarClipper.h
+include/geos/triangulate/polygon/PolygonHoleJoiner.h
+include/geos/triangulate/polygon/PolygonTriangulator.h
+include/geos/triangulate/polygon/TriDelaunayImprover.h
+include/geos/triangulate/polygon/VertexSequencePackedRtree.h
include/geos/triangulate/quadedge/LastFoundQuadEdgeLocator.h
include/geos/triangulate/quadedge/LocateFailureException.h
include/geos/triangulate/quadedge/QuadEdge.h
@@ -411,6 +440,10 @@ include/geos/triangulate/quadedge/QuadEdgeSubdivision.h
include/geos/triangulate/quadedge/TrianglePredicate.h
include/geos/triangulate/quadedge/TriangleVisitor.h
include/geos/triangulate/quadedge/Vertex.h
+include/geos/triangulate/tri/Tri.h
+include/geos/triangulate/tri/TriEdge.h
+include/geos/triangulate/tri/TriList.h
+include/geos/triangulate/tri/TriangulationBuilder.h
include/geos/unload.h
include/geos/util.h
include/geos/util/Assert.h
@@ -426,13 +459,17 @@ include/geos/util/TopologyException.h
include/geos/util/UniqueCoordinateArrayFilter.h
include/geos/util/UnsupportedOperationException.h
include/geos/util/math.h
+include/geos/vend/include_nlohmann_json.hpp
+include/geos/vend/json.hpp
include/geos/version.h
include/geos_c.h
-lib/libgeos-%%PORTVERSION%%.so
-lib/libgeos.a
+lib/cmake/GEOS/geos-config-version.cmake
+lib/cmake/GEOS/geos-config.cmake
+lib/cmake/GEOS/geos-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/GEOS/geos-targets.cmake
lib/libgeos.so
-lib/libgeos_c.a
+lib/libgeos.so.%%PORTVERSION%%
lib/libgeos_c.so
lib/libgeos_c.so.1
-lib/libgeos_c.so.1.14.3
+lib/libgeos_c.so.1.16.0
libdata/pkgconfig/geos.pc