aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-25 19:18:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-25 19:49:58 +0000
commit8a36470536ffca1024585110d4364ee6a9767ca0 (patch)
tree7734b684dc75f707a803b6ce82018a34ad25832b
parent8638313ddc5fffd2f731bcf15936cbf5b8862b59 (diff)
downloadports-8a36470536ffca1024585110d4364ee6a9767ca0.tar.gz
ports-8a36470536ffca1024585110d4364ee6a9767ca0.zip
security/rubygem-ed2551912: Add rubygem-ed2551912 1.2.4 (copied from rubygem-ed25519)
- Add PORTSCOUT
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-ed2551912/Makefile20
-rw-r--r--security/rubygem-ed2551912/distinfo3
-rw-r--r--security/rubygem-ed2551912/pkg-descr13
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3b45f5824787..a9b98fbaf33f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1089,6 +1089,7 @@
SUBDIR += rubygem-doorkeeper-rails5
SUBDIR += rubygem-doorkeeper-rails50
SUBDIR += rubygem-ed25519
+ SUBDIR += rubygem-ed2551912
SUBDIR += rubygem-encryptor
SUBDIR += rubygem-ezcrypto
SUBDIR += rubygem-googleauth
diff --git a/security/rubygem-ed2551912/Makefile b/security/rubygem-ed2551912/Makefile
new file mode 100644
index 000000000000..9ee259dea817
--- /dev/null
+++ b/security/rubygem-ed2551912/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= ed25519
+PORTVERSION= 1.2.4
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 12
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby binding to the Ed25519 (RFC 8032)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gem
+USE_RUBY= yes
+
+PORTSCOUT= limit:^1\.2\.
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-ed2551912/distinfo b/security/rubygem-ed2551912/distinfo
new file mode 100644
index 000000000000..fcc31a67f16e
--- /dev/null
+++ b/security/rubygem-ed2551912/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527946165
+SHA256 (rubygem/ed25519-1.2.4.gem) = dc62c3491e9484d566519ab2bfca1406c7527694c902e6d05074c3a33ecab3b8
+SIZE (rubygem/ed25519-1.2.4.gem) = 137216
diff --git a/security/rubygem-ed2551912/pkg-descr b/security/rubygem-ed2551912/pkg-descr
new file mode 100644
index 000000000000..75b38424929a
--- /dev/null
+++ b/security/rubygem-ed2551912/pkg-descr
@@ -0,0 +1,13 @@
+ed25519.rb is a Ruby binding to the Ed25519 elliptic curve public-key signature
+system described in RFC 8032.
+
+Two implementations are provided: a MRI C extension which uses the "ref10"
+implementation from the SUPERCOP benchmark suite, and a pure Java version based
+on str4d/ed25519-java.
+
+Ed25519 is one of two notable algorithms implemented atop the Curve25519
+elliptic curve. The x25519 gem is a related project of this one, and implements
+the X25519 Diffie-Hellman key exchange algorithm on the Montgomery form of
+Curve25519.
+
+WWW: https://github.com/RubyCrypto/ed25519