aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-12-09 07:39:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-12-09 07:39:06 +0000
commit8a6f8aa6c19e1751504ed28ecbc7c6a216ab9397 (patch)
treeeecf5efa444f5d50792b559876d2234bf6a957e1
parentfd77d7c00a7f8e575fb7333a22b8f0de51c24ea7 (diff)
downloadports-8a6f8aa6c19e1751504ed28ecbc7c6a216ab9397.tar.gz
ports-8a6f8aa6c19e1751504ed28ecbc7c6a216ab9397.zip
x11-fonts/fnt: New port: Missing font manager for UNIX
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/fnt/Makefile44
-rw-r--r--x11-fonts/fnt/distinfo3
-rw-r--r--x11-fonts/fnt/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 39ef8f235bca..3150648388ab 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -58,6 +58,7 @@
SUBDIR += fira
SUBDIR += firacode
SUBDIR += firago
+ SUBDIR += fnt
SUBDIR += fntsample
SUBDIR += font-adobe-100dpi
SUBDIR += font-adobe-75dpi
diff --git a/x11-fonts/fnt/Makefile b/x11-fonts/fnt/Makefile
new file mode 100644
index 000000000000..1a46590e3fc6
--- /dev/null
+++ b/x11-fonts/fnt/Makefile
@@ -0,0 +1,44 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= fnt
+PORTVERSION= 1.4.1
+CATEGORIES= x11-fonts sysutils
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Missing font manager for UNIX
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= bash:shells/bash \
+ chafa:graphics/chafa \
+ lynx:www/lynx \
+ otfinfo:print/typetools
+
+USES= shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= alexmyczko
+
+SHEBANG_FILES= fnt
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/fnt \
+ share/man/man1/fnt.1.gz
+
+OPTIONS_DEFINE= ZSH
+OPTIONS_DEFAULT= ZSH
+
+ZSH_PLIST_FILES= share/zsh/site-functions/_fnt
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 \
+ ${STAGEDIR}${MANPREFIX}/share/man/man1
+
+do-install-ZSH-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
+ ${INSTALL_DATA} ${WRKSRC}/completions/_fnt \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/fnt/distinfo b/x11-fonts/fnt/distinfo
new file mode 100644
index 000000000000..4e0fbc588536
--- /dev/null
+++ b/x11-fonts/fnt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1638983233
+SHA256 (alexmyczko-fnt-1.4.1_GH0.tar.gz) = 263edd4e3ebd71bb5c63e5f063bfbed6a711b5786e6f6174c6ee586e530c1727
+SIZE (alexmyczko-fnt-1.4.1_GH0.tar.gz) = 6949
diff --git a/x11-fonts/fnt/pkg-descr b/x11-fonts/fnt/pkg-descr
new file mode 100644
index 000000000000..c5cf66f2de1b
--- /dev/null
+++ b/x11-fonts/fnt/pkg-descr
@@ -0,0 +1,4 @@
+The missing font manager for UNIX. It helps you to download vector fonts
+from Debian sid, and Google Web Fonts.
+
+WWW: https://github.com/alexmyczko/fnt