aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-07-10 10:17:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-07-10 10:17:10 +0000
commit8aae19b319b01b8c2fd6d15eedb09e999ccb384e (patch)
tree1d3c98c114226fabde9e2fa15e8d43d488e313cf
parent0d2c09e668321a2d20b0c35bf6675f110305ba4c (diff)
graphics/fotocx: the port had been updated to version 24.50
Regenerate three patches so they don't diverge from the actual code too much (context line numbers had got quite a bit off).
-rw-r--r--graphics/fotocx/Makefile2
-rw-r--r--graphics/fotocx/distinfo6
-rw-r--r--graphics/fotocx/files/patch-f.refine.cc14
-rw-r--r--graphics/fotocx/files/patch-fotocx.cc12
-rw-r--r--graphics/fotocx/files/patch-zfuncs.cc32
-rw-r--r--graphics/fotocx/pkg-plist6
6 files changed, 37 insertions, 35 deletions
diff --git a/graphics/fotocx/Makefile b/graphics/fotocx/Makefile
index 2346c5dcd8eb..4174d1b442f5 100644
--- a/graphics/fotocx/Makefile
+++ b/graphics/fotocx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fotocx
-PORTVERSION= 24.40
+PORTVERSION= 24.50
CATEGORIES= graphics
MASTER_SITES= https://kornelix.net/downloads/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/graphics/fotocx/distinfo b/graphics/fotocx/distinfo
index 7edab19f96a9..98e510bd7702 100644
--- a/graphics/fotocx/distinfo
+++ b/graphics/fotocx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1717588456
-SHA256 (fotocx-24.40-source.tar.gz) = ae9bbb1eeb2da4eee0deb4e067c4a9624d6ad80083ba87354182bf3972f4d449
-SIZE (fotocx-24.40-source.tar.gz) = 16036394
+TIMESTAMP = 1719829647
+SHA256 (fotocx-24.50-source.tar.gz) = d147d082b531b367c82ff5af5c86a302f34d29f32765a599f130b8f877610cf4
+SIZE (fotocx-24.50-source.tar.gz) = 16197289
diff --git a/graphics/fotocx/files/patch-f.refine.cc b/graphics/fotocx/files/patch-f.refine.cc
index e5d89fd86bc4..96c86a0ce4fc 100644
--- a/graphics/fotocx/files/patch-f.refine.cc
+++ b/graphics/fotocx/files/patch-f.refine.cc
@@ -1,15 +1,15 @@
---- f.refine.cc.orig 2023-03-01 07:32:06 UTC
+--- f.refine.cc.orig 2024-07-01 07:25:41 UTC
+++ f.refine.cc
-@@ -223,7 +223,7 @@ void m_edit_dist(GtkWidget *, ch *menu)
+@@ -257,7 +257,7 @@ void m_edit_dist(GtkWidget *, ch *menu)
EFedit_dist.Farea = 2; // select area usable
- EFedit_dist.Fpaintedits = 1; // use with paint edits OK 23.50
+ EFedit_dist.Fpaintedits = 1; // use with paint edits OK
EFedit_dist.Fscript = 1; // scripting supported
- EFedit_dist.threadfunc = thread;
+ EFedit_dist.threadfunc = edit_dist_names::thread;
if (! edit_setup(EFedit_dist)) return; // setup edit
-@@ -589,7 +589,7 @@ void m_flatdist(GtkWidget *, ch *menu)
+@@ -653,7 +653,7 @@ void m_flat_dist(GtkWidget *, ch *menu)
EFflatdist.Farea = 2; // select area usable
EFflatdist.Fpaintedits = 1; // use with paint edits OK
EFflatdist.Fscript = 1; // scripting supported
@@ -18,10 +18,10 @@
if (! edit_setup(EFflatdist)) return; // setup edit
-@@ -1067,7 +1067,7 @@ void flatdist_func(int _radius, int _flatten, int _deb
- EFflatdist.menufunc = m_flatdist;
+@@ -1213,7 +1213,7 @@ void flatdist_func(int _radius, int zones[5])
+ EFflatdist.FprevReq = 0;
EFflatdist.Farea = 2; // select area usable
- EFflatdist.Fscript = 1; // scripting supported 23.4
+ EFflatdist.Fscript = 1; // scripting supported
- EFflatdist.threadfunc = thread;
+ EFflatdist.threadfunc = flatdist_names::thread;
diff --git a/graphics/fotocx/files/patch-fotocx.cc b/graphics/fotocx/files/patch-fotocx.cc
index e835b2af32e6..f91cdfe7491a 100644
--- a/graphics/fotocx/files/patch-fotocx.cc
+++ b/graphics/fotocx/files/patch-fotocx.cc
@@ -1,17 +1,17 @@
---- fotocx.cc.orig 2024-02-07 10:14:27 UTC
+--- fotocx.cc.orig 2024-07-01 07:25:41 UTC
+++ fotocx.cc
-@@ -317,7 +317,7 @@ int main(int argc, ch *argv[])
+@@ -335,7 +335,7 @@ int main(int argc, ch *argv[])
// delete fotocx temp files if owner process is no longer running
pidlist = 0;
-- snprintf(buff,200,"pidof fotocx fotocx.x"); // get active fotocx PIDs 23.3
+- snprintf(buff,200,"pidof fotocx fotocx.x"); // get active fotocx PIDs
+ snprintf(buff,200,"pgrep -d\\ fotocx fotocx.x");
fid = popen(buff,"r");
if (fid) {
pp = fgets_trim(buff,200,fid);
-@@ -455,13 +455,15 @@ int main(int argc, ch *argv[])
+@@ -464,13 +464,15 @@ int main(int argc, ch *argv[])
- // get SMP thread count // 23.3
+ // get SMP thread count
- NSMP = 0; // assume at least 4 threads
+ NSMP = get_nprocs();
@@ -23,6 +23,6 @@
if (pp && strmatchN(pp,"CPU(s):",7)) NSMP = atoi(pp+8); // P-cores + E-cores
}
+#endif
- if (NSMP < 1) { // 23.80
+ if (NSMP < 1) {
Plog(1,"cannot get SMP thread count, assume 4 \n");
NSMP = 4;
diff --git a/graphics/fotocx/files/patch-zfuncs.cc b/graphics/fotocx/files/patch-zfuncs.cc
index 8af1fb535815..d75c25d8f7fb 100644
--- a/graphics/fotocx/files/patch-zfuncs.cc
+++ b/graphics/fotocx/files/patch-zfuncs.cc
@@ -1,6 +1,6 @@
---- zfuncs.cc.orig 2023-12-02 22:45:44 UTC
+--- zfuncs.cc.orig 2024-07-01 07:25:41 UTC
+++ zfuncs.cc
-@@ -565,6 +565,7 @@ int zmalloc_test(int64 cc)
+@@ -559,6 +559,7 @@ int zmalloc_test(int64 cc)
double realmemory()
{
@@ -8,7 +8,7 @@
FILE *fid;
ch buff[100], *pp;
double rmem = 0;
-@@ -583,15 +584,45 @@ double realmemory()
+@@ -577,15 +578,45 @@ double realmemory()
}
fclose(fid);
@@ -54,7 +54,7 @@
FILE *fid;
ch buff[100], *pp;
double avmem = 0;
-@@ -616,6 +647,11 @@ double availmemory()
+@@ -610,6 +641,11 @@ double availmemory()
}
fclose(fid);
@@ -66,7 +66,7 @@
return avmem;
}
-@@ -755,7 +791,7 @@ void zappcrash(ch *format, ... )
+@@ -749,7 +785,7 @@ void zappcrash(ch *format, ... )
uname(&unbuff); // get cpu arch. 32/64 bit
arch = unbuff.machine;
@@ -75,7 +75,7 @@
if (fid1) {
ii = fscanf(fid1,"%s %s %s",OS1,OS2,OS3);
pclose(fid1);
-@@ -1060,7 +1096,7 @@ double get_seconds()
+@@ -1062,7 +1098,7 @@ double get_seconds()
timespec time1;
double secs;
@@ -84,7 +84,7 @@
secs = time1.tv_sec;
secs += time1.tv_nsec * 0.000000001;
return secs;
-@@ -1109,7 +1145,7 @@ void logtime_init(ch *text)
+@@ -1111,7 +1147,7 @@ void logtime_init(ch *text)
using namespace logtime_names;
printf("logtime init: %s\n",text);
@@ -93,7 +93,7 @@
return;
}
-@@ -1117,7 +1153,7 @@ void logtime(ch *text)
+@@ -1119,7 +1155,7 @@ void logtime(ch *text)
{
using namespace logtime_names;
@@ -102,7 +102,7 @@
elapsed = time2.tv_sec - time1.tv_sec;
elapsed += 0.000000001 * (time2.tv_nsec - time1.tv_nsec);
time1 = time2;
-@@ -1812,6 +1848,10 @@ int wait_Jthread(pthread_t tid)
+@@ -1808,6 +1844,10 @@ int wait_Jthread(pthread_t tid)
return 0;
}
@@ -113,7 +113,7 @@
/********************************************************************************/
-@@ -1862,7 +1902,7 @@ void set_cpu_affinity(int cpu)
+@@ -1858,7 +1898,7 @@ void set_cpu_affinity(int cpu)
{
int err;
static int ftf = 1, Nsmp;
@@ -122,7 +122,7 @@
if (ftf) { // first call
ftf = 0;
-@@ -1873,7 +1913,8 @@ void set_cpu_affinity(int cpu)
+@@ -1869,7 +1909,8 @@ void set_cpu_affinity(int cpu)
CPU_ZERO(&cpuset);
CPU_SET(cpu,&cpuset);
@@ -132,16 +132,16 @@
if (err) Plog(2,"set_cpu_affinity() %s \n",strerror(errno));
return;
}
-@@ -2274,7 +2315,7 @@ uint diskspace(ch *file)
+@@ -2182,7 +2223,7 @@ uint diskspace(ch *file)
FILE *fid;
- pp = zescape_quotes(file); // 23.4
+ pp = zescape_quotes(file);
- snprintf(command,200,"df --output=avail \"%s\" ",pp);
+ snprintf(command,200,"df -k '%s' | awk '{print $4}'",pp);
zfree(pp);
-
+
fid = popen(command,"r");
-@@ -4135,14 +4176,18 @@ ch * SearchWildCase(ch *wpath, int &uflag)
+@@ -4050,14 +4091,18 @@ ch * SearchWildCase(ch *wpath, int &uflag)
flist and flist[*] are subjects for zfree().
zfind() works for files containing quotes (")
@@ -161,7 +161,7 @@
int ii, jj, err, cc;
glob_t globdata;
ch *pp;
-@@ -6109,9 +6154,16 @@ int zinitapp(ch *appvers, int argc, ch *argv[])
+@@ -6028,9 +6073,16 @@ int zinitapp(ch *appvers, int argc, ch *argv[])
if (argc > 1 && strmatchV(argv[1],"-ver","-v",0)) exit(0); // exit if nothing else wanted
progexe = 0;
diff --git a/graphics/fotocx/pkg-plist b/graphics/fotocx/pkg-plist
index 4c0d07995444..2954fa8e0d30 100644
--- a/graphics/fotocx/pkg-plist
+++ b/graphics/fotocx/pkg-plist
@@ -143,6 +143,7 @@ share/applications/fotocx.desktop
%%DATADIR%%/images/area-blend2.jpg
%%DATADIR%%/images/area-rescale.png
%%DATADIR%%/images/area-rescale2.png
+%%DATADIR%%/images/area_fill.png
%%DATADIR%%/images/batch-change-meta.png
%%DATADIR%%/images/batch-convert.png
%%DATADIR%%/images/batch-copy-move.png
@@ -173,8 +174,6 @@ share/applications/fotocx.desktop
%%DATADIR%%/images/cartoon.jpg
%%DATADIR%%/images/change-alpha.png
%%DATADIR%%/images/choose-captions.png
-%%DATADIR%%/images/chromatic.png
-%%DATADIR%%/images/chromaticA.png
%%DATADIR%%/images/color-mode.png
%%DATADIR%%/images/color-mode2.png
%%DATADIR%%/images/color-negative.jpg
@@ -224,6 +223,7 @@ share/applications/fotocx.desktop
%%DATADIR%%/images/first-index.png
%%DATADIR%%/images/fix-motion-blur.png
%%DATADIR%%/images/fix-motion-blur1.jpg
+%%DATADIR%%/images/flatten-histogram2.png
%%DATADIR%%/images/flatten-photo1.png
%%DATADIR%%/images/flatten-photo2.jpg
%%DATADIR%%/images/flatten-photo3.jpg
@@ -233,6 +233,8 @@ share/applications/fotocx.desktop
%%DATADIR%%/images/folder.png
%%DATADIR%%/images/fotocx-views.jpg
%%DATADIR%%/images/fotocx.png
+%%DATADIR%%/images/fringes.png
+%%DATADIR%%/images/fringesA.png
%%DATADIR%%/images/gallery-screen.png
%%DATADIR%%/images/gallery-sort.png
%%DATADIR%%/images/gallery-view.jpg