aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 00:35:36 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 00:35:36 +0000
commit8aae744d04920573ee2c3c34390c268a05beff39 (patch)
treea2e5cb56a177809b08667889c37022422c6d1d2c
parentd1217544364f5e70e2343dea3bf2c58cdc1c2075 (diff)
downloadports-8aae744d04920573ee2c3c34390c268a05beff39.tar.gz
ports-8aae744d04920573ee2c3c34390c268a05beff39.zip
biology/cd-hit: fix build on powerpc
LLVM on powerpc doesn't have libomp: cdhit-common.c++:36:9: fatal error: 'omp.h' file not found
-rw-r--r--biology/cd-hit/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/biology/cd-hit/Makefile b/biology/cd-hit/Makefile
index 2782ab0e47ac..66331b1d6629 100644
--- a/biology/cd-hit/Makefile
+++ b/biology/cd-hit/Makefile
@@ -18,6 +18,12 @@ SHEBANG_FILES= ${WRKSRC}/*.pl
MAKE_FLAGS= openmp=yes
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e 's|/bin/bash|${LOCALBASE}/bin/bash|g' \