aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-26 21:08:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-26 21:50:03 +0000
commit8b23284b8fca0c6934cf158459359c8dff2be61a (patch)
treea8744906bdcdceaca20bf703d56672c973c728ec
parent2f67ed1a0cbee7fe3bd94845b834e0a98108b966 (diff)
downloadports-8b23284b8fca0c6934cf158459359c8dff2be61a.tar.gz
ports-8b23284b8fca0c6934cf158459359c8dff2be61a.zip
misc/py-ascii-magic: New port: Convert pictures into ASCII art
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-ascii-magic/Makefile23
-rw-r--r--misc/py-ascii-magic/distinfo3
-rw-r--r--misc/py-ascii-magic/pkg-descr2
4 files changed, 29 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a3a882914063..876fea1988dc 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -376,6 +376,7 @@
SUBDIR += py-SoapySDR
SUBDIR += py-alive-progress
SUBDIR += py-apache-beam
+ SUBDIR += py-ascii-magic
SUBDIR += py-boost-histogram
SUBDIR += py-cinder
SUBDIR += py-colorbrewer
diff --git a/misc/py-ascii-magic/Makefile b/misc/py-ascii-magic/Makefile
new file mode 100644
index 000000000000..ea1a132e9fd7
--- /dev/null
+++ b/misc/py-ascii-magic/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= ascii-magic
+DISTVERSION= 1.6
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Convert pictures into ASCII art
+WWW= https://github.com/LeandroBarone/python-ascii_magic
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.5+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/misc/py-ascii-magic/distinfo b/misc/py-ascii-magic/distinfo
new file mode 100644
index 000000000000..6316c3e9e6e6
--- /dev/null
+++ b/misc/py-ascii-magic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672088606
+SHA256 (ascii_magic-1.6.tar.gz) = 7da5518f7368e73f11e2151a0c060804aa149e267b369b7ee7653fbd7b046a51
+SIZE (ascii_magic-1.6.tar.gz) = 8661
diff --git a/misc/py-ascii-magic/pkg-descr b/misc/py-ascii-magic/pkg-descr
new file mode 100644
index 000000000000..b7f3f63f0c04
--- /dev/null
+++ b/misc/py-ascii-magic/pkg-descr
@@ -0,0 +1,2 @@
+ascii-magic is a Python package that converts images into ASCII art for
+terminals and HTML.